Jump to content

JavMos

Just Joined
  • Content count

    1
  • Joined

  • Last visited

About JavMos

  • Rank
    InsanelyMac Protégé
  1. Hi. Sorry for my bad English. This is not my work, I'm only put together a lot of guides find around the forums. Hardware: Board: ASUS P5B Deluxe WIFI Procesor: Core 2 Duo E6400 Memory: 2 gigabytes Graphics: Nvidia Gforce 6500 256 Mb SATA: Seagate 250 gb PATA: Western 120 gb Ide: LG DVD writer/reader Working: SATA controller (IDE mode) Pata controller Jmicron 363 Quartz Extreme On-board sound (2 chanel only) On-board Lan 2 Back USB ports Front USB ports Not working: On-board Lan 1 WIFI Install Guide: From a2000rick. Thanks. OSX Installation 1. Change your BIOS settings so that your using AHCI for the intel ICH8R controller (this will be IDE again later) 2. JMicron doesn't work yet so your going to need a USB DVD drive 3. Put in the DVD, when booting press F8 and choose your USB DVD drive 4. Click next, next, next until you get to the desination screen. 5. Open Disk Utilites, and format your free space to HFS Journaled 6. Install OSX w/ JaS.10.4.8.Combo.Update, INTEL.SSE3.mifki, INTEL.ICH8.SATA.Support,VIAATA support, Azaliasound 7. Wait until it reboots 8. Enter your info PATA Controller: JMicron 363 From Julian23, thanks editet /System/Library/Extensions/AppleVIAATA.kext/contents/info.plist: sudo nano /System/Library/Extensions/AppleVIAATA.kext/contents/info.plist then search for: <key>VIA SATA Controller</key> <dict> <key>CFBundleIdentifier</key> <string>com.apple.driver.AppleVIAATA</string> <key>Hardware Name</key> <string>8237 SATA</string> <key>IOClass</key> <string>AppleVIAATARoot</string> <key>IOPCIPrimaryMatch</key> <string>0x2363197B 0x31491106 0x00e310de 0x005410de 0x005510de</string> <key>IOProbeScore</key> <string>1000</string> <key>IOProviderClass</key> <string>IOPCIDevice</string> <key>Serial ATA</key> <true/> </dict> add the vendor and device id marked in red. edit /System/Library/Extensions/AppleAHCIPort.kext/Contents/Info.plist: sudo nano /System/Library/Extensions/AppleAHCIPort.kext/Contents/Info.plist then search for <key>GenericAHCI</key> <dict> <key>CFBundeIdentifier</key> <string>com.apple.driver.AppleAHCIPort</string> <key>IOClass</key> <string>AppleAHCI</string> <key>IOPCIClassMatch</key> <string>0x2363197B</string> <key>IOProbeScore</key> <integer>800</integer> <key>IOProviderClass</key> <string>IOPCIDevice</string> <key>Vendor Name</key> <string>Generic AHCI</string> </dict> change the vendor and device id to the value marked in red. then do the usual things: sudo rm -rf /System/Library/Extensions.kextcache sudo rm -rf /System/Library/Extensions.mkext kextcache -k /System/library/Extensions Reboot If all go ok, now you can use yor PATA and IDE DVD Nvidia: Thanks to the Project Titan.kext Go to this site: http://omni.starchaser.org/titan/ and download the titan.kext (ther is in a link named November 4, 2006) to your desktop and unzip it. 1) Put Titan kext in your /System/Library/Extensions/ folder 2) Correct the file premissions: sudo chown -R root:wheel /System/Library/Extensions/Titan.kext sudo chmod -R 755 /System/Library/Extensions/Titan.kext 3) Remove the cached and packed extensions: sudo rm -f /System/Library/Extensions.mkext sudo rm -f/System/Library/Extensions.kextcache 4) sync and reboot. LAN: Copy from braveskunk. Thanks Conect the cable to the second LAN port 1. download skgw.kext from here:http://forum.insanelymac.com/index.php?showtopic=15700&st=0 2. save it somewhere<sorry for my stupid comments but i'm so happy;p 3. unzip it 4. place it for example on desktop 5. open terminal 6. type sudo -s and press enter 7. type your password and press enter note: if you unzipped it to your desktop,then type: 8. type: cd desktop and press enter(return key) if somewhere else it's good to know how to navigate thru folders in mac: list files: ls; current folder: pwd; entering folder: cd folder_name; changing to root folder:cd /; don't place ";" in commands;p let's move on: 9. mv skge.kext /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns press enter(return key) 10. cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns press enter(return key) 11. chmod -R 755 skge.kext press enter(return key) 12. chown -R root:wheel skge.kext press enter(return key) 13. rm /System/Library/Extensions.mkext press enter(return key) 14. rm /System/Library/Extensions.kextcache press enter(return key) 15. kextcache -k /System/Library/Extensions press enter(return key) 16. reboot WAIT AND ANJOY YOUR NETWORK CONNECTION:) Sound: From a2000rick. Thanks again. On-Board Sound: AD1988 1. Open Terminal and type the following to delete your AppleHDA.kext sudo rm -rf /System/Library/Extensions/AppleHDA.kext 2. Edit your AppleAzaliaAudio.kext sudo nano /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/Info.plist 3. find Realtek ALC880/ALC860 and change the string value to <string>0x11d41988</string> 4. sudo nano /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist 5. find <key>IOPCIPrimaryMatch</key> and change the string value to <string>0x284b8086</string> 6. Fix the permissions and remove cashed kext CODE sudo chown -R root:wheel AppleAzaliaAudio.kext sudo chmod -R 755 AppleAzaliaAudio.kext sudo rm /System/Library/Extensions.kextcache kextcache -k /System/Library/Extensions/ System time Again from a2000rick System Time If your clock is running fast then try this fix 1. In windows download PC Wizard (http://www.cpuid.com/pcwizard.php) 2. Run it, and under Mainboard ->chipset->northbridge find FSB (Mine was 266) (and mine too) 3. Boot into OSX with this parameter: fsb=266 (or whatever yours was) 4. If this fixes the problem edit your com.apple.boot.plist file Its found here: /Library/Preferences/SystemConfiguration 5. in terminal type: sudo nano com.apple.boot.plist 6. add fsb=266 to the Kernal Flags string 7. WriteOut, and Exit 8. type: sudo chown -R root:wheel com.apple.boot.plist sudo chmod -R 755 com.apple.boot.plist 9. Reboot OK that's it for now. Enjoy.
×