Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Just Joined
  • Content count

  • Joined

  • Last visited

About Alterrean

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
  1. After getting my Dell Inspiron 6400 fully operational with MacOS X 10.4.8 I decided that as a way of saying thank you to all the people who made this possible, I was going to write some sort of a guide to help other people to get there too. So, basically I'm gonna just copy here all the procedures i took to get there. 1. You'll need an OS X 10.4.7 JAS DVD image burnt into a DVD. 2. Then you'll need to disable one core from the laptop's BIOS setup. Then of course boot your laptop with it and proceed with the system install. (Remember to check the SS3, GMA950 and Wireless options to get those three things working with just the installation of the OS.) 3. After the installation is complete, we need to upgrade to 10.4.8. The easiest way i found to do this is with mac.nub's guide here http://forum.insanelymac.com/index.php?showtopic=33342. 4. Once we have that update installed and working, it's time to get sound from our mac. In order to do this we will use Taruga's method. Just download the AppleHDAPatcher from this post http://forum.insanelymac.com/index.php?showtopic=32859 and then the codec dump attached at the end of this guide. Just drop the codec dump on the AppleHDAPatcher icon and authenticate to let the program patch the driver. 5. We have now just two problems to solve: Both cores working and the battery fix. To get the battery working, I followed keithpk's tutorial here: http://forum.insanelymac.com/index.php?showtopic=14912 You'll need to reboot your SO in order to get that working. 6. Final step, getting both cores working. To do that, i followed devilhood's tutorial over here: http://forum.insanelymac.com/index.php?showtopic=15474. I used devilhood's suggestion for the Kernel Flag too: <key>Kernel Flags</key> <string>platform=X86PC fn=3 cpus=1 -v</string> 7. Now we just have to go back to our BIOS setup and activate both cores. Now we have everything working! :-D Just in case, I'm pasting here my laptop specifications (I don't know if everything will work with other specs) Intel Core Duo 1.66 GHz Intel GMA950 Wireless card: Minicard DW1390 (BROADCOM CORPORATION) Audio: STAC Sigmatel 9200 Hope that you can find this handy and once again, Thank You all people who worked so hard to get everything working! Stac9200_Dell_6400.txt
  2. AppleHDA Solution - Work in progress

    Hi everyone! I just wanted to thank Taruga for his amazing job. And trexplorer for the codec dump. I have now a fully functional Mac OS X 10.4.8 on my Dell Inspiron 6400. Wireless, Ethernet, video and now sound. Even the system sounds work perfect. Thank you very much! :-D Alterrean