Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About Spartaner25

  • Rank
    InsanelyMac Protégé
  1. I´m at a point, where i copied the 10.6.8 AppleACPIPlatform.kext to my desktop (and want to copy it alter on to S/L/E) just to get the battery workking. But, i don´t know why, i saw, that 18seven tried with his Asus U36sd to get battery working, too. But he uses less code then Jingu, and neither he divided the registers into 8 bit nor uses B1B2, he just uses SMBUS. But with his changes i get battery percentages (Well, i get an error when i go to the systemprofiler and want to see informations about my battery, but who cares at the moment ). I´ve attached all my dsdts and their diffs from the base dsdt. DSDT.zip
  2. That sounds great, but my notebook has neither a second battery nor a connector for it (Like all N61xx models) And there is one more thing. I´ve searched again in Jingus DSDT after differences and found two other store function he has devided in two 8 bits via B1B2. They are both under the Method (TACH) wich is under Scope (_SB.PCI0.SBRG.EC0) (I´ve attached the diff file.) but even if this looks promising, the error stays the Same . dsdtdiff.zip
  3. Thanks for your fast reply . First i search in google after a explanation for the used methodes but i found nothing except other asus notebook owners who have troubles with their batteries and linux. Then i tried to think logical about what you said/ what i know and what is in the DSDT. If the Methode (BATS) determines if we use a slice battery or not (it couldn´t be if there is a battery or not, that is decided by Method (_STA)), it´s maybe to switch these both Store functions in each methode, but it resulted in the same "Capacity Read Zero" error. If (BSLF) { Store (B1DC, Local0) } Else { Store (B1B2 (BDC0, BDC1), Local0) } But any other change resulted in thousands of errors. Then i searched after similar DSDTs and found the one for the G53 with your comments, but you did not explained the Methode (BATS). And if i look at the DSDT from Jingu i see, that his Methode (BATS) and his Methode (BIF1) etc. is the same. So why is his DSDT working?
  4. I have a small Problem . I´ve modified my DSDT like Jingu explained because the Parts in the DSDT he mentioned looks exactly like mine. But, i get always the error in the log: AppleSmartBattery: Error: Capacity Read Zero (0) And the capacity is show as Zero (Surprise ). I`ve tried to set UseExtendedBatteryInformationMethod to false/true and UseExtendedBatteryInformationMethod to true/false but that did not help. I have attached my unpatched DSDT, my patched DSDT and the *.diff file between the two. Both DSDTs were compiled without an error. DSDT.zip
  5. Chameleon Wizard - Utility for Chameleon.

    I Love this Tool! It was great before, but now it is incredible! I have no words to describe it .
  6. Ati 5730 Full res With QE/CI (have problem not really good)

    I´ve got my EDID over Windows and it´s working great. But there is no way to get it under OSX, i think.
  7. Ati 5730 Full res With QE/CI (have problem not really good)

    My shadows are also stepped, but this is not a great problem for me . And Hicks, did you make a EDID for your Laptop?
  8. Ati 5730 Full res With QE/CI (have problem not really good)

    Does no one have an idea what´s wrong? I´ve alredy tried various Frambuffers(Eulemur,Vervet,Nomascus), and no one worked (Monitor worked perfect, native resolution with forced EDID but No QE/CI). But, i get the promised effect with vervet (In system profiler it looks like there is another monitor attached, but i have only one attached). Problem solved with the installation of 10.7. But thanks for the help .
  9. Ati 5730 Full res With QE/CI (have problem not really good)

    Ok, first thing: I compiled a new bootfile with chameleon v1633. It works like the old one. Download see attachments. Second thing is, i don´t get QE/CI. I have the native screen resolution (Thanks to the EDID-Trick) and the card is recognized in the chameleon boot process: Using PCI-Root-UID value: 0 Framebuffer @0xC0000000 MMIO @0xD0020000 I/O Port @0x0000D000 ROM Addr @0xD0000000 ATI card POSTed, reading VBIOS from legacy space (AtiConfig) Framebuffer set to: Hoolock Nr of ports set to framebuffer's default: 3 ATI Redwood ATI Mobility Radeon HD 5730 1024MB (Hoolock) [1002:68c0] (subsys [1043:1c22]):: PciRoot(0x0)/Pci(0x3,0x0)/Pci(0x0,0x0) and in the system profiler: ATI Mobility Radeon HD 5730: Chipset Model: ATI Mobility Radeon HD 5730 Type: GPU Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 1024 MB Vendor: ATI (0x1002) Device ID: 0x68c0 Revision ID: 0x0000 Displays: Internal LCD Forced EDID: Resolution: 1366 x 768 Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Rotation: Supported Display Connector: Status: No Display Connected Display Connector: Status: No Display Connected I´ve also installed these kexts ,dump my rom and i inserted the following lines in my org.chameleon.Boot.plist: <key>GraphicsEnabler</key> <string>Yes</string> <key>AtiConfig</key> <string>Hoolock</string> <key>UseAtiROM</key> <string>Yes</string> So, why is there no QE/CI ? i386.zip