Jump to content

msll

Members
  • Content count

    42
  • Joined

  • Last visited

About msll

  • Rank
    InsanelyMac Protégé
  1. Hope for AR5007EG?

    Here is the log when run the attached kext on Compaq C770US/10.5.5 vanila with atheros AR5007EG. Everything normal except the scan can not find any network. AirPort_Athr5424ab: Ethernet address 00:1f:**:**:**:** ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 ALF ALERT: sockwall_cntl_updaterules ctl_enqueuedata rts err 55 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67 AirPort: Link Down on en2 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67 unable to reset hardware; hal status 67
  2. Install on the Compaq C714NR?

    For the retail over itakos, I think we are almost there. I installed kalyway 10.5.2-->Jas 10.5.3-->Mac software update 10.5.4. It works good. Then the 10.5.5 out, I used the software update to 10.5.5, It works just fine except the powermanagement which I had to restore anyway due to the hardware issue For Atheros 5006/5007EG, I dont think anyone can make it now. The worst thing is we even can not plug in another wireless card like 4311 because the bios for compaq C700 is no way to hack. If anyone able to find out another wireless card which is working w/o hacking bios. That would be great.
  3. Rebranding an AR5007EG

    10.5.5 did not work too. I've already upgraded to the 10.5.5 yesterday. No improvement for the atheros AR5007EG. So I believe it is our time to forget it. I am looking info to hack the BIOS so I can replace another card. Hope this will save your time
  4. Rebranding an AR5007EG

    I own an atheros AR5007EG too. But I personally believe the rebranding will not work for this card. The problem is not caused by this device ID or vendor ID. It is caused by the "Atheros Hardware Access Layer (HAL)". Unless Apple update their wireless drivers to include the latest HAL, this card will never works under mac os. I started to try rebranding couple weeks ago. But I now give up. I believe it will not work. But I wish you good luck!
  5. Just finished installing Kalway 10.5.2-->Jas 10.5.3 combo update-->software update to 10.5.4 from Apple. The integrated card reader just works OOB. Now the only thing completely failed is wireless (atheros ar5007EG)
  6. attached is the ath_info from ubuntu 8.04. I don't know if it is helpful. Please note I masked the mac address for safety issue -==Device Information==- MAC Revision: 2425 (0xe2) Device type: 3 /============== EEPROM Information =============\ | EEPROM Version: 5.3 | EEPROM Size: 4 kbit | | EEMAP: 2 | Reg. Domain: 0x64 | |================= Capabilities ================| | 802.11a Support: no | Turbo-A disabled: yes | | 802.11b Support: no | Turbo-G disabled: yes | | 802.11g Support: yes | 2GHz XR disabled: yes | | RFKill Support: yes | 5GHz XR disabled: yes | | 32kHz Crystal: no | | \===============================================/ /=========================================================\ | Calibration data common for all modes | |=========================================================| | CCK/OFDM gain delta: 1 | | CCK/OFDM power delta: 5 | | Scaled CCK delta: 5 | | 2GHz Antenna gain: 0 | | 5GHz Antenna gain: 0 | | Turbo 2W maximum dBm: 38 | | Target power start: 0x16e | | EAR Start: 0x1b8 | \=========================================================/ /=========================================================\ | Calibration data for 802.11g operation | |=========================================================| | I power: 0x00 | Q power: 0x10 | | Use fixed bias: 0x01 | Max turbo power: 0x26 | | Max XR power: 0x1e | Switch Settling Time: 0x28 | | Tx/Rx attenuation: 0x19 | TX end to XLNA On: 0x00 | | TX end to XPA Off: 0x00 | TX end to XPA On: 0x0e | | 62db Threshold: 0x1c | XLNA gain: 0x00 | | XPD: 0x01 | XPD gain: 0x0a | | I gain: 0x00 | Tx/Rx margin: 0x01 | | False detect backoff: 0x00 | Noise Floor Threshold: -1 | | ADC desired size: -38 | PGA desired size: -80 | |=========================================================| | Antenna control 0: 0x00 | Antenna control 1: 0x02 | | Antenna control 2: 0x21 | Antenna control 3: 0x21 | | Antenna control 4: 0x00 | Antenna control 5: 0x00 | | Antenna control 6: 0x01 | Antenna control 7: 0x22 | | Antenna control 8: 0x22 | Antenna control 9: 0x00 | | Antenna control 10: 0x00 | Antenna control 11: 0x02 | |=========================================================| | Octave Band 0: 3 | db 0: 3 | | Octave Band 1: 4 | db 1: 4 | | Octave Band 2: 0 | db 2: 0 | | Octave Band 3: 0 | db 3: 0 | \=========================================================/ /============== Per rate power calibration ===========\ | Freq | 6-24Mbit/s | 36Mbit/s | 48Mbit/s | 54Mbit/s | |======|============|==========|===========|==========| | 2412 | 15.00 | 15.00 | 15.00 | 13.01 | |======|============|==========|===========|==========| | 2437 | 15.00 | 15.00 | 15.00 | 13.01 | |======|============|==========|===========|==========| | 2472 | 15.00 | 15.00 | 15.00 | 13.01 | \=====================================================/ /=================== Per channel power calibration ====================\ | Freq | pwr_0 | pwr_1 | pwr_2 | pwr_3 |pwrx3_0|pwrx3_1|pwrx3_2|max_pwr| | | pcdac | pcdac | pcdac | pcdac | pcdac | pcdac | pcdac | | |======|=======|=======|=======|=======|=======|=======|=======|=======| | 2412 | 25.00 | 25.00 | 0.00 | 25.00 | 0.00 | 0.00 | 29.01 | 25.00 | | | [112] | [112] | [112] | [112] | [20] | [35] | [63] | | \======================================================================/ GPIO registers: CR 0x00000000, DO 0x00000000, DI 0x0000000b STA_ID0: 00:1f:e1:xx:xx:xx STA_ID1: 0x1a806880, AP: 0, IBSS: 0, KeyCache Disable: 0 TIMER0: 0x00000030, TBTT: 48, TU: 0x00040030 TIMER1: 0x0007ffff, DMAb: 65535, TU: 0x0003ffff (-49) TIMER2: 0x01ffffff, SWBA: 65535, TU: 0x003fffff (+3932111) TIMER3: 0x00000031, ATIM: 49, TU: 0x00040031 (+1) TSF: 0x000000000ef4ce6a, TSFTU: 48435, TU: 0x0003bd33 BEACON: 0x00000000 LAST_TSTP: 0x10040004
  7. Could you list how you patched it in details? As we were told, If your card is still working under windows and your device id is not 001c, you should be able to get it work under mac os by changing the info.plist in AtherosAirport.kext/Contents Device class is the thing I totally have no idea, that's why I did not try my AR5007EG yet. Could anyone help us here?
  8. Kykc, If you look at several posts above * Device Class from 200 to 280 (at 0x85) * Device ID from 001c to 1014 (at 0x82) * Subvendor ID from 1458 to 1014 (at 0x8a) * Subdevice ID from e917 to 058a (at 0x8b) This is the successful rebranding. The original is 168c:001c. He change the Device ID to 1014 and Sub_Device ID to 058a, but at the end he got 168c:058a! Maybe you should try to change your device ID back to original first to make sure the card is working under vista/XP? and then try to change both device ID and subdevice ID? Just my two cents. Here is the list of atheros wireless card with vendor ID 168c and device ID 001c. > 168c:001c:105b:e000 "LAN-Express AS IEEE 802.11g PCI-E Adapter" > 168c:001c:105b:e002 "LAN-Express AS IEEE 802.11g PCI-E Adapter" > 168c:001c:106b:0086 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:106b:0086 "Atheros AR5006X Wireless Network Adapter" Apple Airport extreme > 168c:001c:10cf:139c "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:10cf:142e "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:10e9:1020 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:10e9:1025 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:1113:7519 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:144f:7096 "Atheros AR5006EX Wireless Network Adapter" > 168c:001c:144f:7106 "Atheros AR5006EG Wireless Network Adapter" > 168c:001c:144f:7108 "Atheros AR5006X Wireless Network Adapter" > 168c:001c:144f:7111 "Atheros AR5006EGS Wireless Network Adapter" > 168c:001c:144f:7112 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:144f:7116 "Atheros AR5006X Wireless Network Adapter" > 168c:001c:144f:7128 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:144f:7130 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:144f:7131 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:1468:0422 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:1468:0423 "LAN-Express AS IEEE 802.11g PCI-E Adapter" > 168c:001c:1468:0425 "Atheros AR5006X Wireless Network Adapter" > 168c:001c:1468:0427 "Atheros AR5005G Wireless Network Adapter" > 168c:001c:1468:0428 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:1468:042a "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:168c:0034 "11b/g Wireless LAN Mini PCI Express Adapter II" > 168c:001c:168c:0035 "11b/g Wireless LAN Mini PCI Express Adapter III" > 168c:001c:168c:0423 "LAN-Express AS IEEE 802.11g PCI-E Adapter" > 168c:001c:168c:3061 "Atheros AR5006EGS Wireless Network Adapter" > 168c:001c:168c:3062 "Atheros AR5006EXS Wireless Network Adapter" > 168c:001c:168c:3063 "Atheros AR5006EX Wireless Network Adapter" > 168c:001c:168c:3064 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:168c:3065 "Atheros AR5006EG Wireless Network Adapter" > 168c:001c:168c:3067 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:1a32:0100 "Atheros AR5006EG Wireless Network Adapter" > 168c:001c:1a32:0105 "Atheros AR5007EG Wireless Network Adapter" > 168c:001c:1a32:0200 "Atheros AR5006EX Wireless Network Adapter" > 168c:001c:1a3b:1026 "Atheros AR5007EG Wireless Network Adapter" This is the successful rebranding > 168c:1014:1014:058a "11a/b/g Wireless LAN Mini PCI Express Adapter" Hi, Did your Gigabyte card support 802.11a originally? Could you please tell us why you selected 058a? Did you have some other try? THX!
  9. Atheros Button Troggled WLan

    Micro93, First of all, your wireless card should be atheros AR5007EG, which is not working under mac os x unless you have already rebranded it successfully. ( I don't hear anybody succedd yet) Second, even if your wireless card is working under leopard, let button will be still red instead of blue. I have made this card working under linux but that button did not work at all. Help that explains
  10. Install on the Compaq C714NR?

    Kennyp, could you attach here the pkg from Jas 10.5.4? I might give it a try. I know there are so many people waiting for the driver to make AR4007 work. This wireless card was used in many cheap notebooks. THX!
  11. Install on the Compaq C714NR?

    I have Compaq C770US which was bought recently for $330. The best way to install leopard is: 1) Install Kalyway 10.5.2 for intel and amd distro, do not select any video patch (I have X3100) 2) Update with Jas 10.5.3 combo 3) Use "Software update" to update everything including security and kernel from Apple. (currently is 10.5.4 (9E17)) What I got is basically everything I want including speedsteps, full video with QE/CI. With Xbench 1.3, I got score of 54.19. Details: Results 54.19 System Info Xbench Version 1.3 System Version 10.5.4 (9E17) Physical RAM 2048 MB Model MacBook2,1 Drive Type FUJITSU MHY****BH CPU Test 53.24 GCD Loop 94.04 4.96 Mops/sec Floating Point Basic 45.35 1.08 Gflop/sec vecLib FFT 37.15 1.23 Gflop/sec Floating Point Library 64.44 11.22 Mops/sec Thread Test 125.63 Computation 109.42 2.22 Mops/sec, 4 threads Lock Contention 147.47 6.34 Mlocks/sec, 4 threads Memory Test 110.42 System 108.96 Allocate 230.88 847.88 Kalloc/sec Fill 105.55 5131.95 MB/sec Copy 72.84 1504.55 MB/sec Stream 111.93 Copy 104.83 2165.26 MB/sec Scale 104.84 2165.99 MB/sec Add 120.13 2559.06 MB/sec Triad 119.96 2566.30 MB/sec Quartz Graphics Test 133.20 Line 122.05 8.13 Klines/sec [50% alpha] Rectangle 159.30 47.56 Krects/sec [50% alpha] Circle 129.44 10.55 Kcircles/sec [50% alpha] Bezier 126.91 3.20 Kbeziers/sec [50% alpha] Text 134.00 8.38 Kchars/sec OpenGL Graphics Test 20.07 Spinning Squares 20.07 25.46 frames/sec User Interface Test 141.66 Elements 141.66 650.15 refresh/sec Disk Test 34.50 Sequential 55.60 Uncached Write 57.45 35.28 MB/sec [4K blocks] Uncached Write 62.77 35.51 MB/sec [256K blocks] Uncached Read 43.36 12.69 MB/sec [4K blocks] Uncached Read 64.34 32.34 MB/sec [256K blocks] Random 25.01 Uncached Write 8.76 0.93 MB/sec [4K blocks] Uncached Write 58.30 18.67 MB/sec [256K blocks] Uncached Read 60.58 0.43 MB/sec [4K blocks] Uncached Read 82.35 15.28 MB/sec [256K blocks] Things that do not work right now includes: 1) wireless (Atheros ar5007, which is a no-go.) I use Zydas usb adapter instead 2) Sleep can wakeup, but will not display battery usage unless restart computer But it is ok, I can totally live with it. Leopard is my default OS now. The pre-installed Vista home premium as my backup system. If anybody can make Atheros AR5007 TO WORK. What a wonderful and cheap macbook!
  12. Radeon Xpress 200M

    I am a ATI Radeon Xpress 200M user for a couple of years (Toshiba A105). I actually installed Tiger and Leopard successfully. So I can explain why to you. When you install Tiger, you will see VRAM (total) 16MB. But if you adjust the VRAM to 128M or even 256M in windows XP, and then switch to leopard, you will see the VRAM is the same as your setting in Windows XP, which means 128M or 256M! BTW, in leopard, Xpress 200M will give you software CI, but not really QE/CI working. I hope I carlify your wondering.
  13. Toshiba A105-Install success

    Ok, Wireless is OK now. But I still didn't get X200M video to work, even can not change resolution. Calisto 3 for Tiger didn't work. Anyone help? All the other seems fine.
  14. Toshiba A105-Install success

    Yes. I just deleted my 10.4.9 (uphuck V1.3) on A105-s1013 WHICH HAS ati RADEON XPRESS 200M. Installed this build of leopard without any problem. Very impressive. But My Atheros wireless didn't work yet and I can't change screen resolution. I will figure it out. Thanks!
  15. Toshiba A105-Install success

    Could you tell us your toshiba model number ? A105-XXXXX? Or if you don't know, could you tell us what's your video card? I am wondering if it is ATI xpress 200M. Thank you.
×