Jump to content
About Just Joined group Read more... ×

Conroe Mac

Members
  • Content Count

    487
  • Joined

  • Last visited

Posts posted by Conroe Mac


  1. Is there any progress with the Mobility Radeon HD 3450? No one seems to know anything.. Is it even being worked on or have they given up? Also, none of these package installers are for Mobility cards. Are we even in the right topic? I'm really tired of waiting starting to lose hope.. Have they fixed the Mobility HD 3650 drivers? Surely there can't be much of a diffrent besides changing a few numbers?

     

    I think everyone has given up. I haven't heard anything in weeks.


  2. http://forum.insanelymac.com/index.php?showtopic=89659

     

    This is the thread. It tells you how to install kexts though it's not too great at explaining how to remove them. Basically when Darwin loads, you type "-s" and then hit enter. Then you're in single user mode. This is the same thing as the terminal. You need to remove the offending kext. I will try to explain it without running the actual commands so bear with me. For each step, type what is in quotes and hit return.

     

    1. "sudo -s" This logs you in as super user, you must type in your password after this

    2. "mkdir /problemkexts/" This creates a directory to put our problem kexts in

    3. "mv /System/Library/Extensions/name_of_kext.kext /problemkexts/" The mv is for move and this moves the kext to the directory we created

    4. "rm -rf /System/Library/Extensions.mkext" I believe this clears the kextcache, but I could be mistaken. It's a necessary step.

     

    After you reboot, you should be good to go. In step 3, make sure you use the name of the kext that you are moving. If you are not sure of the name, you can change directories and list the names of all the kexts with the following commands: "cd /System/Library/Extensions/" and then "ls". There's probably a better writeup somewhere else, but this gives you the basic information.

     

    See also this thread for deleting a kext from single user mode:

     

    http://forum.insanelymac.com/index.php?showtopic=41603


  3. As for video...

     

    if anyone has the time to try it, there is a hope on post # 887 here http://forum.insanelymac.com/index.php?sho...7526&hl=ATI 3450&st=880#

     

    I would but tried another one and now only a blue screen... I'll reinstall and then try it if no one else does.

    PS, is there a better way to restore after a bad kext install than to reformat and start all over?

     

    Next time the computer reboots, boot with the -s flag in order to boot in single user mode. Then you can remove the offending kext without reformatting. There's a thread somewhere about how to do it if you aren't too handy with the command line interface.


  4. With great power, comes great responsibility. Quite unfortunate to hear that power corrupted. We were all "noobs" once and the future of linux is in converting the masses not just the technologically savvy.


  5. ATA is supposedly slower. It's an older standard, hence it being used in XP. I'm not so sure there's a big performance difference.

     

    From wikipedia: As their standard interface, SATA controllers use the Advanced Host Controller Interface (AHCI), which allows advanced features of SATA such as hot plug and Native Command Queuing (NCQ). If AHCI is not enabled by the motherboard and chipset, SATA controllers typically operate in "IDE emulation" mode which does not allow features of devices to be accessed if the ATA/IDE standard does not support them. Windows device drivers that are labeled as SATA are usually running in IDE emulation mode unless they explicitly state that they are AHCI. While the drivers included with Windows XP do not support AHCI, AHCI has been implemented by proprietary device drivers.[1] Windows Vista[2], the current version of Mac OS X[citation needed] and Linux with kernel version 2.6.19 onward [3] have native support for AHCI.

     

    Basically, even if you use a SATA cable, you're still running in IDE mode (remember those big ribbon cables?). To get the benefits of SATA, you should run in AHCI.


  6. Thanks for the writeup Matt. I think this is a good first step to making a solid writeup that all Studio owners can use. Another method to get the 1397 wireless working is to run the bcm43xx_enabler.sh script instead of replacing kexts. Headings for each step (or, even better, each piece of hardware) might make it easier to find pertinent information for your writeup.

     

    Wireless 1397

     

    Download zip file below (credit goes to McSmart). Unzip and you should get a script file called "bcm43xx_enabler.sh". Drag the script into the volume where your OS X installation is. Then open a terminal and type the following:

     

    cd /
    sudo ./bcm43xxenabler.sh

    Exit out of terminal and restart. You should be good to go. Keep the script in case a future update corrupts the kext. You might have to run it again. If you have any questions, refer to this thread: http://forum.insanelymac.com/index.php?showtopic=51725

    bcm43xx_enabler_0.5.1pre.sh.zip


  7. Nice work Compcrasher. There's a similar thread at this address: http://forum.insanelymac.com/index.php?sho...4235&st=100

     

    I have installed from ideneb 10.5.5 and report the following:

     

    Working:

    Integrated webcam (took a pic =)

    Firewire (haven't tested, but recognized)

    AHCI mode for HD

    ICH8

    Fingerprint reader

    Wireless 1397 w/ bcm43xx_enabler.sh

     

    Not working:

    Video (HD 3450)

    Sound

     

    Not sure:

    HDMI

    Bluetooth

     

    Regarding sound, is sound coming out of the speakers or is the IDT just "recognized"?


  8. XP will work without changing the Bios, but you have to slipstream the drivers into the install disc. There isn't really a good writeup on how to do it, but it is possible. I have a feeling that support for the 3450 is right around the corner. As I understand it, the X3100 (onboard graphics) works fine?

×