Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About Peluco

  • Rank
    InsanelyMac Protégé
  1. AppleHDA.kext for Latitude E6420

    Perfectly working on Sierra!
  2. Hello Hervé. I've tested, for curiosity, the DSDTs you've linked, and it don't work well with my e6420. With the DSDT you linked, I lose USB and HDMI output, and no audio. As I've told before, I'm using the e6220 DSDT modified to activate DualLink. The only issue with that one is that I need Voodoo to get audio. I have another issue with my config. I use the computer connected to a HDMI 22" monitor, so I left the laptop panel as a second screen and the 22" as the main screen. But sometimes, when OSX is loading, it powers off the laptop panel and activates only the external display. And I can't activate the panel again, nor by connecting and disconnecting the external screen nor by using Fn+F8 (which garbles display and I have to reboot). It does so randomly, I can't find a pattern. When I have some spare time, I'll play with the framebuffer settings to see if it helps with this problem. Regards.
  3. Well, thanks. Maybe it's worth trying, now I'm seeing some graphics glitches when I'm using the computer for long time. I think that it could be hardware failure, but I've not seen it before on windows. As I understand, I have to select a framebuffer on config.plist, but as you mention port-patching... do I need to change DSDT?
  4. Hello Codinger. I'm lost. What is the purpose of the framebuffer changing? Could I get some benefits from it?
  5. I've edited the 6220 DSDT with MaciASL. You can find attached my own DSDT and SSDT (do you have a proper SSDT?). patched.zip
  6. Hello ssprod. Finally I've managed to get it running, fairly well by now. I forgot to mention here (was the forum down for some days?). What I've done is to follow this guide: http://forum.osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-el-capitan-clover-guide/ For the E6220 model (practically identical to e6420). Then I've edited the DSDT to activate DualLink, and used VoodooHDA.kext for audio. I had a problem installing Clover on the internal SSD. El Capitan used CoreStorage for it by default, and I had to disable it to let Clover install on HDD: diskutil corestorage revert /dev/disk1 /dev/disk1 is a virtual disk created for corestorage, the physical disk is /dev/disk0. After that, it is working pretty well. Wifi won't work, I have to exchange the card. Now I'm going to work on activate bluetooth, it's the only thing I miss by now. I don't know what could be your problem, but I would try to make a boot USB using the guide I've linked and check if the problem arises when booting with it.
  7. It does the same with slide=0 and without it. Thanks anyway.
  8. Hello. I've just installed El Capitan on a Dell Latitude e6420. This is an i5 with HD3000 graphics and 1600x900 screen. It seems to work (at least what I've tested), but only with an external HDMI monitor. The laptop screen is garbled and I can't use it. By searching I've read that the same model with the 1366x768 pannel works fine, but mine has a 1600x900 panel. I've read that the HD3000 needs to DualLink activated on Clover config for resolutions greater than 1366x768. I've tested with DualLink to 1 and to 0 on Clover and the results are the same on both cases. Any hints on how to solve this? Thanks.
  9. Asus P5N7A-VM

    Yesterday I was playing with some overclocking with this board and to check if SpeedStep was working I installed VoodooMonitor. Well, I've discovered that CPU IS ALWAYS WORKING AT LESS THAN HALF SPEED. My CPU is a C2D E5200 @ 2.5 Ghz, with 12.5x multiplier. Well, OSX put the CPU, using SpeedStep, at 6x (1200 Mhz), and it didn't move under heavy loads, always at 1200 Mhz. I've solved it by installing VoodooPowerMini. Now OSX moves the cpu between 1200 Mhz and 2500 Mhz freely according to the system load. I've been working with a half powered computer for some months. My system is 10.6.4, with the 'AppleHDA.kext' and 'IOUSBFamily.kext' from 10.6.2 to solve audio and USB issues. Can you check if this is a generalized problem or is only my system?
  10. Asus P5N7A-VM

    I used it for a time with a 9600GT, I only have to enable GraphicsEnabler.
  11. Asus P5N7A-VM

    With the DSDT I'm using (.dsl in post #779, .aml in post #782, with p states for e5200) and ROM 514, in my system sleep works flawlessly, but for shutdown and restart I need to have installed OpenHaltRestart.kext. For sleep to work I need to have the video memory at 256Mb. With 512Mb the system doesn't sleep.
  12. Asus P5N7A-VM

    WTF!!! With arch=i386 it boots fine into 32 bit kernel!!!!!!! With Leopard I was doing it with -x32, so I supposed that SL was the same. Perfect!! Booting into 32 bit kernel lets me install VMWare Fusion. One thing less in which our installations are different. Thanks!!
  13. Asus P5N7A-VM

    In order to shutdown or restart I need to have installed OpenHaltRestart.kext. I had a similar problem with Leopard and it was because I had installed an ATA HD with linux. Disabling ATA device in BIOS solved it for me. When I want to boot linux I simply enable the device again. I've not tried with SL by now. Oh, well... I can only boot in 64 bits mode!!!!!!! Even if during boot I specify "-x32" the kernel boots into 64 bits mode. I think it was after installing LittleSnitch, but I'm not sure.
  14. Asus P5N7A-VM

    With this DSDT I only have AppleHDA.kext, fakesmc.kext, OpenHaltRestart.kext and IOAHCIBlockStorageInjector.kext. My system configuration is: BIOS VERSION: 0514 CPU: E5200 C2D @2.5 Ghz RAM: 8Gb Kingston DDRII ValueRAM GPU(s): Integrated nVidida 9300 using 256 Mb memory HDD(s): 1 Tb SATA2 Seagate 7200 and 250 Gb, I don’t know the specs, but it’s the original hd that came bundled with my iMac (I changed this for a 1 Tb one) BOOTLOADER: Chameleon 2 RC1 + PCEFI 10.1 boot file MISC: Conceptronic’s Firewire card, working perfectly in SL For me it works fine, speed step, shutdown, etc. For the audio I don't use optical output or HDMI output, so I don't know if it's working. Line output works fine. Sometimes when I mesh with the kexts, I had to reboot in single user mode and rebuild permissions and caches from command line.
  15. Asus P5N7A-VM

    I compiled it and it seems to work like the one I have before, I can't tell any difference. Here is the compiled version. dsdt.aml.zip