Jump to content
InsanelyMac Forum

oliveirapaulo

Members
  • Content count

    7
  • Joined

  • Last visited

About oliveirapaulo

  • Rank
    InsanelyMac Protégé

Contact Methods

  • Website URL
    http://

Profile Information

  • Gender
    Male
  • Location
    Recife, PE - Brazil
  1. oliveirapaulo

    GMA X4500

    Something strange here... My 2A42AppleIntelGMAX3100FB (the 2A42AppleIntelGMAX3100 was removed) is being loaded on my Sony VAIO VGN-FW245J, but I can't get native resolution (1600x900)... Attaching my Plasma TV via VGA port with the notebook powered off, I started Leopard and can get only 800x600x32 (60 hertz) on my TV (my notebook display shows a completely corrupted image)... Using the "Spaces" feature from Leopard, I dragged the "Display" window from the notebook side to Plasma TV. I realize that Leopard isn't showing valid resolutions for the built-in display (1600x900 native res)... The resolutions listed there are: - 640x480 (60, 75, 85, 90, 95, 100 and 120Hz) - 800x600 (60, 75, 85, 90, 96, 100 and 120Hz) - 1024x768 (60, 75, 85, 90, 96, 100 and 120Hz) - 1280x768 (60, 75, 85, 90, 96, 100 and 120Hz) - 1280x960 (60, 75, 85, 90, 95, 100 and 120Hz) - 1280x1024 (60, 75, 85, 90, 96, 100 and 120Hz) - 1344x1008 (60, 75, 85, 90, 96, 100 and 120Hz) - 1400x1050 (60, 75, 85, 90, 96, 100 and 120Hz) - 1600x1200 (60, 75, 85, 90, 96 and 100Hz) - 1920x1440 (60 and 75Hz) - 2048x1536 (60Hz) I tried them all... Only resolutions from 1280x960 up to 2048x1536 worked (except 1600x1200) and just @ 60Hz... BUT... Obviously, 1280x960 don't fit on 1600x900 display, what I get is an image with 60px cropped at the bottom... At the right side, I get just a black border... With 1280x1024, the same behavior... Hmmm... Opppps... The black border is at the same size... Testing with 1344x1008... The same size... All tested resolutions (up to 2048x1536) are showing the black border with the same size... The width for the available area is exactly 1280...!!!! The Leopard clearly not detected my builtin display... EDID related? Ideas?
  2. oliveirapaulo

    GMA X4500

    Hey guys... I've a Sony VAIO VGN-FW245J... This notebook uses an Intel GMA X4500MHD... I've hex-edited AppleIntelGMAX3100 and AppleIntelGMAX3100FB binaries and the corresponding Info.plist files... Leopard starts up but I've an unusable display (looks like a light gray --- see it below)... After that I connected using VNC and using System Profiler I could see that the two kexts were loaded. Then I've the idea of connecting my Panasonic Plasma 42" PZ80 via the VGA out from notebook. After clicking 'Detect Displays' about 30 seconds later (in this time I observed my notebook blanking screen 3 or 4 times --- perhaps trying to find an usable resolution) my Plasma TV shows what you can see in picture 2... Yes... 800x600 resolution only (I tried higher ones with no luck) and no artifacts/corruption!!! Unfortunately no CI/QE and I've noted that all known resolutions (from 640x480 to 1920x1200) are listed in 'System Preferences' for the built-in notebook display (perhaps because Leo couldn't get a valid list from the hardware --- incorrect addresses???)... I've disassembled AppleIntelGMAX3100 and AppleIntelGMAX3100FB files and I'll try to find operations with addresses and registers on GM965 chipset, according to the Intel specs and datasheets. Patience and research...
×