Jump to content

xeu

Members
  • Content Count

    7
  • Joined

  • Last visited

  1. To get whatevergreen backlight working clover config.plist Boot / Arguments: add igfxcflbklt=1 Devices / Properties / PciRoot ; same place as framebuffer entries, within dict <key>enable-cfl-backlight-fix</key> <true/> With those and a simple PLNF DSDT entry I got backlight buttons working but only after a sleep/wake cycle.
  2. xeu

    Filevault 2 (FV2) with ps2 keyboard

    3rd version bis works for me
  3. xeu

    Filevault 2 (FV2) with ps2 keyboard

    I've tested efi from the post "Small bug corrected : 2nd version AppleKeyFeeder.efi" It works nicely ! I don't have to plug an USB keyboard to type my passphrase to unlock FV2 anymore. My config is a Lenovo x260 (based on tluck t460 w/ Clover EFI), PS2 keyboard was working in Clover but not for FV2 passphrase before that
  4. oh thank you, i've removed bluetooth in bios - and let only "FakePCIID_Broadcom_WiFi.kext" for wifi ( removed BlueTooth_Injector_T420.kext / BrcmFirmwareRepo.kext / BrcmPatchRAM2.kext )
  5. Hi I've upgraded from Sierra to High Sierra last week. Sierra setup was perfectly fine (I'm starting to think I should have kept it !) Now the bad part (high sierra) - when the computer is awaken after a sleep, randomly (let say 1 out of 3 time) it goes to bios POST, clover then the multilingual error message "You need to restart your computer." setup: - t420s with bios mod (including whitelist + vbios) - clover lastest (4212) from github https://github.com/tluck/Lenovo-T420-Clover - hibernate was set 0 - it didn't changed during upgrade $ pmset -g | grep hibernatemode hibernatemode 0 The only difference which shouldn't matter : clover config.plist mod & kext related to wifi/bt broadcom ; it was fine w/ sierra. bdmesg output, after bad wake up: ... 0:796 0:005 - [04]: 'Macintosh HD' 0:801 0:005 AddLoaderEntry for Volume Name=Macintosh HD 0:802 0:001 Check if volume Is Hibernated: 0:802 0:000 Check sleep image 'by signature': 0:805 0:002 read prefs \Library\Preferences\com.apple.PowerManagement.plist status=Success 0:805 0:000 using default sleep image name = \private\var\vm\sleepimage 0:808 0:002 sleepimage not found -> Not Found 0:808 0:000 hibernated: no - sign ... it search for sleepimage, which isn't there (okay as it's configured to not creating one) /var/log/system.log Oct 3 09:19:00 xs-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.quicklook[34902]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.quicklook Oct 3 19:42:16 localhost bootlog[0]: BOOT_TIME 1507052536 0 => no output between those time (slept & failed wake-up)
  6. Thank you for your answer - I felt less lonely in this corner ! On my side it was a dry run on a fresh install, just to test so I re-installed the whole : glad to know a faster way was possible. over there : http://www.insanelymac.com/forum/topic/317290-filevault-2/page-1 it looks to me they are using (modified) UsbKbDxe for keyboard input - perhaps a solution to have a look for our T420/T420s ? regards
  7. Is it possible to use FileVault 2 with Clover and this configuration (T420/T420s) ? I've tried to enable it after install - it rebooted but - Regular boot: i got a warning circle icon - Recovery : I was unable to enter passphrase
×