Jump to content

ssimon

Members
  • Content count

    35
  • Joined

  • Last visited

About ssimon

  • Rank
    InsanelyMac Protégé
  1. FIX FOR GRAPHICS "DOWNGRADE" BY APPLE After the Kallyway 10.5.1 to 10.5.2 patched upgrade, a new Apple update appeared, one about graphics. I did the upgrade, rebooted, and all looked OK, but without even realizing I lost CI/QE It seems that the /System/Library/Extensions/ATIRadeonX1000.kext had been replaced (most likely by the Apple graphics update), and the device ID for my ThinkPad T60p graphics chip (FireGL v5200 a.k.a X1600) was lost! You can test this by looking under System Profiler under Graphics/Displays and see if CI/QE are off, or by checking to see if the "ripple" effect of the gadgets is still present, or by trying a cool screen saver like the awesome "lotsawater" one. If the screen is white instead of seeing ripples, you need a fix. If you are like me and you lost CI/QE then just edit the Info.plist file inside of ATIRadeonx1000.kext and add your device ID to the list in the <IOPCIMatch> section. Mine was 0x70C41002 and I left the others there. Enjoy & Good Luck!
  2. What App are you using? What changes did you make? Can you please let us know? Thanks!
  3. AppleHDA Patcher Results

    Computer Type: IBM/Lenovo ThinkPad T60p ( 2623-D8U ) Sound Card Vendor: Analog Devices Sound Card Model: AD1981HD Vendor Id: 0x11d41981 Subsystem Id: 0x17aa2025 Revision Id: 0x100200 Working: NOTHING! Not Working: ALL Patcher Version used: 1.20 (says "needs more research") System Version: KALYWAY Leopard 10.5.2 - EFI - MBR - Vanilla Kernel Linux Dump File Attached! AD1981HD_T60_dump.txt
  4. AppleHDA Solution - Work in progress

    Hey guys, hoping someone got the same ALC880 (from a Foxconn 945G7MA-8EKRS2 motherboard) to work with this patcher. I tried the new patcher v1.16 on my desktop system (Jas 10.4.8 Intel SSE3 w/ Semthex kernel 8.8.1) and received this: AppleHDA Patcher - 2006/2007 Taruga v1.16 _______________________________________________________ Codec : Realtek ALC880 Vendor Id : 0x10ec0880 Subsystem Id : 0x105bb603 _______________________________________________________ This codec is not working at the moment, it needs more research Here is my ALC880 Dump File from Ubuntu for the Foxconn 945G7MA-8EKRS2 motherboard. Has Anyone gotten their ALC880 to work yet? Taruga, if you could be so kind as to add this chipset to a future patcher version, I would appreciate it. Many thanks!
  5. Analog devices SoundMax AD1981HD on HP notebooks

    Here is my own compiled tutorial of the Apple Azalia 2 channel audio out only fix. I take no credit, I just compiled this from multiple sources. Good luck! ---------- T60p and X60 Audio Fix: Searched Google for: AppleAzaliaAudio.kext AD198 Got: http://forum.osx86project.org/lofiversion/....php/t2001.html and http://forum.osx86project.org/lofiversion/...php/t18642.html (BACKUP 1st anything you delete!) 1. Delete AppleHDA.kext & Cleanup a bit: In Terminal, type: sudo rm -rf /System/Library/Extensions/AppleHDA.kext sudo rm -rf /System/Library/Extensions/AppleAC97Audio.kext sudo rm -rf /System/Library/Extensions.mkext sudo rm -rf /System/Library/Extensions.kext 2) Edit AppleAzaliaAudio.kext: In Terminal, type: sudo pico /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/Info.plist Search for (use hotkey= ctrl + w): <key>IOHDAudioCodecVendorID</key> change the string to: <string>0x10ec0882</string> Exit pico sudo pico /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist Search for (use hotkey= ctrl + w):
<key>IOPCIPrimaryMatch</key> change the string to:
<string>0x27d88086</string> Exit pico 3) Clean up the system: In Terminal, type: sudo diskutil repairpermissions / sudo chown -R root:wheel /System/Library/Extensions/AppleAzaliaAudio.kext sudo chmod -R 755 /System/Library/Extensions/AppleAzaliaAudio.kext cd /System/Library sudo rm -rf Extensions.mkext sudo rm -rf Extensions.kextcache chown -R root:wheel /System/Library/Extensions rm /System/Library/Extensions.kextcache kextcache -k /System/Library/Extensions sudo kextload /System/Library/Extensions/AppleAzaliaAudio.kext 4) Then, reboot and enjoy sound out of two channels. ----------
  6. 1st, and foremost, a thousand thanks Jcool, your installer worked PERFECTLY on my ATI X1900XT One very small issue though: I have both a 30" Dell LCD and a 20" LCD, and I rotate the 20" to 90deg so it matches up with the 30" Anyway, I am able to setup everything perfectly after your installer, but if I reboot and come back, the primary display on the left (the 20") is back in standard ROTATION, instead of the 90deg I had previously configured it for. So every time I reboot I have to rotate the 20" LCD. Basically the rotation preferences for the 1st display are not getting saved between reboots... Anyone have rotation survive a reboot after installing Jcool's patch, or a fix?
  7. Analog devices SoundMax AD1981HD on HP notebooks

    I keep reading posts from people saying that they want their HP AD1981HD to work like the IBM, but for the life of me I cannot find a solution to patch AppleHDA.kext to work on a ThinkPad T60/X60/R60 Has anyone gotten it to work? (not by using the AppleAzalia patch tho!)
  8. Soundmax HDA ConfigData and/or PinConfiguration

    Hi domeproject, I have a ThinkPad with the AD1981HD chipset and Taruga's v1.15 patcher does not do anything when I drop my codec dump file on it. I have attached it below. I too am in desperate need of someone to patch AppleHDA.kext so this finally works. Does anyone have proper ConfigData for ThinkPad T60/X60/R60 ? AD1981HD_T60p_dump.txt
  9. AppleHDA Solution - Work in progress

    NHJ, in what way am I not "respectuous for the work" like you say? I run the v1.15 utility, drop the dump file on top of the icon of the patcher on my desktop, and the open window does not even blink, no feedback whatsoever, nothing happened! Reboot, no sound. I was simply asking if maybe there is something wrong with my codec dump file, or maybe I 1st need to remove or add some extensions, BEFORE running the patcher, that is all. That is why I asked Taruga, who incidentally opened this thread and said to send him dump files so he can make the patcher compatible with my AD1981HD chipset, if possible. Besides, have you even thought that the reason it does not work is that in 84 pages of posts so far no one, asside from me, had given Taruga an AD1981HD linux dump from a modern ThinkPad? Jesus, getting flamed just for following the poster's rules and asking (politely I might add)... Where's the love man?
  10. [How To] Solutions for Wireless Problems

    FYI to anyone using AppleAzalia Audio fix ==> The 802.11n enabler for the Airport Extreme Cards works but will DISABLE audio if installed! See my post HERE I have yet to find a solution.
  11. Analog devices SoundMax AD1981HD on HP notebooks

    Unfortunately, NO! I had it working with AppleAzalia, but then when I installed the Plug-in for 802.11n audio broke and dissapeared. See my report HERE 802.11n Wireless works great now @ 150MB, but no more audio. I am therefore trying the AppleHDA approach now.... but without much success. My last post on the matter is HERE If anyone can get their ThinkPad T60/X60/R60 to work with AppleHDA, PLEASE let me know!!!
  12. AppleHDA Solution - Work in progress

    Taruga, could you please just tell me if my linux codec dump file will work with your v1.15 patcher as I am pulling my hair out here. Trust me I do not have a lot of hair to spare... Also, if you think it will work could you please also tell me what files SHOULD and should NOT be present, so I can ensure the proper patching takes place. Thank you kindly in advance with every hair strand I have left! AD1981HD_T60p_dump.txt
  13. AppleHDA Solution - Work in progress

    NO DICE! Patcher launches, I dragged and dropped the codec dump (.txt file attached here) on the patcher icon, but NOTHING happens and the main patcher window just says "Please drag and drop..." Any suggestions? AD1981HD_T60p_dump.txt
  14. AppleHDA Solution - Work in progress

    OK, I managed to get the Linux Dump! I have therefore updated my original post HERE It seems that under Linux the Audio on a ThinkPad laptop will NOT work right if you have turned off the MODEM in the BIOS. Sure enough my modem was off (who uses dial-up these days?) and that was the problem. Once I turned ON the modem in the BIOS and rebooted the "cat /proc/asound/Intel/codec#0 > /tmp/AD1981HD_dump.txt" command worked like a charm and I got my dump file. For anyone interested, I have attached my Audio Dump file to this post. It should work for most Thinkpads T60/X60/R60 Now to try to patch the audio and see if it works. Since I originally messed with the AppleAzalia to get Audio to work I might not have all the files I need. I have since deleted AppleAzalia.kext but what other kext files do I need to delete or have ready and available for the patcher to work? Does anyone know? NO DICE! Patcher launches, I dragged and dropped the codec dump (.txt file attached here) on the patcher icon, but NOTHING happens and the main patcher window just says "Please drag and drop..." Any suggestions? AD1981HD_T60p_dump.txt
  15. AppleHDA Solution - Work in progress

    I seem unable to get the AD1981HD audio dump in Linux. I booted my ThinkPad T60p laptop to Ubuntu 7.04 Live CD and it recognized everything, including the audio with both Analog & digital options + microphone. However when I issue the commands cat /proc/asound/card0/codec#0 >> dump.txt all I get is a new line and a blinking cursor, no file gets created and it just sits there. All the "files" in /proc/asound show as size "0"! What am I doing wrong? UPDATE: Problem fixed! See my follow-up post HERE
×