Jump to content

alixzibit

Members
  • Content count

    13
  • Joined

  • Last visited

About alixzibit

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  1. Dual boot, different hard drives?

    Dual boot wont be a problem, just make sure your windows is on a GUID partition and after you install 10.8.2 you should install chameleon bootloader to your mac drive. What this will do is it will replace your windows boot and will let you choose at the startup between OSx and windows. EDIT: Im not completely sure if SSD and normal HDD will work together with chameleon. But if you have the chameleon bootloader even on a usb, you can still be able to boot
  2. So you are saying that the kext which I provided didnt work for your laptop but you found other working kexts? And now you are able to boot to your installer? If thats case Ill gladly edit my guide and add your links
  3. I'm not sure if it has anything to do with AHCI port. Usually even if your RAID drive is not compatible the installer will still load and then you won't be able to see any drives from the disk utility. This is assuming that you are still stuck at that stage you can try these AHCI kexts that I have further attached in the guide, there are from my system. But I believe this issue has got to do with PXHCD.kext (USB driver) Did you try booting with '-f' with/or '-x' ? EDIT: Pls check your inbox
  4. You have to use a bit of terminal commands to get the mach_kernel working. No worries luckily I found an easier way. Just download the kernel patch installer from the links section and install
  5. I have noticed that there not many guides out there for installing Mountain Lion on Intel HM 77 chipset laptops. So I thought of sharing my experience on Installing ML on my HP Sleekbook 15t (b001-ee). Hardware Specs: BIOS Manufacturer: Insyde. BIOS Type: UEFI - LOCKED (with support for legacy boot) Core i3 3217U @ 1.8 Ghz (2 Cores, 4 threads) 4GB Samsung DDR3 1600 RAID 500 GB HDD IDT High Definition Audio Atheros Bluetooth (Device ID: 0311f) Atheros AR9565 NVIDIA OPTIMUS (Geforce GT 630m - PCIe + Intel HD 4000 - Built In) Realtek RTL 8101E/8102E Ethernet What Works? Proper Detection Of CPU, RAM USB 2.0 and 3.0 Ethernet (recognized as RTL 8169) Intel HD 4000 Graphics (Quartz Extreme and Core Image Enabled) Bluetooth Trackpad IDT High Definition Audio (recognized as Intel HDA) Battery What does not work? NVIDIA Optimus Brightness keys (works only at boot) WIFI - Im using a micro Wifi USB from a manufacturer called 'Tenda' it uses Realtek RT2870 USB chip, this same chip is found on the more popular WIFI stick from D-Link (DWA-125). Latest drivers are readily available from the realtek website, I got usb from a shop near my place for $10, it might be even more cheaper online Booting OSx without USB - I need myself some guidance, because I have tried using clover to boot but it does not work at all unfortunately Installation: What do you need: > A Mac or a computer with Mac OSx 10.6.8 or Higher (a Virtual Machine is fine too, I installed using a VMware image of 10.8.3, google souldevteam for more details) > 8 GB USB > Retail DVD or copy of Mountain Lion What does Mac OSx need to prepare USB ML Installer? > Latest version of myHack app - myHack | Taking the iFail out of iHack - SojuGarden > Latest version of Chameleon Wizard -Hackintosh Chameleon Wizard 4.2.1 - Downloads - OSx86.net >Kext Wizard - Hackintosh Kext Wizard 3.7.10 - Downloads - OSx86.net What does the target laptop needs to be running? >The computer should already be running a windows OS at least with windows running on separate partition (It should se a GUID partition) OR a separate Hard Disk (recommended) > Windows OS should have MacDrive installed (trial version will do fine) Preparing ML USB: >Mount USB >Run myHack app, run "Create Mac Osx Installer" choose 10.8, select target your mounted USB now browse through the computer and select the Mountain Lion dmg/iso (InstallESD) or if its an app browse to your applications folder to find the installer. The copying process may take around 40 mins. The app may also ask to create Extra folder, just select generic >After the process is done, install extensions which I have attached using kext wizard on the USB choosing S/L/E folder to install. Delete Browse to S/L/E on the usb and delete AppleHDA kext, Repair permissions and rebuild caches using the same app. P.S. I didn't have a problem with getting my internal drives detected by the installer, but if you do come across a similar issue download the AHCI kexts I have attached and install along with the extensions files mentioned earlier. UPDATE: Added alternate AHCI and USB kext (which works for HP ENVY Sleekbook 6-1151er) - credit transmist >Launch Chameleon Wizard, install latest bootloader to your ML USB, select boothfs option not update. >In Chameleon Wizard app, goto Smbios tab, edit the smbios file and from the model presets choose Macbook Pro 9.2 and save the file to desktop >Copy smbios file from desktop and paste it to your Extra folder on your ML USB. Installing on target laptop >Go to BIOS, disable secure boot it might ask you for password. Enable Legacy Boot. Configure Boot Order to prioritize USB. Or using F9 key at boot which will allow you to choose USB >Boot from usb >Once at the bootloader screen, boot the installer using the following flags -v cpus=1 GraphicsEnabler=No >You should now be at the install screen >Goto disk utility and create GPT/GUID partition >Continue and install Mac OSx. Should take 15-20 mins >Near the end of installation myHack will ask for adding Extra folder again, install generic if you had not done this before or this time just choose the one you modified earlier in your USB, then later it will ask for removal of some kexts (ApplePolicyControl, NVD*** kexts) just select to remove them. >Once its done, restart and now boot into windows and access the ML drive where you just installed the OSx (as mentioned earlier, you should have MacDrive to view OSx drives) >Browse to System/Library/Extensions folder and delete the following kexts: AppleHDA, all AppleIntelHDGraphics4000 kexts, geforce kext, all GF*** kexts, all NVD*** kexts >Restart and boot from USB >Launch the installer again using the same boot flags as mentioned earlier >From Utilities run myHack and then run Myfix. This will fix permissions from the files you deleted using windows >Restart again and boot from USB >Now boot the Mac Osx drive, using same boot flags >If all went accordingly you should now have successfully booted to your Mountain Lion Post-Installation For this part you need to download the following: >10.8.3 Combo update OS X Mountain Lion Update v10.8.3 (Combo) - Support - Apple >Multi beest - Mountain Lion (http://www.tonymacx8...m/downloads.php - You need to be registered user to download) >Kernel Patch to fix all cores (cpus=1 issue) (check attachments) >Ethernet driver (check attachments) Your current Mountain Lion version is 10.8 download 10.8.3 Combo update from Apple website and install. DO NOT click restart just yet though. >Browse to System/Library/Extensions folder and delete the following kexts: AppleHDA, geforce kext, all GF*** kexts, all NVD*** kexts >Install the extensions that I provided again using Kext Wizard >Run Multi-beest, Expand Drivers & Bootloader>Misc> and select USB 3.0 Universal and PS/2 and install >Install Ethernet driver RTGNIC >Install Kernel Patch >Fix permissions using kext wizard and restart >Boot from USB >Now you can boot into your ML without any boot flags, you may use -v for debug or -f or -x if for some reason it fails to boot Latest version of chameleon bootloader will auto inject your HD 4000 graphics info and you should have QE/CI working Pls do share your experiences and help improve this guide for others THANKS! Hope I had helped you! Attachment Links New Extensions zip: (UPDATED) https://mega.co.nz/#...mTxRvbGRstPHOZI RTGNIC: https://mega.co.nz/#...QOYiJwSLBdRki7w Kernel Patch Installer: https://mega.co.nz/#...HpmpYYlB6oWhXAI Alternate AHCI and USB kexts https://mega.co.nz/#...aWPVRSpM3Sw_D4g AHCI.zip
  6. the guide is a bit tricky, but it works, i got it working after couple times too. i'll try to explain wat i did: -first i made sure/or deleted the hdaenabler.kext from the extensions folder -then i ran alc installer from the zip file -i again went back to extensions folder and now deleted alcinject.kext -then i went to system preferences to see whether my sound card was detected and if it was i made sure tat i selected output to internal speakers (dont wrry if its not detected at this stage) - repaired permissions using disk utility and restarted my system -then using kext helper i installed hdaenabler -fixed permissions (and again went bck to system preferences and checkd is my sound is still detected, which by now should be, i again made sure tat the output is selected as internal speakers -fixed permissions and restarted -by now i definitely had the sound wrking -i then ran the hda fix, repaired permissions and restarted FYI - if u r getting choppy or cracking sound then its most likely u need to follow the last step in my posted guide to get it working properly. OR incase u by some chance find tat difficult u cud use -v idlehalt=0 cpus=2 at the boot when u restart to make sure tat sound wrks fine. (but u will hav to go thru this everytime u boot) i hope this helps and i dunno for me guid partition worked... strange...
  7. anyone with Acer Aspire 4520(AMD)

    i thinkso it will be alrite. U jus need to get and install the kexts properly
  8. anyone with Acer Aspire 4520(AMD)

    I just recently posted a small guide on how to get leopard working for acer 4520 (audio n ethernet is wrking, and wifi is still experimental) u can chk it out here http://www.insanelymac.com/forum/index.php...amp;pid=1165258
  9. Cant install leopard dont know why....

    is this after installing or before??? Check ur bios and make sure ur ide/sata controller is set to AHCI mode and not IDE mode. Check ur bios legacy usb controllers is enabled too (it sometimes can cause kernal panics while detecting USB either attached or simply the bus itself) And if this was after installation, then install again and make sure u format ur hard drive as GUID partition
  10. iDeneb v1.4 Hangs After Install

    did u partition your hdd as GUID?
  11. download osx86 tools for your leopard: http://######.com/osx86tools/ You can use this to view your components name and device ids
  12. Since i have been benefited by using the resources of this website, i thought of sharing my experience on installing 10.5.4 on a acer 4520 laptop: Specs: AMD Turion TL-58 (1.9Ghz) - Detects correctly 1GB DDR2 667 RAM - Detects correctly NForce 610m Chipset - (used nforce mcp67 drivers, and they work well) Nforce Ethernet - (Works) Realtek ALC 268 Audio - (Works) NVIDIA 7000m Graphics (Works, Only CI, No QE) Atheros AR242x Wifi/AR5007 - (The card gets detected, but at restart it gives me a kernel panic - you can give it a shot though, here's the file and please do post if you got it working, note in the archive there is a program called kismac, use that to search wifi networks, and edit its preferences and add AirportExtremeDriver) Installation DVD i used was Leo4allv4.1 Installation Notes: -If you are using vista and would like to keep your vista installation intact and want dual booting then follow this guide on how to setup dual booting -MAKE SURE YOU SET YOUR SATA CONTROLLER FROM IDE MODE TO AHCI MODE IN YOUR BIOS (this is the main cause of problems occuring during setup) -Type -v idlehalt=0 cpus=2 at boot (as this speeds up loading the setup) -Once the setup loads go to disk utility and partition the drive you want to install Osx to Mac Extended. (Keep in mind the partition must a GUID partition - you can create by selecting the hardrive>partition>options>select guid>format) -Customize and select nforce mcp67 for your chipset drivers, for video choose either nvkush or nvdarwin, darwin will detect GFX properly but it doesnt really matters since no QE -Do not select anything for audio, get the kext from here and follow the guide posted too -Do not select anything for ethernet, get the kext from here -Do not select anything for Wireless, try your luck with link posted above -Choose USB 2.0 Mount Fix -You may if you want remove firewire drivers -Choose power management tool for laptop -Choose EFI Kernel (either Voodoo 9.5.0 or TOH 9.4.0) -For AppleSMBIOS choose the one with 667 -For ACPIPlatform, choose the one recommended for EFI -Select applications you like. -Install and you may skip CD checking -Once finished, at boot type -v -f idlehalt=0 cpus=2 (-f flag is to load the kexts properly, only required one time) -Install the kexts for audio, ethernet and if you wish wifi too and repair permissions using disk util -Goto Library>Preferences>SystemConfiguration and open com.apple.boot.plist. Under Kernel Flags line edit/add this <string>idlehalt=0 cpus=2</string> and save the file. This will insure your OSX will always boot by using both your cores, and hence will save you the trouble of entering the line at boot. Do post your feedback and share your experiences on the wifi and GFX. Thanks
×