Jump to content

coltrane35

Members
  • Content Count

    9
  • Joined

  • Last visited

About coltrane35

  • Rank
    InsanelyMac Protégé
  1. Hi everybody, Has anyone managed to make the wifi works with Lion ? Lion GMworks flawlessly on my ASUS P5W DH, but i can't use the realtek RTL8187(L) driver as it does not support 64 bits mode. I've tried Lnx2Mac's Realtek RTL81xx driver without success. link to his blog : http://lnx2mac.blogspot.com/p/realtekrtl81xx-osx-driver.html Does a solution to this problem exist, or will we have to wait an upgrade of the drivers on realtek's site ? Cheers !
  2. coltrane35

    ASUS P5W DH Deluxe

    Lion tourne parfaitement et pour la première fois la mise en veille fonctionne complètement. Le seul hic, c'est que les drivers realtek ne fonctionne plus car incompatibles 64bits. Apparement, il n'est plus possible de faire tourner d'applis en 32 bits sous Lion. Y a-t-il un moyen de contourner ce problème ? EDIT : Je peux me connecter via ethernet mais toujours rien pour le wifi (et je ne peux malheureusement pas utiliser le câble ethernet indéfiniment car pas du tout pratique en l'état). Je viens de tomber sur ce blog où l'auteur présente un projet dédié aux drivers realtek. Voici le lien : http://lnx2mac.blogspot.com/ aller dans la rubrique RTL81xx OS X Driver Je viens de procéder à l'installation, mais toujours impossible de débloquer le wifi ... Si ça inspire quelqu'un, n'hésitez pas ! EDIT 2 Si l'on en croit cet article, l'avenir parait bien compromis pour le driver 8187L ... http://roklandllc.blogspot.com/2011/05/rea...nd-of-life.html EDIT 3 Bon, je jette l'éponge, après avoir arpenté les sentiers du web en long et en large, je me dis que la solution ne pourra venir que d'un drivers recompilé (si c'est bien le terme requis). Dommage ...
  3. coltrane35

    ASUS P5W DH Deluxe

    Pour le voodooHDA, tu le trouve ici : http://code.google.com/p/voodoohda/downloads/list Il s'agit d'un drivers Open Source. Voici ce que l'on peut trouver sur le site: VoodooHDA is an open source audio driver for devices compliant with the Intel High Definition Audio (HDA) specification, based primarily on code from the FreeBSD hdac driver. It is intended as an Intel-only replacement for AppleHDA on Mac OS X with support for a wide range of audio controllers and codecs. All major VoodooHDA development for the past year has been going on from a Project OS X thread, so check that out for the latest source code and updates. This page will be, at least for now, a resource to get installer packages which installs the kext for either 10.5 or 10.6, prefPane, Launch Agent, as well as an uninstall script for those who wish to roll back to their previous state after installing VoodooHDA. You need more than just the kernel extension, so I suggest you use the install package. Je n'ai jamais eu de soucis avec, et je trouve plus simple/rapide d'utiliser l'exécutable. Content de te voir de retour Aliab
  4. coltrane35

    ASUS P5W DH Deluxe

    oui, je tourne en 64 bits. En ce moment, je refais une install de snowleo pour le remettre en 10.6.7. Comme un c.. je pensais pouvoir downgrader avec un back up time machine, mais ça ne marche pas. Soit time machine n'en ai pas capable ou je n'ai toujours pas compris toutes les possibilités de cet utilitaire. Une fois la réinstall terminée, je ferai un clône avec Carbon Copy cloner. UPDATE : La réinstallation s'est bien passée (normal). Je suis à présent en 10.6 Sauvegarde du système avec Carbon Copy Cloner. Je tente finalement la comboupdate 10.6.8. Verdict : ça marche Il y a juste le son à installer avec VoodooHDA ainsi que le Wifi. J'ai ensuite récupéré mes données sauvegardées avec Time Machine.Pour l'instant tout à l'air nickel.
  5. coltrane35

    ASUS P5W DH Deluxe

    Bonjour. Aucun problème de mise à jour jusqu'à la 10.6.7 (même pas besoin de réinstaller le son ou les drivers realtek pour le wifi). Mise à jour en 10.6.8, et là, kernel Panic intempestifs au boot. J'ai réinstallé la mise à jour depuis la combo update, mais ça plante toujours. En farfouillant un peu, j'ai trouvé qu'il pouvait s'agir d'un problème des Kexts IOPCIFamily et AppleACPIPlatform. La solution préconisée par certains site est d'utiliser les fichiers de la 10.6.7. Je boot en safe mode (-x), vérifie le contenu du dossier System>Library>Extension. IOPCIFamily.Kext a été remplacé lors de la mise à jour (vérification de la date) mais pas AppleACPIPlatform. En toute logique je décide de remplacer uniquement IOPCIFamily.kext. Réparation des autorisations puis reboot: Kernel Panic. Je relance en safe mode : plantage. J'ai réessayé plusieurs fois et ça plante toujours. Du coup je me contente de windaube pour l'instant, mais la pomme me manque ! Le silence d'Aliab sur l'update 10.6.8 m'inquiète: est-il en vacances (bien méritées soit dit en passant) ou horreur, a-t-il remplacé toutes ses cartes mères ?
  6. coltrane35

    ASUS P5W DH Deluxe

    ayé ! l'install est en cours. Si je n'avais eu autant de :censored2: dans les yeux, je me serais rendu compte que mon fichier com comportait des erreurs de frappes !!!!! Je croise les doigts pour gérer une install stable de la 10.6.4 en espérant pouvoir gérer tout seul comme un grand ! Et bé voila, j'ai perdu un temps impressionnant tout ça à cause de ma négligence ! Si j'avais mieux regardé mes fichiers, ça aurait marché tout de suite. Voila le déroulement de l'install (pour mon cas): 1 - A partir de Léopard (situé sur HD1) Partitionnement de mon HD2 en 2 partitions avec l'utilitaire de disque: SNOWLEOPARD = 100Go et BOOTSL = 400 Go 2- Installation de Chameleon RC5-r568 (installation standard, toutes les autres options sont décochées) sur BOOTSL et SNOWLEOPARD (je l'ai également installé sur la partition hébergeant LEOPARD, mais je ne crois pas que cela soit nécessaire ...). 3- Ensuite restauration de l'image de MAC OS X INSTALL DVD vers BOOTSL (si l'image est restaurée d'abord, je ne parviens pas à installer chameleon) 4- Création d'un dossier intitulé EXTRA sur les partitions BOOTSL et SNOWLEOPARD 5- Ajouter dans les deux : fichier dsdt.aml + fichier com.appleboot.plist + smbios.plist + Extension.mkext Voici le contenu de smbios.plist <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>SMbiosdate</key> <string>20/08/2008</string> <key>SMbiosversion</key> <string>MP31.88Z.00C1.B00.0802091544</string> <key>SMcputype</key> <string>1281</string> <key>SMexternalclock</key> <string>1,33</string> <key>SMfamily</key> <string>iMac</string> <key>SMmanufacter</key> <string>Apple Inc.</string> <key>SMmaximalclock</key> <string>2,50</string> <key>SMmemmanufacter_1</key> <string>Team Elite</string> <key>SMmemmanufacter_2</key> <string>Team Elite</string> <key>SMmempart_1</key> <string>50M3P4R7</string> <key>SMmempart_2</key> <string>50M3P4R7</string> <key>SMmemserial_1</key> <string>50M353R14L</string> <key>SMmemserial_2</key> <string>50M353R14L</string> <key>SMproductname</key> <string>MacPro3,1</string> <key>SMserial</key> <string>...</string> <key>SMsystemversion</key> <string>1.0</string> </dict> </plist> et le contenu de com.appleBoot.plist <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>EthernetBuiltIn</key> <string>Yes</string> <key>GenerateCStates</key> <string>Yes</string> <key>GeneratePStates</key> <string>Yes</string> <key>GraphicsEnabler</key> <string>Yes</string> <key>Kernel</key> <string>mach_kernel</string> <key>Kernel Flags</key> <string>arch=i386</string> <key>DropSSDT</key> <string>No</string> <key>Timeout</key> <string>5</string> </dict> </plist> 6- Redémarrage et sélection de BOOTSL. L'installateur se lance, je choisis la Partition cible SNOWLEOPARD. 7- Une fois l'install achevée, reboot, puis sélection de la partition SNOWLEOPARD. Une fois arrivé sur le bureau, je lance directement la mise à jour avec le comboupdate 10.6.4. Une fois relancé, on se retrouve en 10.6.4 et il reste à installer le voodooHDA et le drivers realtek pour le wifi et voilà ! Il ne me reste plus qu'à tester tout ça en espérant que l'install soit vraiment stable. En tout cas merci à vous tous, car même si je ne capte pas tout en ce qui concerne la manipulation de kext, le "compilage" et tutti quanti, j'ai l'impression d'avoir un peu progressé. Cependant, "longue est la route vers la connaissance petit scarabée" !
  7. coltrane35

    ASUS P5W DH Deluxe

    Bon, j'ai désactivé les 2 ports ethernet dans le bios, je ne suis plus bloqué sur Yukon. ... Par contre Sound assertion "0 !=createAudioEngines (fPathmap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver .cpp" at line 172 goto Exit est toujours là. ... Et en tapant ce message d'erreur sur Google, je tombe sur sur des posts évoquant ce problème APRES installation de SnowLeopard ... et non pas pendant (en fait je n'arrive même pas à lancer l'install...) A vot' bon coeur messieurs, dames !
  8. coltrane35

    ASUS P5W DH Deluxe

    :wallbash: :wallbash: Merci Aliab pour tous tes conseils, malheureusement la situation a évoluée et pas en bien .... Je reviens un instant sur mon dernier post : - j'ai réussi à faire fonctionner le wi-fi avec les drivers realtek: il suffisait de persévérer et ça a fini par fonctionner (comment, je sais pas trop) -concernant le message d'erreur pour le disque dur, il m'a suffit de le repartionner en une seule partition et le problème fut résolu. En glanant des infos, il apparait que ce problème arrive avec des DD de grosse capacité et lorsqu'une partition frise le TO (ex pour un DD de 2To avec une partition avoisinant le TO ça va planter alors que si elle dispose de 4 partitions de 500 Go ça marche) ... Mais bon, de SL 10.6.4, je reviens à LEO 10.5.6 (fausse manip, obligé de tout réinstaller) Et là, j'en ai un max. Impossible de booter sur la partition hébergeant l'image de SNOW. Je me suis rendu compte (plusieurs jours plus tard) que mon fichier com.Apple.Boot.Plist n'était pas correctement édité: il manquait : arch=i386 ainsi que DropSSDT (ceci expliquait sans doute les messages d'erreur mach_kernel et -pciRoot ... Le fichier corrigé, je parviens à présent à booter sur la partition hébergeant l'image de SL MAIS ça bloque à la ligne suivante : yukon: Ethernet address 00:17:31:e8:BB:9E et là je ne comprend pô ! juste avant ça, j'ai également : Sound assertion "0 !=createAudioEngines (fPathmap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver .cpp" at line 172 goto Exit Là je ne comprend pas ce que cela vient faire là vu que je n'ai pas ajouté le kext HDA dans le dossier Extra. Bref, je sèche et reste désespérement sur le bord de la route .... Actuellement, le dossier EXTRA comprend les fichiers suivants : - com.apple.boot.plist (normalement édité comme il faut) -dsdt.aml -Extension.mkext PAS de smbios.plis car désormais inutile si j'ai bien compris j'ai remplacé le fichier boot par PC EFI V 10.6 récupéré sur le blog de netkas mais cela ne change rien ... Désolé, je pensais que mon prochain message serait pour vous annoncer la bonne nouvelle ... mais on va légèrement reporter ça ... P.S : au début du post, il est dit de restaurer l'image de SL sur une partition PUIS d'installer chameleon? Or, je n'ai jamais pu procéder dans ce sens. D'abord install de chaméléon puis restauration de l'image sinon l'installeur de chameleon freeze. Normal ?? Bon, je retourne écumer le net en quête de réponses. Merci pour votre aide et désolé si je suis passé à côté de la solution sans m'en apercevoir( ), mais là je commence à fatiguer ... EDIT : lorsque je lance en safe mode + verbose, le message Sound assertion "0 !=createAudioEngines (fPathmap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver .cpp" at line 172 goto Exit disparait par contre ça bloque toujours sur : yukon: Ethernet address 00:17:31:e8:BB:9E Help please ! J'ai horreur que mon ordi me nargue plusieurs jours de suite !
  9. coltrane35

    ASUS P5W DH Deluxe

    Bonsoir à tous ! Cela fait depuis un bon moment que je suis ce fil (ainsi que le précédent sur leopard, merci Aliab), et je me décide finalement à vous demander conseil car depuis trois jours je suis à deux doigts de jeter mon G5 par la fenêtre Je suis actuellement passé à la version 10.6.4 de Léopard en suivant les conseils précédents, mais je n'arrive malheureusement pas à avoir une install 100% opérationnelle. Voici les symptômes docteur: - Connexion wifi : j'ai réinstallé le drivers realtek usb wlan en utilisant l'installer. Je vais dans les réglages réseau rentrer les infos réseau, puis rentre le code wep dans la fenêtre Raltek Wlan client utility: la connexion s'établit mais ne cesse de "décrocher". Ce drivers est-il compatible avec SL 10.6.4 en sachant que ce dernier démarre par défaut en 32 bits. - La mise en veille ne fonctionne qu'à moitié, le bougre ne se réveille pas même avec Please Sleep. Pour ça j'ai peut-être un début d'explication: mon boitier est celui d'un ancien G5 et le branchement du power switch est particulier (je crois) du coup, je vient de tomber sur un site ou l'on explique comment souder les fils directement du switch vers la carte mère au lieu d'utiliser la prise regroupant l'usb, le firewire, l'audio etc ... Si quelqu'un possède ce boîtier et qu'il n'a pas eu besoin de bidouiller la connectique, je suis preneur ! D'ailleurs, je suis obligé de couper l'ordi directement à partir de la multiprise sinon il se relance automatiquement ... - Enfin, j'ai un disque dur d'1 TO en usb et lorsque je démarre l'ordi avec ce dernier allumé, j'ai tout de suite un message d'erreur du type : EBIOS read error : error 0X01 block 0X7170e220 sector 0 OU block 0X7170e2"38 sector 0 Du coup, je lance l'ordi avec le disque éteint et celui ci est reconnu lorsque je le branche une fois arrivé sur le bureau de tonton léo. Je tiens à préciser que mon bios est le 3001 et en ce qui concerne le dossier extra, il y a les fichiers suivant : com.apple.boot.plist dsdt.aml extensions.mkext smbios.plist Ces 4 fichiers ont été récupérés il y a une semaine max au début de ce topic et modifiés comme précisé par Aliab. J'ai également ajouté VoodooHDA.kext (et le son fonctionne). J'espère ne pas avoir été trop long, trop imprécis ou être passé à côté d'explications déjà données précédemment. En tout cas, si vous pouviez me dépatouiller, j'apprécierais énormément ! Merki !
×