Jump to content
InsanelyMac Forum

wbpluto

Members
  • Content count

    19
  • Joined

  • Last visited

About wbpluto

  • Rank
    InsanelyMac Protégé
  1. Finally, I found the root cause of my partition problem: If we installed Win8.1 first and then boot into OS X Installer, Disk Utility show "This disk appears to be partitioned for BootCamp. Changing the partition map may make this disk unbeatable using Windows." is just OK. We must select the partition prepared for OS X installation, then erase it as normal, the operation will success!
  2. 1. I used "diskpart - clean" command before installing Windows 8.1, then this problem occurs. I must repartition the whole disk in OS X installer, so Windows 8.1 partition lost. I attempted to install Win8.1 after OS X installed, but Win8.1 Setup told me the disk is MBR partition table! so I must diskpart - clean, then install Windows8.1 properly and of course OS X partition lost:( I haven't used BootCamp on my SP2, only official diskpart and diskutil are used, so this problem is strange. See comments below:
  3. Thanks for this thread! I have 3 problems on my Surface Pro 2: 1. Partition cannot be erased in OS X installer: My partition table is GPT created in Windows 8 Setup. I followed the C. Install OSX on the Surface Pro 2, step 3, Disk Utility reports "This partition cannot be modified." "This disk appears to be partitioned for BootCamp. Changing the partition map may make this disk unbeatable using Windows." [ So, finally cleaned the whole disk and installed only OS X]. 2. LED Backlight control didn't work. After installed followed this post and using FilesPackage V0.3 for 10.9.2, I found my SP2 backlight cannot be controlled in Display System Preference -- the scrollbar appears, but no effect when slide on it! 3. Cannot control volume by volume key on the left. I found the Volume -/+ keys didn't work, if this can be fixed?
  4. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    Sorry, this domain *.lefora.com is blocked by Chinese government because it's a public blog hosting some sensitive contents, so we cannot access it in China. Hi,guy. Any config.plist is OK I think, DSDt.aml is iFRIE one, and my EFI/kexts/10.8 folder is empty.
  5. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    HI, iFIRE, I found that although Internal display didn't work correctly without External display connected before launch, but if I switch the rotation to 90/180/270 degrees, it will be extremely OK! If I switch it back to 0 degree, it go back to didn't work. Maybe it is a pregnant discovery. Do you have some advice on this?
  6. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    Sorry, I noticed youhave made some mistakes in your DSDT.aml, so it was not work, for example, you added a new _DSM method out of the scope of IGPU. And After I open the aml file in DSDT Editor, it reported there are some warnings of the file. After all, thanks for your kind again so much!
  7. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    Any config.plist is OK I think, DSDt.aml is iFRIE one, EFI/kexts no any files.
  8. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    Here are reports for 4 times of reports, but the 4th try failed to gather information due to cannot login to desktop。 Please open the txt file for results. SurfacePro-DarwinDumperReports-20130411.rar
  9. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    Pen is working with some offset, but Finger touch is not working.
  10. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    thanks, but why FrameBuffer0(Internal display) is secondary, and FrameBuffer1 (External) is primary display? May I fix it in DSDT? BTW, I found that your DSDT.aml just work while external MiniDisplayPort is connected before launch, if there's only internal display, the screen will be only just top half with many horizontal lines. just like this picture:
  11. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    Awsome! It really WORKS! I cannot thank you more~~~ The only problem: external display is primary with dock, and internal display is seconary, how to resolve it?
  12. wbpluto

    Why HD4000 on Surface Pro with heavy snow effect?

    What a pity, hwy no one here?
  13. Hi Guys, I am trying to run OS X on Surface Pro natively through Clover UEFI, not in VM. Now, the biggest problem is HD4000 with heavy grayed snow effect (and QE/CI/AirPlay/Brightness is supported)...It's so strange, and how to resolve this problem? Who can help me to resolve it? I have recorded a video for this:http://v.youku.com/v_show/id_XNTM2ODM1NDEy.html acpi_dsdt-SurfacePro-fromAIDA64.zip
  14. it works on my Lenovo F50A....thanks
  15. AppleHDAPatcher doesn't support My ALC262 on Intel ICH7-m in my Lenovo F50A...... it says "doesn't supported Generic 11c1 Si3054 Detected". ======================================= I have tried v5, output is OK. Please make Patcher support my sound card,,thank you! codec.txt
×