Jump to content

lordeath

Members
  • Content count

    24
  • Joined

  • Last visited

About lordeath

  • Rank
    InsanelyMac Protégé
  1. Ohh! I'm sorry I didn't notice of that. try this one. http://www.megaupload.com/?d=TRKFD47G It's 32bit. SO if you want to try it must boot at 32. Debugging is enabled on this build. (That can delay boot a lot if your USB device is plugged at boot time). Hope it helps
  2. It seems to be working properly on all my macs with Tactic3d headsets and all my cm-108 usb cards. If you have any problem post it and I'll try to fix it. Now I'm working on TrinityAudio.cpp to make it work with gcc4 and learning to port this to 64bit.
  3. Hi Everybody. Here there is a fix to Robotic Mic input on USB Audio devices. I have tested it on CM-108 chipsets. The problem: http://discussions.info.apple.com/thread.j...=0&tstart=0 http://forums.techarena.in/operating-systems/1394414.htm We know that latest OpenSource version of AppleUSBAudio was working properly. And then it became Closed and began doing noise on mic input randomly. So I have downloaded latest known sources : http://sourceforge.net/projects/darwinsour...BAudio/210.2.1/ Removed trinity Audio (too many errors, I'll check it later) and fixed some defines.Now it's working on 32bit mode. http://www.megaupload.com/?d=TRKFD47G Where to find doc to port kexts to 64bit?
  4. 10.6.6 is out

    I have Sleep working. Not sure about where this kext came from. SleepEnabler.kext http://www.megaupload.com/?d=3J2W6HB8 It works using pmVersion=21 Working on GA-p35-DS3L vanilla kernel. MacosX 10.6.6
  5. About GA P35 DS3l & ALC888

    Finnaly I get it working again, just add ICH9 pci device to alc and hda kexts after installing alc888 from skippy
  6. About GA P35 DS3l & ALC888

    I have the same mobo, I get sound working for a while in Leopard with skipyretard ALC888 package. I think that may be some issues related to cache because since then I couldn't make it to work. I have tryed deleting /system/library/caches, /system/library/extensions/caches, /system/library/extensions.mkext, and running kextcache -k ...
  7. Has anyone installed that update on an AMD based system?. Last 10.4.7 makes me patch again some extensions (Bom.. and some others) So I'd like to read about a sucess story with that update on AMD systems.
  8. EricJD, That restart problem must not be answered in this thread because is OffTopic. Open a new thread on postinstall discussion to solve that. (startup your system with -v and "Boot Graphics"="No" to view what is happening on there and post your results on that thread). If screen goes black it will be something on screen if you use -v flag.
  9. You must delete Extensions.* once. Probably you are current using old drivers at boot.
  10. Finally Sucess story

    Ok, I get AppleAC97Audio.kext modified from http://forum.insanelymac.com/index.php?sho...udio\.kext Then on my Current kext only I replaced AppleVIA kext that is INSIDE that modified kext. If you use that modified kext as is it will not work.
  11. Finally Sucess story

    There is my story... My system As you can see below is: Host Name: sara, OS Version: 10.4.7 (Build 8J2135) (reboot hex edit,10.4.6 JaS dvd, Amd10.4.7update+sec update+decrypts) Incomaz Customized Hardware: ASUS A8V-E SE - Socket 939 AMD - Chipset VIA K8T890 AMD Athlon x64 3800+, 2x 1GB Kingston DDR400 RAM 1x 80Gb ATA ST380021A , 2x 250Gb SATA ST3250823AS Integrated VIA sound (K8T890 + ALC850) working stereo (AppleAC97Audio.kext mod). PCI old CMI8738 working 4.0 (dual stereo, due to modified kext). Common PCI 8139 lan. PCI-E SapphireATIx1600pro, 10.4.4kexts+borisbadenov method(not installer). USB working with IOUSBFamily.kext from 10.4.7. LG DVD-ROM DRD-8160B, HL-DT-ST DVDRAM GSA-4163B. PCI analog Avermedia tv studio 203. (Itv 0.4 can search, but all is yellow.. working on it..) Waiting for: 5.1 on ALC850 Integrated MB sound. CI, QE, 3dsupport on macvidia driver. Avermedia TV support (878 driver). So If anyone of you have the same system o parts of my system emailme and I'll help as much as I can. I have Ripples effect on dashboard, iphoto make all good. Quake4 works good. FrontRow
  12. I think that it will work with any Keyboard, or Keyboard+mouse combo. blah blah blah... = things that we will not change in that file. (all File couldn't be posted twice to show only two lines added on any place). Only you have to do is add that two lines where you see in that Info.plist.
  13. Hi all, It didn't work with my USB keyoard and mouse wireless combo. So searching I get a great solution for those that in your thread need a solution. The hack is in /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/IOUSBHIDDriver.kext/Contents/Info.plist (used by all common HID devices) Only change that Info.plist to put remote feature.. like this: /...blah blah blah../ <dict> <key>Generic Keyboard</key> <dict> <key>CFBundleIdentifier</key> <string>com.apple.iokit.IOUSBHIDDriver</string> <key>HIDDefaultBehavior</key> <string></string> <key>IOClass</key> <string>IOUSBHIDDriver</string> <key>IOProviderClass</key> <string>IOUSBInterface</string> <key>bInterfaceClass</key> <integer>3</integer> <key>bInterfaceProtocol</key> <integer>1</integer> <key>bInterfaceSubClass</key> <integer>1</integer> <key>HIDRemoteControl</key> <true/> </dict> </dict> /.... blah blah blah .../ Original file was like this: /..... Blah blah blah ..../ <dict> <key>Generic Keyboard</key> <dict> <key>CFBundleIdentifier</key> <string>com.apple.iokit.IOUSBHIDDriver</string> <key>HIDDefaultBehavior</key> <string></string> <key>IOClass</key> <string>IOUSBHIDDriver</string> <key>IOProviderClass</key> <string>IOUSBInterface</string> <key>bInterfaceClass</key> <integer>3</integer> <key>bInterfaceProtocol</key> <integer>1</integer> <key>bInterfaceSubClass</key> <integer>1</integer> </dict> </dict> /.... blah blah blah .../ As you can see only this two lines were added on the correct place: <key>HIDRemoteControl</key> <true/> After that reboot, install frontrow with pacifist and go command-esc Thanks, for all
  14. Ok, I got it working. Al I need is all ATI kext from 10.4.5, then I modified it (boris method).. and finally works...
  15. Hi all, I have a JaS 10.4.6 updated to 10.4.7 with AMD update to 10.4.7. Y bought a ATI x1600 card to replace my nv6600 (QE,CI rules!!). but I am a bit confused. Now I have 3d (chess game wors fine ), seems to be QE (I can minimize a dvd playing), but CI seems to be not working. For example, Core Image FUN House only shows white square... where must be an image.. Anyone can tell me if 10.4.4 ATINDRV.kext will fix it? ¿where can I find IT? (PM will be welcome) My profile manager looks like that.. (is all ok) Modelo de chipset: Radeon X1600 Series Tipo: Controlador compatible con VGA Bus: PCI Ranura: PCIEX16 VRAM (total): 256 MB Fabricante: ATI (0x1002) ID del dispositivo: 0x71c2 ID de la revisión: 0x0000 Pantallas: Pantalla VGA: Resolución: 1280 x 1024 @ 75 Hz Profundidad: Color de 32 bits Core Image: Compatible Pantalla principal: Sí Duplicado: Desactivado En línea: Sí Quartz Extreme: Compatible spdisplays_rotation: Compatible my kextstat is: sara:~ root# kextstat -l 1 1 0x0 0x0 0x0 com.apple.kernel (8.4.1) 2 12 0x0 0x0 0x0 com.apple.kpi.bsd (8.4.1) 3 15 0x0 0x0 0x0 com.apple.kpi.iokit (8.4.1) 4 16 0x0 0x0 0x0 com.apple.kpi.libkern (8.4.1) 5 14 0x0 0x0 0x0 com.apple.kpi.mach (8.4.1) 6 10 0x0 0x0 0x0 com.apple.kpi.unsupported (8.4.1) 7 1 0x0 0x0 0x0 com.apple.iokit.IONVRAMFamily (8.4.1) 8 1 0x0 0x0 0x0 com.apple.driver.AppleNMI (8.4.1) 9 1 0x0 0x0 0x0 com.apple.iokit.IOSystemManagementFamily (8.4.1) 10 1 0x0 0x0 0x0 com.apple.iokit.ApplePlatformFamily (8.4.1) 11 39 0x0 0x0 0x0 com.apple.kernel.6.0 (7.9.9) 12 1 0x0 0x0 0x0 com.apple.kernel.bsd (7.9.9) 13 1 0x0 0x0 0x0 com.apple.kernel.iokit (7.9.9) 14 1 0x0 0x0 0x0 com.apple.kernel.libkern (7.9.9) 15 1 0x0 0x0 0x0 com.apple.kernel.mach (7.9.9) 16 13 0x34d4c000 0xf000 0xe000 com.apple.iokit.IOPCIFamily (2.0) <11> 17 7 0x34d5e000 0x4000 0x3000 com.apple.iokit.IOACPIFamily (1.2.0) <11> 18 3 0x34d99000 0x37000 0x36000 com.apple.driver.AppleACPIPlatform (1.0.3) <17 16 11> 19 0 0x34e22000 0x5000 0x4000 com.apple.BootCache (25.1) <6 5 4 3 2> 20 3 0x34ee5000 0x32000 0x31000 com.apple.iokit.IOHIDFamily (1.4.7) <6 5 4 3 2> 21 0 0x34f28000 0x4000 0x3000 com.apple.driver.AppleAPIC (1.1.0) <11> 22 0 0x34f3e000 0x4000 0x3000 com.apple.driver.AppleSMBIOS (1.0.6) <11> 23 0 0x34fda000 0x4000 0x3000 com.apple.driver.AppleACPIButtons (1.0.3) <20 18 17 6 5 4 3 2> 25 0 0x3a29d000 0x3000 0x2000 com.apple.driver.AppleACPIPCI (1.0.3) <18 17 16 11> 26 0 0x3a311000 0x5000 0x4000 com.apple.driver.AppleRTC (1.0.2) <17 5 4 3 2> 28 1 0x3a493000 0x5000 0x4000 com.apple.driver.ApplePS2Controller (1.1.0) <11> 29 7 0x3a54e000 0x16000 0x15000 com.apple.iokit.IOStorageFamily (1.5) <6 5 4 3 2> 31 0 0x3a704000 0x3000 0x2000 com.apple.driver.ApplePS2Keyboard (1.1.0) <28 20 11> 32 3 0x3a7ce000 0xd000 0xc000 com.apple.iokit.IOATAFamily (1.6.0f2) <11> 34 0 0x3a8a5000 0x6000 0x5000 com.apple.driver.AppleVIAATA (1.0.2) <32 16 11> 35 9 0x3a912000 0x19000 0x18000 com.apple.iokit.IOUSBFamily (2.5.6) <11> 36 0 0x3a944000 0xc000 0xb000 com.apple.driver.AppleUSBUHCI (2.5.6) <35 16 11> 37 0 0x3a9ab000 0x10000 0xf000 com.apple.driver.AppleUSBEHCI (2.5.6) <35 16 11> 38 0 0x3a9f0000 0x9000 0x8000 com.apple.driver.AppleUSBHub (2.5.6) <35 11> 39 5 0x3aa53000 0x15000 0x14000 com.apple.iokit.IOSCSIArchitectureModelFamily (1.4.7) <11> 40 0 0x3aa74000 0x4000 0x3000 com.apple.iokit.IOATAPIProtocolTransport (1.4.3) <39 32 11> 41 0 0x3ab46000 0xa000 0x9000 com.apple.iokit.IOATABlockStorage (1.4.3) <32 29 11> 42 0 0x3ac41000 0x6000 0x5000 com.apple.iokit.SCSITaskUserClient (1.4.7) <39 29 11> 43 2 0x3ad8a000 0x8000 0x7000 com.apple.iokit.IOCDStorageFamily (1.4) <29 5 4 3> 44 1 0x3adba000 0x13000 0x12000 com.apple.iokit.IOSCSIBlockCommandsDevice (1.4.7) <39 29 11> 45 1 0x3ade3000 0x5000 0x4000 com.apple.iokit.IODVDStorageFamily (1.4) <43 29 5 4 3> 46 0 0x3ae14000 0x12000 0x11000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (1.4.7) <45 44 43 39 29 11> 47 0 0x3ae5b000 0x3000 0x2000 com.apple.driver.AppleUSBComposite (2.5.0) <35 11> 48 0 0x3af79000 0x9000 0x8000 com.apple.iokit.IOUSBMassStorageClass (1.4.2) <39 35 29 11> 49 0 0x3b071000 0x5000 0x4000 com.apple.iokit.IOUSBHIDDriver (2.5.5) <35 20 11> 50 2 0x3b147000 0x34000 0x33000 com.apple.iokit.IOBluetoothFamily (1.7.3f4) <11> 51 1 0x3b180000 0x5000 0x4000 com.apple.driver.AppleUSBBluetoothHCIController (1.7.3f4) <50 35 11> 52 0 0x3b1e9000 0x3000 0x2000 com.apple.driver.CSRUSBBluetoothHCIController (1.7.3f4) <51 50 11> 54 3 0x3a498000 0x1b000 0x1a000 com.apple.iokit.IOGraphicsFamily (1.4.3) <16 6 5 4 3> 55 2 0x3a4b3000 0xf000 0xe000 com.apple.iokit.IONDRVSupport (1.4.3) <54 16 6 5 4 3> 56 0 0x3a56f000 0x32000 0x31000 com.apple.kext.ATINDRV (4.3.4) <55 54 11> 58 2 0x3a707000 0x17000 0x16000 com.apple.iokit.IOAudioFamily (1.5.6b1) <35 11> 59 0 0x34f35000 0x5000 0x4000 com.homebrew.driver.CMI8738Audio (0.6.4) <58 16 11> 61 0 0x3a249000 0x9000 0x8000 com.apple.iokit.IOUSBUserClient (2.5.0) <35 11> 62 1 0x3a72e000 0xd000 0xc000 com.apple.driver.AppleAC97Audio (1.0.0) <58 11> 63 0 0x34f49000 0x4000 0x3000 com.apple.driver.AppleAC97AudioVIA (1.0.0) <62 16 11> 64 0 0x3a2a4000 0x4000 0x3000 com.apple.driver.AppleACPIThermal (1.0.3) <18 17 11> 65 2 0x3a316000 0x9000 0x8000 com.apple.iokit.IOSerialFamily (9.0.0d30) <6 5 4 3 2> 66 1 0x3a73b000 0x8000 0x7000 com.apple.driver.Apple16X50Serial (1.7) <65 16 11> 67 0 0x34f21000 0x2000 0x1000 com.apple.driver.Apple16X50ACPI (1.7) <66 17 11> 68 2 0x3a7e6000 0x16000 0x15000 com.apple.iokit.IONetworkingFamily (1.5.0) <6 5 4 3 2> 69 0 0x3a5a1000 0x4000 0x3000 com.apple.driver.AppleRTL8139Ethernet (1.2.0) <68 16 5 4 3 2> 70 0 0x3a7fc000 0x39000 0x38000 com.apple.iokit.AppleYukon (1.0.1b5) <68 16 11 2> 71 0 0x3a835000 0x49000 0x48000 com.apple.ATIRadeonX1000 (4.3.2) <55 54 16 11> 73 1 0x3a8dd000 0xa000 0x9000 com.apple.driver.AppleSMC (1.0.1d9) <17 5 4 3> 74 0 0x3a881000 0x3000 0x2000 com.apple.Dont_Steal_Mac_OS_X (6.0.0) <73 6 4 3 2> 75 0 0x3b092000 0x8000 0x7000 com.apple.filesystems.ntfs (1.2) <4 2> 76 0 0x3b07e000 0x9000 0x8000 com.apple.iokit.IOBluetoothSerialManager (1.7.3f4) <65 11>
×