Jump to content

jarodsix

Members
  • Content count

    47
  • Joined

  • Last visited

About jarodsix

  • Rank
    InsanelyMac Protégé
  1. Hi, thank you both (esp. MaLd0n) for providing the DSDT for this laptop, I appreciate it very very much. Since Lion, the VoodooBattery or AppleACPIBatteryManager don't work. There are good instructions why and how to fix this at http://www.insanelym...pic=272459&st=0 I went ahead and "fixed" the dsdt according to those instructions and now I have battery / AC recognized. It seems to work, though I still have to test it properly (I have been running mostly on AC, and just tested unplugging a couple of times). I share it here for your convenience, look into the file for comments to see the changes. In terms of other things: backlighting - I have not done anything in terms of PNLF, so I don't have the slider, but sometimes I can just change backlight levels using Fn keys (no OSD displayed, but backlight does change). After restart or wake-up (I believe) this ability is lost. I have to shut down, pull the AC plug, remove/insert battery to gain it back (I tried this once, maybe just a coincidence). In kernel log, there is "kernel[0]: Faking key release for brightness up" whenever I flip the wireless hw switch (wlan + BT). - maybe has to do sth with how voodooPS2 keyb works/maps the brightness, I dont know (beyond my knowledge). Firewire - i cannot find anything about firewire in dsdt. Maybe I am just looking in the wrong place. Nevertheless, if i put the laptop to sleep and then wake up, kernel starts complaining (kernel log) like "kernel: FireWire GUID 00d0510000000001 is invalid!" where the guid is indeed different than the one reported before sleeping. This message repeats itself every 30 seconds sharp. One further note: I am using 10.7.4 with ###### 4.5.2 -> UserDSDT - This includes both GeneratePStates / GenerateCStates == "Yes". - With both set to yes, the laptop was stuck at 800Mhz, i.e. would not speedstep. I discovered that disabling P state generation makes speedstep work. Confirmed via FakeSMC + IntelCPUPlugin + HWmonitor.app. As for CStates, leave that to Yes, otherwise AppleIntelCPUPM will complain about missing _CST. battery-repair.dsl.zip
  2. add npci=0x2000 into com.apple.Boot.plist of the disk you are trying to boot. You can use e.g. the lion boot DVD to get into your "dead" VM and use Terminal to edit /Volumes/<name of your disk drive>/Library/Preferences/SystemConfiguration/com.apple.Boot.plist Next you still have the LSI kext problem: AppleLSIFusionMPT.kext replace that with the one from 10.7/10.7.1, again use DVD to do that. http://www.insanelymac.com/forum/index.php...70140&st=20 edit: +1 mouse problem: http://www.insanelymac.com/forum/index.php?showtopic=270215
  3. jarodsix

    GeForce 6200 AGP on SL

    ad ADR - use DSDTSE from osx86.es - extract dsdt table, then search for 0x00010 and the rest should be self-explanatory. ad P4 - it is actually celeron SSE2 3 GHz. Installer havent tried, Safari works. It is VIA chipset, USB2.0 (ehci) does not work (freeze on plug-in). Errors on Realtek 8139 nic. AGP GPU nvidia 6200 stutters from time to time. Too problematic chipset (it was much better with 10.5). kernel is from http://nawcom.com/osx86/files/10.6/Kernels/10.0.0/ (i guess qoopz based kernel for legacy CPU)
  4. jarodsix

    GeForce 6200 AGP on SL

    SUCCESS! Hello, thank you for this tip. It works for me (Retail, Chameleon RC4 (EmpireEFI 1085), SL 10.6.0, SSE2 P4, 6200 AGP 128 MB, VGA/DVI). I removed ATY_init.kext. My device is also P0P1, so I just added the part starting from GFX0 and modified the VRAM size to 128MB (0x08), e.g.: "VRAM,totalsize", Buffer (0x04) { 0x00, 0x00, 0x00, 0x08 // this is 128 MB VRAM }, sample RAM sizes are here: http://forum.netkas.org/index.php?topic=222.0 I did not modify NVCAP, I did not know what to put there anyway, but your values work for me (I have VGA/DVI, until now only VGA tested). In addition I had to add the DTGP method, which was missing in my bios/dsdt. E.g. Notice that DTGP method is called near the end of this pcj's patch: }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) You need to add this method (if its missing in your file) otherwise you will get compile error (missing method). To add it take a look here (search for DTGP): http://www.insanelymac.com/forum/lofiversi...hp/t171183.html Another nice tutorial (about in the middle of the page): http://apocolipse.com/?p=14 Now heading to fixing my troubles with EHCI....
  5. I dont know how far the audio progress is right now (I read through this thread a couple of days ago) but I have found this interesting bit in Dell Manual for this notebook (see picture attached). The mic input is actually being used also as an output when using 5.1?
  6. jarodsix

    ALC262 driver with headphone speaker and mic

    Also on S7110 - I installed iPC Osx86 10.5.6, there is a ALC262 package, I guess that this is the same package or smth. Anyway, full support, thanks.
  7. jarodsix

    Solution for Realtek ALC262

    Hello, I just wanted to say that I have installed iPC Osx86 10.5.6 Uni Final (PPF5) and there is this ALC262 driver which JUST WORKS FOR ME 10000%: !!! Credits to the creator of this driver, you made me one hell of a happy man! I have a Fujitsu-siemens S7110 laptop, all listed working, incl volume control (as visible in Sound pref pane): 2 items in Output: Built-speakers, Headphones out -- these are actually 2 discrete stereo outputs which can be aggregated, just by running Doom3 with OpenAL i got 4 channel surround (Multichannel aggregation set up in Audio MIDI utility). 2 items in Input: Internal mic, external mic in. This laptop has powermanagement features, sometimes when I turn it on (on reboot to windows, or on battery esp), the sound is not coming out (only noise; hardware mute?). Most often it is sufficient no to reboot to windows too often! :-)
  8. jarodsix

    A List of external sounds that work

    I have this Hercules Muse Pocket LT USB card, and it works great, no extra drivers/patching, full support, also both inputs (mic and linein) work, so really it should be in the category USB 5.1 working in OS X: There is only one problem: you cannot selectively mute mic sound in front output (and pay attention I mean mic output, not mic recording levels set in sound/audio midi setup -- I mean the "Thru" checkbox in AUDIO/Midi does not work for this card). Of course you can just unplug the mic and that's it.
  9. jarodsix

    ATI Moblity Radeon HD 3650 on iDeneb 1.3

    This is precisely the behaviour in my HP 8530p. Fully working on external, nothing on internal (or garbage with another kexts). So I suppose I indeed have LVDS @0. So you are saying we just need a new/modified Megalodon framebuffer, or maybe could we use some other framebuffer that would support LVDS on internal screen? Just for a note, this HP 8530p has three connections: 1 internal (LCD), 2 external - VGA and HDMI.
  10. jarodsix

    ATI Moblity Radeon HD 3650 on iDeneb 1.3

    Once booted, it does not do anything at all (Fn-F4 in my case).
  11. jarodsix

    ATI Moblity Radeon HD 3650 on iDeneb 1.3

    No, internal is not working. To be precise, it first flashes in blue color, then is "covered" with black, however the back-light stays on. @ridgeline: yes, full res. switch works, incl. frequency Hz (CRT) Is there anything I could do to help out?
  12. jarodsix

    ATI Moblity Radeon HD 3650 on iDeneb 1.3

    I also have a HP 8530p laptop (T9400, mobility HD 3650, devid 9591) First I installed a driver package from here http://www.insanelymac.com/forum/index.php?showtopic=107526 but no success (garbage pattern on screen). Then I installed this package from sendspace and right now I have full res switch, QE, CI, playing Doom3 on ultrahigh quality :-) but as you probably know, only on external VGA monitor. To activate external monitor I had to Fn-switch the active screen to external at BIOS/bootloader prompt first, to get the system to startup on the external screen instead of internal LCD (which would otherwise just go black after startup). System profiler screenshot attached. So the acceleration support is working, just to get this display recognition worked-out and I am a happy man. :-)
  13. Little off-topic joke, but I visit zfs.macosforge.org very often for changes and nothing is moving there for quite a while. However I noticed a nice wishlist http://lists.macosforge.org/pipermail/zfs-...ber/001172.html
  14. jarodsix

    WWDC Roundup

    I expected the keynote to be much more technical, rather than just plain "last-year repetitory" zero-information talk. Safari on windows? Not that new in my opinion - what has iTunes been using for rendering the Store content for couple of years already? Isn't that webkit?
  15. jarodsix

    Drivers for my laptop AMILO Pro V3205

    http://wiki.osx86project.org/wiki/index.ph...AMILO_Pro_V3205 this above is a guide for 10.4.7 Now I have already installed 10.4.8 on it, but was lazy to write a newer description. Use 10.4.8 DVD and install GMA950 package (as opposed to what I wrote in the description for 10.4.7), but don't select it during installation, do it after installation using pacifist and replace on every question. V3205 line also includes Core2 duos, my was only Core Duo. With Core2 there are more problems. oh, and yes: modem doesn't work wifi driver for iwi3945 in progress (my wifi is this one, yours i guess too) http://code.google.com/p/iwidarwin/ sound only output, see instructions, though there is also a work in progress http://forum.insanelymac.com/index.php?sho...mp;#entry231456.
×