Jump to content
InsanelyMac Forum

Heepster

Just Joined
  • Content count

    4
  • Joined

  • Last visited

About Heepster

  • Rank
    InsanelyMac Protégé

Contact Methods

  • Website URL
    http://

Profile Information

  • Gender
    Male
  • Location
    Germany
  • Interests
    Music, Sports, Mac and Linux
  1. Star Wars Battlefront II

    Of course you can add your own version... But I would appreciate it if you add an small changelog ;D And yes you're right, my copy of the game is a german one
  2. Star Wars Battlefront II

    Hiho... I tried to run Star Wars Battlefront 2 (SWBF2) on my Mac and I've created an Image and a Readme... This version works great but it was not really much work (since cider 2060 is a great improvement) Maybe this download will save somebody somewhere some time Star Wars Battlefront 2 by Heepster Instructions: 1. Install Star Wars Battlefront 2 using Crossover, or Paralells (install using crossover did not work on every tested mac...) 2. Install the official Patch 1.1 from: ftp://ftp.lucasarts.com/patches/pc/BFIIUpdateInt1_1.exe International Version ftp://ftp.lucasarts.com/patches/pc/BFIIUpdateEngCD1_1.exe English Version (I've only tested 1.1 because there is no DVD-crack with working MP in the German version...) 3. Apply the No CD crack to your game-directory (override LaunchBF.exe and BattlefrontII.exe (in the GameData dir.) (I've included the crack into this Zip file because it was really hard to find an working Nocd fix for 1.1 4. Copy your "Star Wars Battlefront II Folder" to the "Move your Star Wars Battlefront 2 Folder here !" (The Folder is located at "C:\Program Files\Lucas Arts" in Paralells or at "/Users/<yourname>/Libary/CrossOver Games/Bottles/default/drive_c/Program Files/Lucas Arts") 5. If you did everything in the right order the Game should run;D Known issues: * Game does crash from time to time... * Multiplayer game browser (LAN) does not work all the time * shadows on high quality will slow your game! ... I did not test everything... feel free to do it yourself ! Version History V1.1 * ported to cider 2097 * fixed "high" texture settings bug * added DirectX files to improve stability V1.0 * initial release If you find bugs or know how to improve this version of cider please feel free to post here http://www.megaupload.com/de/?d=MMHV19MR (39mb)
  3. LotR: Battle for Middle-earth 2

    I tried 2060 but it doesn't work out here... V2060 does not start any exe other than the one from CoH... don't know why ^^ edit: I am talking nonsense.... Star Wars Battlefront 2 runs great with 2060... it's just BFME2 that doesn't work...
  4. LotR: Battle for Middle-earth 2

    Hi, I tried to port LotR: Battle for Middle-earth 2 with Cider and it works really good except for one stange bug (and on minor)... The game self defeats itself after 3min 30... My first thought was that it's a issue with the copy protection but the same version works good with CX-games and paralells (ok, paralells and cx are slow ;D )... I tried everything... I added the original Registry Keys to system.reg [Software\\Electronic Arts\\Electronic Arts\\The Battle for Middle-earth II] 1231178331 "InstallPath"="C:\\Program Files\\Electronic Arts\\Die Schlacht um Mittelerde II\\" "Language"="German" "MapPackVersion"=dword:00010000 "UseLocalUserMaps"=dword:00000000 "UserDataLeafName"="Meine Die Schlacht um Mittelerde II-Dateien" "Version"=dword:00010006 [Software\\Electronic Arts\\Electronic Arts\\The Battle for Middle-earth II\\ergc] 1231178331 @="MYKEY" [Software\\Electronic Arts\\The Battle for Middle-earth II] 1231178331 "CacheSize"="5499066368" "CD Drive"="D:\\" "DisplayName"="Die Schlacht um Mittelerde II" "Folder"="C:\\Documents and Settings\\All Users\\Start Menu\\Programs\\Electronic Arts\\Die Schlacht um Mittelerde II\\" "Install Dir"="C:\\PROGRA~1\\ELECTR~1\\DIESCH~1\\" "Installed From"="D:\\" "Language"="German" "Locale"="de" "Patch URL"="http://transtest.ea.com/Electronic Arts/The Battle for Middle-earth 2/NorthAmerica" "Product GUID"="{2A9F95AB-65A3-432c-8631-B8BC5BF7477A}" "Region"="NorthAmerica" "Registration"="Software\\Electronic Arts\\Electronic Arts\\The Battle for Middle-earth II\\ergc" "Suppression Exe"="rtsi.exe" "SwapSize"="0" [Software\\Electronic Arts\\The Battle for Middle-earth II\\1.0] 1231178331 "DisplayName"="Die Schlacht um Mittelerde II" "Language"=dword:00000003 "LanguageName"="German" I used this config and Cider 1430 from Spore WINE REGISTRY Version 2 ;; All keys relative to \\Machine\\Software\\Wine\\Wine\\Config ;; ;; MS-DOS drives configuration ;; ;; Each section has the following format: ;; [Drive X] ;; "Path"="xxx" (Unix path for drive root) ;; "Type"="xxx" (supported types are 'floppy', 'hd', 'cdrom' and 'network') ;; "Label"="xxx" (drive label, at most 11 characters) ;; "Serial"="xxx" (serial number, 8 characters hexadecimal number) ;; "Filesystem"="xxx" (supported types are 'msdos'/'dos'/'fat', 'win95'/'vfat', 'unix') ;; This is the FS Wine is supposed to emulate on a certain ;; directory structure. ;; Recommended: ;; - "win95" for ext2fs, VFAT and FAT32 ;; - "msdos" for FAT16 (ugly, upgrading to VFAT driver strongly recommended) ;; DON'T use "unix" unless you intend to port programs using Winelib ! ;; "Device"="/dev/xx" (only if you want to allow raw device access) ;; [Drive C] "Path" = "@BUNDLEPATHRESOURCE@/transgaming/c_drive" "Type" = "hd" "Label" = "Dos Drive" "Filesystem" = "win95" [Drive D] "Path" = "${HOME}" "Type" = "hd" "Label" = "My Home" "Filesystem" = "win95" [Drive E] "Path" = "/tmp" "Type" = "hd" "Label" = "tmp" "Filesystem" = "win95" [Drive F] "path" = "@BUNDLEPATHRESOURCE@/transgaming/f_drive" "Type" = "cdrom" "Label" = "cdrom" "Filesystem" = "win95" [Drive G] "Path" = "/" "Type" = "hd" "Label" = "root" "Filesystem" = "win95" [Drive P] "Path" = "@USERPREFS@/p_drive" "Type" = "hd" "Label" = "Dos Drive 2" "Filesystem" = "win95" [wine] "Windows" = "c:\\windows" "System" = "c:\\windows\\system32\\" "Temp" = "e:\\" "Path" = "c:\\windows\\;c:\\windows\\system32\\" "GraphicsDriver" = "sdldrv" "ShellLinker" = "/usr/lib/transgaming_cedega/winex/bin/wineshelllink" "MozillaControl" = "Y" "Browser" = "" [winspool] ;Set to "Y" to enable printing support. "Printer" = "N" # <wineconf> [DllDefaults] "DefaultLoadOrder" = "native, builtin, so" [DllOverrides] "commdlg" = "builtin, native" "comdlg32" = "builtin, native" "oleaut32" = "builtin, native" "ver" = "builtin, native" "version" = "builtin, native" "shell" = "builtin, native" "shell32" = "builtin, native" "shfolder" = "builtin, native" "shlwapi" = "builtin, native" "lzexpand" = "builtin, native" "lz32" = "builtin, native" "comctl32" = "builtin, native" "commctrl" = "builtin, native" "advapi32" = "builtin, native" "crtdll" = "builtin, native" "mpr" = "builtin, native" "winspool.drv" = "builtin, native" "d3d8" = "builtin, native" "d3d9" = "builtin, native" "d3drm" = "builtin, native" "ddraw" = "builtin, native" "dinput" = "builtin, native" "dinput8" = "builtin, native" "dmusic" = "builtin, native" "dsound" = "builtin, native" "opengl32" = "builtin, native" "msvcrt" = "native, builtin" "rpcrt4" = "native, builtin" "msvideo" = "builtin, native" "msvfw32" = "builtin, native" "quartz" = "builtin, native" "mcicda.drv" = "builtin, native" "mciseq.drv" = "builtin, native" "mciwave.drv" = "builtin, native" "mciavi.drv" = "native, builtin" "mcianim.drv" = "native, builtin" "msacm.drv" = "builtin, native" "msacm" = "builtin, native" "msacm32" = "builtin, native" "midimap.drv" = "builtin, native" "psapi" = "builtin, native" "wininet" = "builtin, native" "dbghelp" = "native, builtin" [Version] "Windows" = "winxp" "Cedega" = "tovik-22" ; DOS version to imitate ;"DOS" = "6.22" [pthreads] "PthreadsValue" = "default" [transgaming] "renice_wineserver" = "N" "working_directory" = "" "alsa_radio" = "Y" "oss_radio" = "N" "scheduler_value" = "No" [sdldrv] "ScreenDepth" = "32" "Desktop" = "N" "Enable3D" = "1" "ShowFPS" = "0" "DisplaySettingsDialog" = "0" [x11drv] "AllocSystemColors" = "100" "CopyDefaultColors" = "0" "PrivateColorMap" = "N" "PerfectGraphics" = "N" "Managed" = "Y" "Desktop" = "No" "UseDGA" = "N" "UseXShm" = "Y" "DXGrab" = "Y" "UseXVidMode" = "Y" "UseXRandR" = "N" "DesktopDoubleBuffered" = "Y" "TextCP" = "0" "ShowFPS" = "Y" "ShowMem" = "N" "VideoRam" = "256" "AGPVertexRam" = "128" "NV_VAR" = "Y" "ARB_VBO" = "Y" [d3dgl] "AnisotropicTextureFiltering" = "Y" "VertexShaders" = "Y" "PixelShaders" = "Y" "PixelShadersLevel" = "2.0" "ClipSpaceFix" = "Y" "FragmentOffset" = "Auto" "FixedProgram" = "Auto" "RectangleTextures" = "Auto" "DynamicVBO" = "N" "IndexVBO" = "N" "FBO" = "Y" "GLSL" = "M" "VertexShadersLevel" = "2.0" "FloatTextures" = "Y" "OcclusionQueries" = "Y" ;"Provides full compliance with native vertex shaders 'mova' command (Yes/No) "ForceMOVACompliance" = "N" [opengl] "FixedGLExtensionBuffer" = "N" "GLExtensionBuffer" = "" [dinput] ; dead zone for joystick input from 0 to 10000. 1000 is 10% of range. "DefaultDeadZone" = "1000" "AbsoluteMouseSensitivity" = "1" ;; Configuration of the function of joystick axes ;; The joystick name and axis functions can be determined with jstest. ;; The available axis types are: ;; "none", "X", "Y", "Z", "RX", "RY", "RZ", ;; "slider", "hat", "POV", and "ball" ;; "hat" and "POV" are synonymous. Hats use two axes. [fonts] "Resolution" = "96" "Default" = "-adobe-times-" "FreeType" = "Y" [FontPatterns] "Pattern0" = "-adobe-times*" "Pattern1" = "-adobe-helvetica*" "Pattern2" = "-adobe-courier*" "Pattern3" = "-misc-fixed*" ;"0"="/path/to/extra/fonts" [FontAlias] "MS Serif" = "Times New Roman" "Helv" = "Arial" "MS Sans Serif" = "Arial" "System" = "Arial" "Tahoma" = "Arial" ;; ;; Mono Space Fonts ;"Courier New"="Courier" ;"FixedSys"="Courier" ;; Disable the virtual memory manager (enabled by default) ; "MemoryManager" = "N" [serialports] "Com1" = "/dev/ttyS0" "Com2" = "/dev/ttyS1" "Com3" = "/dev/ttyS2" "Com4" = "/dev/modem" [parallelports] "Lpt1" = "/dev/lp0" [spooler] "LPT1:" = "|lpr" "LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -" "LPT3:" = "/dev/lp3" ;"read" = "0x779,0x379,0x280-0x2a0" ; "write" = "0x779,0x379,0x280-0x2a0" [spy] "Exclude" = "WM_SIZE;WM_TIMER;" [registry] "LoadGlobalRegistryFiles" = "Y" "LoadHomeRegistryFiles" = "Y" "LoadWindowsRegistryFiles" = "Y" "WritetoHomeRegistryFiles" = "Y" "SaveOnlyUpdatedKeys" = "Y" [Tweak.Layout] "WineLook" = "Win98" [Console] "Drivers" = "xterm" "XtermProg" = "konsole" ;"InitialRows" = "25" ;"InitialColumns" = "80" ;"TerminalType" = "nxterm" [Clipboard] "ClearAllSelections" = "0" "PersistentSelection" = "1" ; List of all directories directly contain .AFM files ;"1" = "/usr/share/ghostscript/fonts" ;"2" = "/usr/share/a2ps/afm" ;"3" = "/usr/share/enscript" ;"4" = "/usr/X11R6/lib/X11/fonts/Type1" [Wineserver] "SHMWineserver" = "Y" "Scheduler" = "N" ;;"Scheduler" = "Y" [WinMM] "Drivers" = "winemacca.drv" "WaveMapper" = "msacm.drv" "MidiMapper" = "midimap.drv" [wineoss] "UseMMap" = "Y" "FullDuplex" = "Y" "dsp0" = "/dev/dsp" "mixer0" = "/dev/mixer" [winealsa] "UseMMap" = "Y" "pcm0" = "hw" "ctl0" = "hw" "FullDuplex" = "N" ;; App default settings ;; Ereg [AppDefaults\\eReg.exe\\transgaming] "Disable" = "Y" I don't know, but I think it has to do with registry acess but I cant figure out how to solve... My second bug has to do with the cursor.... The "standard" cursor works very well but you can't see it anymore if it changes it's look (e.g. telling units to move) Sorry for my bad english
×