Jump to content
InsanelyMac Forum

darklok

Members
  • Content count

    10
  • Joined

  • Last visited

About darklok

  • Rank
    InsanelyMac Protégé
  • Birthday 09/21/1966

Contact Methods

  • Website URL
    http://

Profile Information

  • Gender
    Male
  • Location
    Montreal, Qc
  • Interests
    Hackintoshing, making music with Logic 8 and trying to push to the limits my knowledge with computers
  1. darklok

    Broadcom bcm43xx wireless driver [beta]

    Here is my setup: Dell D620 latitude with dell 1390 wifi card , 10.6.6 working wifi, ethernet, usb , etc... I have started to install 10.6.0 with Leppy D620SLV1 install disk, at that point everything worked right out of the box and it couldn't be simpler. Then i upgraded with 10.6.6 combo, and Wifi stopped working, then read for 2 hours trying to find solution and came across this post. Took both Kexts from IO80211 and IONetworkingFamily from my other computer running 10.6.3 and replaced them on my Dell with kext helper B7. Before rebooting, my wifi card was already working back as normal, so i rebooted and guess what ? IT still works !!! i did nothing more than replacing those two kexts, so for those having the same lappy as me, don't fuss around trying anithing else. Thanks to the original poster for the solution Darklock
  2. I am really happy for you wish you the best
  3. Hi, I really need your help guys, i want to be able to use my external audio firewire device and from what i read, AppleFWAudio.kext need to be loaded in order to be able to choose it from the list in the Audio and midi configuration panel. But when i try it manually, because it doesn't load at startup i get this: bash-3.2# kextutil AppleFWAudio.kext Warnings: The booter does not recognize symbolic links; confirm these files/directories aren't needed for startup: /System/Library/Extensions/AppleFWAudio.kext/Contents/CodeDirectory /System/Library/Extensions/AppleFWAudio.kext/Contents/CodeRequirements /System/Library/Extensions/AppleFWAudio.kext/Contents/CodeResources /System/Library/Extensions/AppleFWAudio.kext/Contents/CodeSignature (kernel) Refusing new kext com.apple.kext.OSvKernDSPLib, v1.3: a loaded copy with a different executable UUID is already present. (kernel) Refusing new kext com.apple.iokit.IOAudioFamily, v1.7.6f2: already have loaded v1.7f16. (kernel) kxld[com.apple.driver.AppleFWAudio]: The super class vtable '__ZTV13IOAudioEngine' for vtable '__ZTV22AppleFWAudioIsocEngine' is out of date. Make sure your kext has been built against the correct headers. (kernel) Can't load kext com.apple.driver.AppleFWAudio - link failed. (kernel) Failed to load executable for kext com.apple.driver.AppleFWAudio. (kernel) Kext com.apple.driver.AppleFWAudio failed to load (0xdc008016). (kernel) Failed to load kext com.apple.driver.AppleFWAudio (error 0xdc008016). Failed to load /System/Library/Extensions/AppleFWAudio.kext - (libkern/kext) link error. Check library declarations for your kext with kextlibs(8). bash-3.2# exit exit Martin-Larkins-Mac-Pro:~ Martin$ sudo tcsh [Martin-Larkins-Mac-Pro:~] root# cd /System/Library/Extensions/ [Martin-Larkins-Mac-Pro:/System/Library/Extensions] root# kextlibs AppleFWAudio.kext For x86_64: com.apple.iokit.IOAudioFamily = 1.7.6f2 com.apple.iokit.IOFireWireAVC = 4.0.6 com.apple.iokit.IOFireWireFamily = 4.2.6 com.apple.kpi.iokit = 10.4 com.apple.kpi.libkern = 10.4 com.apple.kpi.mach = 10.4 For i386: com.apple.iokit.IOAudioFamily = 1.7.6f2 com.apple.iokit.IOFireWireAVC = 4.0.6 com.apple.iokit.IOFireWireFamily = 4.2.6 com.apple.kpi.iokit = 10.4 com.apple.kpi.libkern = 10.4 com.apple.kpi.mach = 10.4 For ppc: com.apple.iokit.IOFireWireAVC = 4.0.6 com.apple.iokit.IOFireWireFamily = 4.2.6 com.apple.kpi.iokit = 10.4 com.apple.kpi.libkern = 10.4 com.apple.kpi.mach = 10.4 237 symbols not found in any library kext. [Martin-Larkins-Mac-Pro:/System/Library/Extensions] root# kextstat Index Refs Address Size Wired Name (Version) <Linked Against> 1 62 0 0 0 com.apple.kpi.bsd (10.4.0) 2 4 0 0 0 com.apple.kpi.dsep (10.4.0) 3 83 0 0 0 com.apple.kpi.iokit (10.4.0) 4 90 0 0 0 com.apple.kpi.libkern (10.4.0) 5 69 0 0 0 com.apple.kpi.mach (10.4.0) 6 27 0 0 0 com.apple.kpi.private (10.4.0) 7 45 0 0 0 com.apple.kpi.unsupported (10.4.0) 8 0 0 0 0 com.apple.kernel.6.0 (7.9.9) 9 0 0 0 0 com.apple.kernel.bsd (7.9.9) 10 1 0 0 0 com.apple.kernel.iokit (7.9.9) 11 0 0 0 0 com.apple.kernel.libkern (7.9.9) 12 0 0 0 0 com.apple.kernel.mach (7.9.9) 13 15 0x41ae0000 0x15000 0x14000 com.apple.iokit.IOPCIFamily (3.3.0) <7 5 4 3> 14 12 0x41af5000 0x4000 0x3000 com.apple.iokit.IOACPIFamily (1.3.0) <7 6 4 3> 15 2 0x41d2f000 0x41000 0x40000 com.apple.driver.AppleACPIPlatform (1.3.2) <14 13 7 6 5 4 3> 16 0 0x3b875000 0x2000 0x1000 com.psystar.driver.OpenHaltRestart (1.0.3) <4 3> 17 0 0x41a8a000 0x2000 0x1000 org.tgwbd.driver.NullCPUPowerManagement (1.0.0d2) <7 4 3> 18 2 0x41da6000 0x1d000 0x1c000 com.apple.iokit.IOGraphicsFamily (1.7.1) <13 7 5 4 3> 19 0 0x41a8c000 0x2000 0x1000 com.superhai.driver.PlatformUUID (1.0.0) <4 3> 20 0 0x41ad7000 0x4000 0x3000 com.superhai.driver.VoodooBattery (1.2.1) <14 4 3> 21 0 0x41de5000 0x20000 0x1f000 com.apple.driver.AppleIntelCPUPowerManagement (105.10.0) <7 6 5 4 3 1> 22 10 0x41e17000 0x18000 0x17000 com.apple.iokit.IOStorageFamily (1.6.1) <7 6 5 4 3 1> 23 0 0x41c7d000 0x11000 0x10000 com.apple.driver.DiskImages (283) <22 7 6 5 4 3 1> 24 0 0x41e82000 0x8000 0x7000 com.apple.nke.applicationfirewall (2.1.11) <7 6 5 4 3 1> 25 2 0x41c8e000 0x3000 0x2000 com.apple.kext.AppleMatch (1.0.0d1) <4 1> 26 0 0x41ced000 0x5000 0x4000 com.apple.security.quarantine (0) <25 7 6 5 4 2 1> 27 0 0x41e8a000 0x8000 0x7000 com.apple.security.sandbox (0) <25 7 6 5 4 2 1> 28 0 0x41d08000 0x3000 0x2000 com.apple.security.TMSafetyNet (6) <7 6 5 4 2 1> 29 0 0x41c71000 0x2000 0x1000 org.voodoo.driver.VoodooTSCSync (1.1) <7 4 3> 30 0 0x41d05000 0x3000 0x2000 com.apple.driver.AppleAPIC (1.4) <4 3> 31 0 0x41d0b000 0x4000 0x3000 com.apple.driver.AppleSMBIOS (1.6) <7 4 3> 32 6 0x47b1a000 0x3c000 0x3b000 com.apple.iokit.IOHIDFamily (1.6.4) <7 6 5 4 3 1> 33 0 0x41e10000 0x4000 0x3000 com.apple.driver.AppleACPIButtons (1.3.2) <32 15 14 7 6 5 4 3 1> 34 0 0x41e14000 0x3000 0x2000 com.apple.driver.AppleHPET (1.5) <14 7 5 4 3> 35 0 0x41f4d000 0x6000 0x5000 com.apple.driver.AppleRTC (1.3.1) <14 5 4 3 1> 36 0 0x41f2d000 0xb000 0xa000 com.apple.driver.AppleIntelIntegratedFramebuffer (4.2.0) <18 13 10 7 5 4 3> 38 0 0x41e0d000 0x3000 0x2000 com.yourcompany.driver.AppleACPIPS2Nub (1.0.0d1) <14 7 5 4 3 1> 39 8 0x47c75000 0x31000 0x30000 com.apple.iokit.IOUSBFamily (4.0.2) <13 7 5 4 3 1> 40 0 0x47c36000 0x10000 0xf000 com.apple.driver.AppleUSBUHCI (4.0.2) <39 13 7 5 4 3 1> 41 1 0x41f38000 0x3000 0x2000 com.apple.iokit.IOSMBusFamily (1.1) <5 4 3> 42 0 0x41f65000 0x5000 0x4000 com.apple.driver.AppleACPIEC (1.3.2) <41 15 14 5 4 3> 43 0 0x41f3b000 0x4000 0x3000 org.netkas.fakesmc (2) <14 7 4 3> 44 1 0x41f5b000 0x3000 0x2000 com.apple.driver.AppleEFIRuntime (1.3.0) <7 5 4 3> 45 2 0x47c16000 0xd000 0xc000 com.apple.iokit.IOATAFamily (2.5.1) <5 4 3 1> 46 0 0x47c23000 0x9000 0x8000 com.apple.driver.AppleIntelPIIXATA (2.5.1) <45 13 5 4 3> 47 2 0x47c30000 0x6000 0x5000 org.voodoo.driver.PS2Controller (1.1.0) <14 7 5 4 3 1> 48 1 0x47c4a000 0x4000 0x3000 com.apple.kext.OSvKernDSPLib (1.3) <5 4> 49 1 0x47cf0000 0x17000 0x16000 com.apple.iokit.IOAudioFamily (1.7.0fc16) <48 5 4 3 1> 50 0 0x47cbb000 0x22000 0x21000 org.voodoo.driver.VoodooHDA (0.2.1) <49 13 7 5 4 3 1> 51 2 0x47c4e000 0x6000 0x5000 com.apple.iokit.IOAHCIFamily (2.0.4) <5 4 3 1> 52 0 0x47c60000 0x14000 0x13000 com.apple.driver.AppleAHCIPort (2.1.2) <51 13 5 4 3 1> 53 0 0x47d4d000 0x16000 0x15000 com.apple.driver.AppleUSBEHCI (4.0.2) <39 13 7 5 4 3 1> 54 0 0x47ce7000 0x6000 0x5000 com.apple.driver.AppleEFINVRAM (1.3.0) <44 7 5 4 3> 55 3 0x47df6000 0x43000 0x42000 com.apple.iokit.IOFireWireFamily (4.2.6) <5 4 3 1> 56 0 0x47d24000 0x27000 0x26000 com.apple.driver.AppleFWOHCI (4.7.1) <55 13 7 6 5 4 3 1> 57 0 0x41e05000 0x2000 0x1000 com.apple.iokit.IOUSBUserClient (4.0.0) <39 7 5 4 3 1> 58 0 0x47dbd000 0x11000 0x10000 com.apple.driver.AppleUSBHub (4.0.0) <39 5 4 3 1> 59 0 0x47ddd000 0x13000 0x12000 com.apple.iokit.IOAHCIBlockStorage (1.6.2) <51 22 5 4 3 1> 60 0 0x47f01000 0x4000 0x3000 org.voodoo.driver.PS2Mouse (1.2.0) <47 32 7 6 5 4 3 1> 61 0 0x47f05000 0x4000 0x3000 org.voodoo.driver.PS2Keyboard (1.1.0) <47 32 7 6 5 4 3 1> 62 5 0x47f42000 0x1a000 0x19000 com.apple.iokit.IOSCSIArchitectureModelFamily (2.6.5) <5 4 3 1> 63 0 0x47d91000 0x5000 0x4000 com.apple.iokit.IOATAPIProtocolTransport (2.5.1) <62 45 5 4 3 1> 64 0 0x47f3f000 0x3000 0x2000 com.apple.driver.XsanFilter (402.1) <22 5 4 3 1> 65 3 0x47fae000 0x8000 0x7000 com.apple.iokit.IOCDStorageFamily (1.6) <22 5 4 3 1> 66 2 0x47fd5000 0x6000 0x5000 com.apple.iokit.IODVDStorageFamily (1.6) <65 22 5 4 3 1> 67 1 0x47ffc000 0x5000 0x4000 com.apple.iokit.IOBDStorageFamily (1.6) <66 65 22 5 4 3 1> 68 0 0x48042000 0x18000 0x17000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (2.6.5) <67 66 65 62 22 5 4 3 1> 69 0 0x47fa0000 0x7000 0x6000 com.apple.iokit.SCSITaskUserClient (2.6.5) <62 22 5 4 3 1> 70 1 0x47c2c000 0x4000 0x3000 com.apple.driver.AppleUSBComposite (3.9.0) <39 4 3 1> 71 0 0x47fdb000 0x4000 0x3000 com.apple.driver.AppleUSBMergeNub (4.0.0) <70 39 4 3 1> 72 0 0x480d2000 0xb000 0xa000 com.apple.iokit.IOUSBMassStorageClass (2.6.1) <62 39 22 5 4 3 1> 73 0 0x480b5000 0x18000 0x17000 com.apple.iokit.IOSCSIBlockCommandsDevice (2.6.5) <62 22 5 4 3 1> 74 1 0x47f7d000 0x2000 0x1000 com.apple.driver.AppleHIDKeyboard (1.2.0a3) <32 4 3> 75 1 0x48071000 0x6000 0x5000 com.apple.iokit.IOUSBHIDDriver (4.0.2) <39 32 5 4 3 1> 76 0 0x47f8d000 0x2000 0x1000 com.apple.driver.AppleUSBHIDKeyboard (1.2.0a3) <75 74 32 4 3> 77 2 0x48108000 0x16000 0x15000 com.apple.iokit.IONetworkingFamily (1.8) <7 6 5 4 3 1> 79 0 0x4823b000 0x6000 0x5000 com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0d1) <6 4 3 2 1> 80 0 0x48241000 0x5000 0x4000 com.apple.BootCache (31) <7 6 5 4 3 1> 81 2 0x484fd000 0xa000 0x9000 com.apple.driver.AppleSMC (3.0.1d2) <14 7 5 4 3> 82 1 0x4857c000 0xb000 0xa000 com.apple.driver.IOPlatformPluginFamily (4.1.2b1) <6 5 4 3> 83 0 0x48592000 0x10000 0xf000 com.apple.driver.ACPI_SMC_PlatformPlugin (4.1.2b1) <82 81 14 13 7 6 5 4 3> 84 0 0x48552000 0x10000 0xf000 com.apple.iokit.IOFireWireAVC (4.0.6) <55 5 4 3 1> 85 0 0x4826e000 0x3000 0x2000 com.apple.driver.AppleLPC (1.4.12) <13 5 4 3> 86 7 0x48692000 0x2c000 0x2b000 com.apple.iokit.AppleProfileFamily (41) <13 7 6 5 4 3 1> 88 0 0x4845a000 0x5000 0x4000 com.apple.driver.AppleUpstreamUserClient (3.3.2) <18 14 13 7 5 4 3 1> 90 0 0x4852d000 0x9000 0x8000 com.apple.iokit.IOFireWireIP (2.0.3) <77 55 5 4 3 1> 91 0 0x487f5000 0x2c000 0x2b000 com.apple.iokit.AppleYukon2 (3.1.14b1) <77 13 5 4 3 1> 93 0 0x48475000 0x6000 0x5000 com.apple.Dont_Steal_Mac_OS_X (7.0.0) <81 7 4 3 1> 95 1 0x485e9000 0x9000 0x8000 com.apple.iokit.IOSerialFamily (10.0.3) <7 6 5 4 3 1> 96 0 0x485fe000 0x9000 0x8000 com.apple.iokit.IOBluetoothSerialManager (2.3.3f8) <95 7 5 4 3 1> 97 0 0x48512000 0x5000 0x4000 com.apple.driver.AppleIntelYonahProfile (14) <86 6 4 3> 98 0 0x485d8000 0xb000 0xa000 com.apple.iokit.IOSurface (74.0) <7 5 4 3 1> 99 0 0x418cb000 0x3000 0x2000 com.apple.driver.AppleProfileCallstackAction (20) <86 5 4 3 1> 100 0 0x418d4000 0x3000 0x2000 com.apple.driver.AppleProfileKEventAction (10) <86 4 3 1> 103 0 0x418e5000 0x3000 0x2000 com.apple.driver.AppleProfileRegisterStateAction (10) <86 4 3 1> 104 0 0x418e8000 0x3000 0x2000 com.apple.driver.AppleProfileThreadInfoAction (14) <86 6 4 3 1> 105 0 0x4192e000 0x3000 0x2000 com.apple.driver.AppleProfileTimestampAction (10) <86 5 4 3 1> 106 0 0x41910000 0x3000 0x2000 com.apple.driver.AppleProfileReadCounterAction (17) <86 6 4 3> 107 0 0x41959000 0xa000 0x9000 com.apple.filesystems.autofs (2.1.0) <7 6 5 4 3 1> 108 1 0x49680000 0x60000 0x5f000 com.apple.filesystems.ntfs (3.2) <7 6 5 4 1> 109 2 0x41fb1000 0xd000 0xc000 com.apple.filesystems.msdosfs (1.6.1) <7 5 4 1> 111 1 0x49a04000 0x9000 0x8000 com.apple.filesystems.cd9660 (1.4.1) <7 6 5 4 3 1> [Martin-Larkins-Mac-Pro:/System/Library/Extensions] root# I am screwed up like hell, sorry but i am no geek in MAC world, i have much more experience with Windows and can find my way through My question is, how to tell a kext file to load at startup and what to check if it doesn't load why doesn't it load now System_log.zip i have included logs from IOregistryexplorer and system profiler to help you help me Thanks a bunch guys Darklok
  4. Hi there, From what i see and the little experience i got , i think your bootloader is screwed up, you probably need to reboot with the boot cd from chameleon, or whatever homebrew cd you made and when you get to the boot screen choose your Snow leopard HD then boot, it's supposed to get you there. Then re-install the bootloader from your desktop. I hope it's gonna work for you
  5. Hi Guys, I've read a lot the last 2 days or maybe 3 !!, it's so loooong!!, so now i've decided to post to see if i can get some help First of all, i Have a Gateway Laptop Mt 6840 with an Intel Core Duo @ 2.00 Ghz My first experience was with the kalyway Distro 10.5.2 and everything (almost) went well, except for the Yukon Marvell 88E8038 Ethernet and it's been solved in a matter of days, searching the forum and finding the solution provided by Chun-nan with IOPCIFamily test 7 and modifying my AppleYukon2.kext within IONetworkingFamily.kext with the appropriate Model and Vendor ID found under Windows. On Monday i installed Snow leopard retail 10.6.3 booting with D620SLV1 cd. I know it's not exactly intended for my computer, but since it's working, i installed it , Updated with Combo 10.6.4 and launched the post install to install Chameleon 2 rc3, then reboot. Network was not working, and another time finding my way through the forum, i finally found a working solution, i actually installed OIPCMCIAFamily.kext i found in one post , but in the meantime, it screwed up my Firewire interface FCA202 Behringer and i could not see it anymore in System Profiler. i Removed that and extracted the IOPCIFamily.kext from within IOPCMCIAFamily.kext and installed it, and to my big surprise it worked right away. So now i have Ethernet working , my Firewire shows up in System Profiler, but now here is the problem, i can't select it as a coreaudio device in the Audio and Midi Configuration panel. the laptop uses this chip for Cardbus and Firewire : TI PCI-8412 My question is : can i use AppleFWAudio.kext from 10.5.2 and modify it so it could be loaded by 10.6.4, and second, is it the only kext i would have to modify (was thinking about IOFireWireFamily.kext) since i am a noob, and i made a real effort not to ask anyone before getting stuck. Here i will provide IORegexplorer files before i made my modifications and after so you can compare and will provide System profiler log too System_log.zip I thank you very much guys and in the meantime i will keep looking on google Darklok
  6. darklok

    Marvell Yukon 88E8038 on Snow Leopard Yet?

    I already did that with Kalyway 10.5.2 With Chunnan IOPciFamily test7 and i got my Marvell Yukon 88E8038 working right Away (and My Firewire didn't screw up) But this time With a retail Install of 10.6.3 + Combo Update 10.6.4 i've tried IOPCMCIAFamily.kext you were providing in your post (i know it's from Chunnan) and it worked right away for my Ethernet card, but the problem is that it screwed up my Firewire, couldn't see it anymore in System Profiler, so here's what i did: i took the IOPciFamily.kext from within IOPCMCIAFamily.kext and installed it over the original one with kext utility, and you know what ?, it worked, i have my network working and i can see My External Firewire Device in System profiler, but still can't select it as an audio interface in Audio and Midi Configuration, but that's another story. That means, if you don't want to screw up External Firewire(Mine is Behringer FCA 202) just use the IOPCIFamily.kext within IOPCMCIAFamily.kext. Just my two cents Darklock
  7. Thanks a lot Bitrip, i left a comment in your profile.
  8. Thanks a lot for

    your lightning fast answer.

    really appreciated

  9. Hi all, i got a stripped down version of Logic Pro 8 to try it out before buying the whole Logic Studio and the channel strip settings folder is empty and all the .cst files are missing. I was wondering if someone could be kind enough to provide me an URL with the content of this folder so i can try it. I thank you very much for your help, regards P.S: those files are quite small since these are just settings. Thanks to Bitrip for giving me an answer , this helped me a lot
  10. darklok

    HOW TO: sigmatel 9250 audio :TUTORIAL

    Hi all, I did the tutorial step by step, quite easy and reboot, and VOILA! it works like a charm i have a Gateway MT6840 With a Sigmatel 9250 audio built-in speakers works, they mute when i plug my headphones Microphone works too No mute possible Thanks a thousand times Taruga, very appreciated, keep the good work
  11. darklok

    Marvell Yukon 88E8038 Fast Ethernet

    Hi Guys, I'm really proud to say that i found the solution to my problem and ethernet is working now, i've applied the IOPCIFamily test 7 from Chun-nan with the modifications in IONetworkingFamily.kext changing manually my device name and device ID. I have to say that this is the 2nd day that i installed Kalyway 10.5.2 and i never touched before a Mac, i should say a Hackintosh,i've learned a lot in 2 days and proud of myself because i never asked anyone, only by searching through the forum and reading like 10 or more hours in 2 days. Thanks Chun-nan, Kizwan for your post and everybody else that had to do with IOPCIFamily.kext modification My notebook is a Gateway Mt6840 Still no sound but working on it Darklok
×