Jump to content

CryzHiss

Members
  • Content count

    32
  • Joined

  • Last visited

Everything posted by CryzHiss

  1. As I've noted before, my m1530 (running Mavericks, DarwinX's Kexts and DSDT and Chameleon) doesn't recognise when FireWire-harddrives are plugged in, if they are not already plugged in at boot up. Today, I've discovered that the same applies for my VGA port: if a display is connected at boot up, it is recognised and the desktop is expanded. If I unplug the display, OS X doesn't notice it and still thinks the display is plugged in.The windows don't return to the primary display, and I can still arrange "both" displays in System Settings. Consequently, plugging the cable back in brings back the second display. But if I boot without a second monitor connected via VGA, I can't plug one in. So it seems like the ports are not triggering the "plugged in" event in the kernel. Any ideas why?
  2. Does anybody have issues with FireWire after updating to Mavericks? I can only get external hard drives to show up when they are plugged in and running before boot-up. The port itself is always listed in System Information.app and I never had problems with FireWire before Mavericks. I did a clean install and tried to get it to work with two different hard disks. I only have one Mini FireWire -> FireWire cable, though.
  3. I haven't put my laptop to sleep since the 10.8.5 update, but I am having the same problem. Black screen when waking up with no option but to do a hard reboot. Have you cleaned the fan and reapplied the thermal paste recently? I have done this fairly recently (~4 months ago?) and my temperatures are very much like DarwinX' with the DSDT he posted for 10.8.5, maybe a little bit lower when not under load (CPU 44, GPU 60, Ambient 17; CPU 58, GPU 68 while watching a video on youtube). CPU History: GPU History:
  4. Wow, thank you! I think this fixed the kernel panic I got when reading specific info about my GPU (like in System Profiler or iStat Menus) since I installed ML. I'm not going to revert the changes and check, so either way, I'm blaming you . Thanks again!
  5. After months and months, I have just figured out what caused my sleep-problem, and now I feel like I should have found it earlier. I thought I should share it, in case anyone else comes across it: Don't use VoodooSDHC.kext v2.0. It's bad. I noticed this when trying to copy some pictures off of an SD card. As it turned out, the SD card wasn't recognized, so I removed VoodooSDHC v2.0, installed v1.1.2b, and voilá: no problem reading my SD card. Then I tried my luck with putting my Hack to sleep, and that worked, too! You can find VoodooSDHC v1.1.2b in the 10.7.4-pack that has been posted a couple of pages back.
  6. I can confirm that your DSDT works on M1530. Thank you!
  7. Thank you, I'll dig through it some time this weekend.
  8. Alright, you should find all relevant information in my signature. I don't have an external display connected, or anything else that's messing with my GPU.
  9. Yes, they were installed in both places. I figured that out when I was digging through those kexts some days ago and deleted them from /S/L/E, so now they are just inside FakeSMC.kext. I also made sure to reinstall exactly that version of FakeSMC and rebuilt the caches, but I'm still able to trigger KPs like before. I also tried installing them in both places, but - as expected - no dice. Disabling GraphicsEnabler in Chameleon did not help, either. Oh well, if it works for you, there must be something wrong on my end. I even switched my IOPCIFamily.kext back to the original, but of course, that didn't help either.
  10. I followed your guide and it worked great, thanks for that! So for, I only encountered 3 problems: (1) sleep does not work. The screen goes black, but the fans keep running. It's not possible to wake up from sleep, either, though. Hibernatemode is 0, and I also disabled "Wake for ethernet network access" as you suggested. (2) I get KPs every time go to About this Mac -> More info.... This also happens when I start iStat Menus. (3) Restart does not seem to work. Here is a list of the kexts I added to /S/L/E (+AppleACPIPlatform from SL): Most of the kexts are from DarwinXs 10.7.4 package. FakeSMC is the one you suggested. Is any of these kexts unnecessary or causing any of the issues listed above? Or are any fundamental kexts missing? Thanks for any replies Edit: (2) I was able to isolate this issue to the GPU. Opening System Information directly works, but clicking on "Graphics/Displays" causes the KP (everything else works fine). Deleting NVClockX.kext did NOT solve the problem, but I guess it didn't hurt either.
  11. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    D'oh. Should have thought of that. Thank you very much, I think that did the job. At least my laptop is about 5-10°C cooler than before under normal load, and it didn't go over 75°C during a quick test.
  12. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    I'm having some heat-problems recently. While gaming (I tried World of Warcraft, The Sims, Urban Terror), my laptop gets very hot, constantly about 85-95°C. Sometimes, it appears to jump over 100°C, and my laptop shuts off (because of the hardware, I guess). I don't know when this started, I only now that I did not have these problems about 3 months ago. It only appears when the both GPU and CPU are 'heavily' used. I tried various fan-controlling applications, but none of them worked. I8kfan at least shows me the RPM of my fan, and says that it never speeds up fully, even at 97°C. My constant temperature is about 50-55°C (while using Adium, Thunderbird, iTunes, Textedit, Skype, Firefox, Safari, ...). I have an M1530 with 2.4Ghz, Nvidia GeForce 8600M GT with 256mb, and 4GB RAM. I built my own DSDT with the guide by immo linked in this thread, with working speedstep and graphics (QE,CI). Does anybody have any ideas how to fix this issue? I would be very thankful CryzHiss
  13. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    Okay, this is interesting. I thought I'm the only one with problems with the fingerprint sensor. Every.. 2. boot or so, it stops working. Since I don't have any other USB hardware connected, I didn't realize it was a problem of USB. (Also M1530, T8300)
  14. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    If you have Chameleon 2.0 installed, you need to place the DSDT.aml in the /Extra-Folder, else in the root, as you said. The Terminal-commands are: (for Chameleon 2.0) sudo chmod 755 /Extra/DSDT.aml sudo chown 0:0 /Extra/DSDT.aml (for every other bootloader) sudo chmod 755 /DSDT.aml sudo chown 0:0 /DSDT.aml And also a thanks from me for the update, Chrysaor!
  15. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    Did anyone already update to 10.5.8?
  16. Was the WiFI hardware switch on at boot? Wifi doesn't work if you turn it on after boot, at least on my retail install.
  17. CryzHiss

    10A421A in Software Update

    I found this in the logs of my iMac too
  18. CryzHiss

    Core Duo

    It is 32bit only.
  19. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    First: Thanks for the link, I'll try it. The "PDF issue" is not a problem of our hacks. I tried scrolling the "subwaymap.pdf" on my real iMac (with 10.6, 10A411) and it's also stuttering in Preview. Edit: I installed the linked kext, but I don't see a real change. I made one test before installing and two tests after with XBench, and there is (except for variing results) no huge difference.
  20. CryzHiss

    New featurettes

    Found two small ones: If you draw boxes on your Desktop, they fade out smoothly After setting up syncing between iCal and my Google Calender, Safari automatically filled out the login form for gmail (should be the same if you add a GMail Account to Mail)
  21. CryzHiss

    New featurettes

    Why should things like the support of text clippings in Quicklook not be present in the final build? It's wise, because everyone would laugh if Steve praises that now the menubar fades out while using Exposé in one of his announcements / if Apple praises this as a big new feature on its page about SL?
  22. CryzHiss

    Retail OSX loepard on DELL M1330 problems

    Did you try to use the [GUIDE] Leopard on an XPS 1330/1530?
  23. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    @ab___73 Good to know that I'm not the only one having these problems And really THANK YOU for the updated VoodooPSTrackpad.kext! Works great, much better than FFScroll did (at least for me)!
  24. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    @arsenalsam7 If it's not 80 or 82 either, I don't know, I'm sorry. -- Is anyone else having problems with alt + cmd-keys being swapped on the M1530 keyboard with VoodooPS2Controller.kext? I played a little bit around this afternoon and managed to fix it, at least for me. So, if anyone is able to make use of my edited kext, feel free to do so. (The VoodooPS2Trackpad.kext if the one ab___73 edited, thanks for this!) VoodooPS2Controller.kext.zip
  25. CryzHiss

    [GUIDE] Leopard on an XPS 1330/1530

    Check in System Preferences if your Computer tries to go to sleep after about 5 minutes. If yes, make sure you installed the VoodooUSBEHCI.kext correctly:
×