Jump to content

yehia2amer

Members
  • Content Count

    242
  • Joined

  • Last visited

About yehia2amer

  • Rank
    InsanelyMac Geek

Profile Information

  • Gender
    Male
  • Location
    egypt

Recent Profile Visitors

7,946 profile views
  1. Problem: When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake ! This Machine has a 1300W Power Supply So Sleep is Very Useful. I Tried: 1) FIX_WAK and FixShutdown as per Clover Wiki. 2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject 3) Tried to Run this command: disablehibernate.command.zip 4) Tried darkwake=0 to 10 5) Disabled wake on USB & Wake on LAN (BIOS) Logs: sudo pmset -g System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions 2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler Specs: CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors RAM: 128 GB 1333 MHz DDR3 ECC Memory GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5 Chipset: Intel C602 Audio: Realtek ALC3220 (ALC280) High Definition Audio SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support Network Controller 2: Intel Ethernet Controller I210  NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202 for more info: Any Help will be appreciated, Thanks ! Send me Yehias-Mac-Pro.zip
  2. yehia2amer

    AppleALC — dynamic AppleHDA patching

    yeah my fault again, I must remove the Line Out Jack for the Headphone to work. This makes me confused each time
  3. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Now in I do have 2 options for input: Internal Microphone: this Represent Rear Jack Mic and it is working Line In: Not working Regarding the headphone, it is not working. Line Out (Rear Jack) is working normally ALC3220 LayoutID 21 test 6.ioreg.zip
  4. yehia2amer

    AppleALC — dynamic AppleHDA patching

    1) Now Headphone is not working at all, I even tried to remove the Rear Jack and only connect Headphone. but it is still not working 2) Front Mic and Rear Mic are also not working ALC3220 LayoutID 21 test 5.ioreg.zip
  5. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Not working. Yeah me too, I need to go get some sleep before Salah, Can we complete tomorrow ?, it is 6:30 AM here in Egypt and i didn't sleep yet. Thanks a lot for your help and جمعة مباركة ALC3220 LayoutID 21 test 4.ioreg.zip
  6. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Ooops my fault, they both work now. Working: Headphones (Green Front) Line-Out (Green Rear) Microphone/Line In (Blue Rear) Not Working: Microphone (Pink Front)
  7. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Still the Same. I know, I am a programmer and I don't even know how can you do that Really appreciate what you do, I hope that one day I can do it myself. ALC3220 LayoutID 21 test 3.ioreg.zip
  8. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Still the Same: Working: Headphones (Green Front) Microphone/Line In (Blue Rear) Not Working: Line-Out (Green Rear). ----> Strange it is not working as it used to work on Layout ID 13 Microphone (Pink Front) btw: Regarding the Speaker, I am not sure it is analog or not. maybe I am wrong ! ALC3220 LayoutID 21 test 2.ioreg.zip
  9. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Working: Headphones (Green Front) Microphone/Line In (Blue Rear) Not Working: Speaker (Analog) Line-Out (Green Rear) Microphone (Pink Front)
  10. yehia2amer

    AppleALC — dynamic AppleHDA patching

    ALC3220 LayoutID 21.ioreg.zip
  11. yehia2amer

    AppleALC — dynamic AppleHDA patching

    This is a Dell Precision T7610 Workstation and it do have built in Speaker which is not working and also it do have 2 mic ports, one in front and one in the back of the machine and both of them are not working using layout ID 13 you can find all the motherboard details in the owner's manual here: https://downloads.dell.com/manuals/all-products/esuprt_desktop/esuprt_dell_precision_workstation/precision-t7610-workstation_owner's manual_en-us.pdf
  12. yehia2amer

    AppleALC — dynamic AppleHDA patching

    @Andres ZeroCross do you have time now ?
  13. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Sure, Appreciate your help. I am Ready now if you are !
  14. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Hi @Andres ZeroCross Can you Help me on Fixing those not working Ports ? Is there anything that I Can do to fix them ?
  15. yehia2amer

    AppleALC — dynamic AppleHDA patching

    Hi All, Dell Precision T7610 Workstation ALC3220 (ALC280) Mojave 10.14 (18A391) I Tried All Layout IDs for ALC280 (3,4,11,13,15) Layout 13 is the Only one that partially works. Headphones (Green Front) , Line-Out (Green Rear) Working. Speaker (Analog) , Microphone (Pink Font) , Microphone/Line In (Blue Rear) Not Working. Attached Info.plist, ioreg for each Layout ID Tested. Codec Dump: https://github.com/yehia2amer/Dell-Precision-T7610-Workstation-Hackintosh-Guide/blob/master/Linux ACPI %26 Sound Dump/asound/codec_dump.txt Thanks. AppleALC ALC3220 Tested LayoutIDs.zip
×