Jump to content
InsanelyMac Forum

sunkid

Members
  • Content count

    36
  • Joined

  • Last visited

About sunkid

  • Rank
    InsanelyMac Protégé
  1. You could try to mount the specific directory on your client instead of mounting the root directory of the NAS. If you need both, you may have to work with your IT department to enable this on their end. My own setup is much like this and supports several users. The storage space is a large RAID array on a server. I export individual directories from it via the Linux version of Apple Talk (atalk). This way, individual users see different shares when they connect to the server. Here is a generic view of my AppleVolumes.default configuration file: /mnt/raid/sunkid backups allow:sunkid cnidscheme:cdb options:usedots,upriv /mnt/raid/shewhomustbeobeyed backups allow:lovey cnidscheme:cdb options:usedots,upriv /mnt/raid/minime backups allow:minime cnidscheme:cdb options:usedots,upriv When any of these three users connect, they see one volume named 'backups' that their machines are using for backups. Similar configurations can be done in SAMBA but it will be slightly different in NFS, I believe.
  2. sunkid

    10.6.3 Released !

    Made the rookie mistake and ran the update before checking in here -> kernel panic on boot After removing SleepEnabler.kext, my machine will happily boot but kernel panic a little while later. Here is what I have in my E/E folder: AHCIPortInjector.kext ALC889a.kext ATAPortInjector.kext IOAHCIBlockStorageInjector.kext JMicronATA.kext NullCPUPowerManagement.kext OpenHaltRestart.kext PlatformUUID.kext fakesmc.kext Seems as if the KP only happens when I log in... have it sitting at login screen now for a while longer and it's still up. Anyone have any pointers? This is on a GA-EP45-DS3R as per my sig (left here for SEO ) UPDATE: All is well after running KextUtility to fix permissions and rebuild caches. FWIW, I had removed the old SleepEnabler.kext from /E/E using an Ubuntu live CD, 'cuz that's what I had handy. To mount the HFS+ partition, I used mount -t hfsplus -w -o force /dev/sda2 /mnt rm /mnt/Extras/Extensions/SleepEnabler.kext rm /mnt/Extras/Extensions.mkext umount /mnt reboot After adding the new SleepEnabler.kext and running KextUtility.app, sleep now seems to work, albeit I cannot wake the machine with any USB devices. Using the power button works though and all USB devices re-connect without issues.
  3. That's good news! Can you post a link the the new firmware and a description of what exactly it fixed?
  4. Point TM to the SMB share that contains your sparsebundle. No need to mount it, TM will do that for you. In fact, it may complain about it already being mounted, so best unmount first.
  5. Therein lies your problem! Don't mount the sparsebundle but copy the plist file into the sparsebundle directory using terminal or by selecting "Show package contents" in the Finder's contextual menu (not sure if the second option is available).
  6. Glad to hear it worked. I was really a bit at a loss about this error since the script seems to work for others.
  7. That's an odd syntax error! Try downloading the script again, maybe your download got corrupted.
  8. What operating system is running on the machine that is serving the folder you are trying to use? What protocol do you use (AFP, smb, nfs)?
  9. Can you give us more detail on what you tried and what happened? Without knowing where to start, it's not so easy to provide a more detailed explanation. Usage of the Terminal application is probably a bit beyond the scope of this guide.
  10. I also get the second, shadow-mount of my AFP share whenever Time Machine runs. The second mount has root-only permissions and I think this is now part of the normal protocol. I am also not able to get this to work on a Tiger-based system: Sep 13 08:52:10 hackintosh com.apple.backupd[3617]: Creating disk image /Volumes/Tiger-2/tarpo.sparsebundle Sep 13 08:52:23 hackintosh com.apple.backupd[3617]: Error 118 creating backup disk image Sep 13 08:52:23 hackintosh com.apple.backupd[3617]: Failed to create disk image Sep 13 08:52:28 hackintosh com.apple.backupd[3617]: Backup failed with error: 20 Sep 13 08:52:38 hackintosh com.apple.backupd[3617]: Ejected Time Machine network volume. When I try to use an image created by my script. I get the same unmounting issue as y'all
  11. @GrandPoohBear: how large is the maximum size of your disk image and how big is your disk you are trying to backup? I think Snow Leopard may be enforcing a larger size of the backup disk images to avoid the problems Leopard ran into when backing up to AFP shares. Btw - if you are backing up to a Mac-based AFP share, I don't think you need to make any modifications yourself. Linux AFP shares, on the other hand, don't seem to be able to let TM create the disk image.
  12. That did the trick! Thanks!! btw - OSX68Tools doesn't work for me anymore, but I installed the extension manually: sudo chown -R 0:0 Realtek1000.kext sudo chmod -R go-r Realteck1000.kext sudo mv Realtek1000.kext /System/Library/Extensions sudo kextcache -mkext1 Extensions.mkext /System/Library/Extensions Not sure if the last step is necessary, as SL seems to automatically rebuild its Extension cache now.
  13. Snow Leopard now reports HD size in base 10 and not in base 2 anymore. Thus, that 300GB drive you bought actually shows up as 300GB now and not as 279GB like before.
  14. That is odd! Did you try a backup with a disk image that has a max of more than 300GB? Seems like TM in SysPrefs wants 299.93GB for whatever reasons.
  15. Check your logs, they may indicate what the issue is. Maybe your disk image doesn't have enough space for the backup. As for how I found the trick: to get a working image, I pointed my time machine at a leopard-bases AFP share on a mac laptop. Once I had that, I saw the new plist file in it. Took me a while to figure out that the extended properties on it where doing nothing else other than hiding it from the Finder. Time machine doesn't seem to care about that though.
×