Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

crtman

Members
  • Content count

    6
  • Joined

  • Last visited

About crtman

  • Rank
    InsanelyMac Protégé
  1. Thank you very much, I removed unnecessary kexts and CST and it worked like a charm. Can I install VoodooMonitor to watch steedstep working or it just works with VoodooPower? Also I applied SATA built-in patch and EHCI patch to my dsdt so now I need just these kexts: LegacyHDA.kext PlatformUUID.kext OpenHaltRestart.kext fakesmc.kext Thank you!
  2. Hi, I've patched my dsdt with this: Scope (_PR) { Processor (CPU0, 0x00, 0x00000410, 0x06) { Name (_PSS, Package (0x04) { Package (0x06) { 2403, 0, 10, 10, 0x0928, 0 }, Package (0x06) { 2136, 0, 10, 10, 0x0824, 1 }, Package (0x06) { 1869, 0, 10, 10, 0x0720, 2 }, Package (0x06) { 1602, 0, 10, 10, 0x061B, 3 } }) Name (_PSD, Package (0x05) { 0x05, 0x00, 0x00, 0xFC, // Double-checked the 0xFC value with ACPISpec v4.0 pdf 0x04 // Number of Processors - If you have a Quad core CPU then this value should read 0x04 }) Name (_CST, Package (0x04) { 0x03, Package (0x04) {ResourceTemplate () {Register (FFixedHW, 1, 2, 0x000)},1,1,1000}, Package (0x04) {ResourceTemplate () {Register (SystemIO, 8, 0, 0x414)},2,1,500}, Package (0x04) {ResourceTemplate () {Register (SystemIO, 8, 0, 0x415)},3,17,250} }) } Processor (CPU1, 0x01, 0x00000410, 0x06) { Alias (\_PR.CPU0._PSS, _PSS) Alias (\_PR.CPU0._PSD, _PSD) Alias (\_PR.CPU0._CST, _CST) } Processor (CPU2, 0x02, 0x00000410, 0x06) { Alias (\_PR.CPU0._PSS, _PSS) Alias (\_PR.CPU0._PSD, _PSD) Alias (\_PR.CPU0._CST, _CST) } Processor (CPU3, 0x03, 0x00000410, 0x06) { Alias (\_PR.CPU0._PSS, _PSS) Alias (\_PR.CPU0._PSD, _PSD) Alias (\_PR.CPU0._CST, _CST) } } It was initially taken from blackosx's dsdt and changed with my FID/VID from PStateChanger Currently I'm running Snow Leopard 10.6.2 x64 with Chameleon 2.0 RC4. I'm getting KP at the very start without NullCPUPowerManagement. Am I missing something? Thanks PS: EIST is working (checked my BIOS settings) LPC seems to be working: $ kextstat | grep LPC 53 0 0xffffff7f808a3000 0x3000 0x3000 com.apple.driver.AppleLPC (1.4.9) <9 5 4 3> $ lspci | grep LPC 00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02) PS2: My extra kexts (hope it will help): AHCIPortInjector.kext + IOAHCIBlockStorageInjector.kext (optional, fixes orange icons) ALC889a.kext NullCPUPowerManagement.kext OpenHaltRestart.kext PlatformUUID.kext (optional, OS works fine but Hardware UUID in Sys Profiler filled with zeroes) SleepEnabler.kext VoodooPState.kext (used to check my pstate) fakesmc.kext
  3. What bootloader should I use for 10.6 final (432)? Chameleon 2.0 RC2 or PC_EFI 10.2 Beta?
  4. Hi, I'm installing retail 10.5.6 and having problems with my video card. I've tried NVinject and it got my resolution but not QE. Then I tried GFX string using OSx86 Tools but no luck. I just get 1024x768 with lots of artifacts (see screenshot). Here is my string: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Kernel</key> <string>mach_kernel</string> <key>Kernel Flags</key> <string></string> <key>device-properties</key> <string>d20300000100000001000000c60300001500000002010c00d041030a0100000001010600001c0 01060000007fff040014000000400032002c006e0061006d00650000001100000073656e736f722d 06172656e74220000005600520041004d002c0074006f00740061006c00730069007a00650000000 0000000000002036000000400032002c00680077006300740072006c002d0070006100720061006d 073002d00760065007200730069006f006e00000008000000000000021c000000640065007600690 630065005f0074007900700065000000100000004e5644412c4765466f7263650e0000006e006100 d00650000000f0000004e5644412c506172656e7422000000400030002c006400650076006900630 65005f00740079007000650000000b000000646973706c6179100000006d006f00640065006c0000 01f0000004e5649444941204765466f7263652039383030204754582044444c22000000400031002 006400650076006900630065005f00740079007000650000000b000000646973706c617912000000 00032002c007200650067000000080000000000000222000000400032002c0064006500760069006 0065005f0074007900700065000000120000004e5644412c6770752d64696f646520000000400032 02c0063006f006d00700061007400690062006c0065000000160000004e5644412c73656e736f722 706172656e7422000000400032002c002300730069007a0065002d00630065006c006c0073000000 80000000000000020000000400031002c0063006f006d00700061007400690062006c00650000000 0000004e5644412c4e564d616314000000400030002c006e0061006d0065000000120000004e5644 12c446973706c61792d413a000000400032002c0068007700730065006e0073006f0072002d00700 6100720061006d0073002d00760065007200730069006f006e000000080000000000000226000000 00032002c0023006100640072006500730073002d00630065006c006c00730000000800000000000 0114000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220 00000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4 564d61631e00000072006f006d002d007200650076006900730069006f006e000000090000003331 73261100000004e00560043004100500000001800000004000000000003000c00000000000007000 00000e0000004e00560050004d000000200000000100000000000000000000000000000000000000 000000000000000</string> </dict> </plist>
  5. Hi. I've got the same MoBo as karaakeha1 (GA-P35-DS4). I've installed Retail 10.5.6, then i run 10.5.6_kexts_pack.zip (1.07MB). It successfully copied new kexts and removed incompatible ones. After getting permission repaired I installed chameleon 2.0 RC1 and rebooted, but I get "Still waiting for root device" error. (screenshot arrached). I installed retail from iPC and it boots fine from chameleon 2.0 Thanks Tried to install IOAHCIFamily.kext and AppleAHCIPort.Kext with kext tool to iPC and now iPC doesn't boot up too with the same error:) UP: It works! But only with -f param. How can I fix it?
  6. HDA patcher 1.20

    Hi guys, does anyone have Taruga HDA Patcher 1.6? I've googled it a lot but no luck : (.
×