Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

  1. 10.7.2 update issues

    I have found another solution, for those who don't want to install [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. I encountered the same problem several times, when I tried to update to 10.7.2 by KP during "Moving Items in to place" stage, and ApplePolicyControl.kext giving troubles (updating both ways - directly from Apple's site with Software Updates or by downloading the Combo package and launching it for update procedures). I searched the shared information in many places, many testers having the same problem (even some of them using genuine Apple machines), but without a certain result with reliable solution. Then, I remembered that updating Leopard contained a solution with removing a kext during the installation procedure. I do not remember who proposed the solution, but now is working for this problem mentioned above. I am really sorry for not remembering whom to give the credit for this solution. Here are the steps to be used: 1. Download the MacOSX 10.7.2 Client Combo package from Apple's site (the .dmg file of about 820 MB). 2. Launch Terminal and use administrator "sudo -s" command then enter the password for administrator's rights. 3. Use the command between the brakes and hit ENTER: <while sleep 1; do rm -rf /System/Library/Extensions/AppleGraphicsControl.kext/Contents/PlugIns/ApplePolicyControl.kext; done> (Nothing seems to happen, but in background the command is waiting for the kext to appear and to erase it quickly) 4. Launch the updater from the .pkg and follow the instructions, after mounting the .dmg file. 5. DO NOT PRESS THE RESTART BUTTON when the update is finished. 6. Switch to the Terminal window and press simultaneously CTRL+C to exit the routine entered. 7. EXIT the Terminal and press now the RESTART button in the Installer of Update window. That was all, and my system is running now 10.7.2 in 32bit (Dell6400 with IntelGMA950). I hope this will help others to SOLVE their Kernel Panic troubles that appear do to the ApplePolicyControl.kext
  2. [HOW TO] ATI HD 4350

    Hi Anarchintosh, I tried a lot of the methods described that I found to install my new Gygabite ATI 4550 card, but without success, and I have observed that the card is recognized as 0x95521002 (meaning Mobile M92 HD 4350). This PID is included in info.plist of ATIX2000Controller.kext but not recognized at all. Though, is working at highest resolution supported by my monitor 1280x1024, unfortunately without QE/CI. Any suggestions? Thank you for your full effort in solving the problems for this stubborn cards.
  3. Hi to all of you Dell owners. I am presenting a routine for genuine installation of SnowLeo without DSDT and I hope this will help others. Three captured images are attached in order to prove the successful installation and upgrade to 10.6.2 A. Packages needed to prepare the computer A1. BUI (Bootable Utilities Image) with an iPartition fully functional A2. Genuine Apple Snow Leopard A3. Bootable CD for Inspiron 6400 (search for it on Insanely) A4. Download VoodooHDA.kext (for Audio) and VoodooTSCSync.kext (for Intel Core 2 Duo functionality) A5. Chameleon 2.0 RC3 or even the new one RC4 B. Preparation of the laptop Dell Inspiron 6400 B1. Check on Insanely my description for BIOS settings B2. Boot on BUI and partition the SATA drive as GPT (GUID) following next instructions: - start iPartition3 from BUI bootable media (DVD or USB); - delete all partitions from the hard disk using iPartition3; - create first partition as MacOSX Extended Journaled with GUID; - create next partitions (no more than 3) as FAT32 after the first one (here you have to check the option "Visible in Windows" from the right panel for each new FAT32 partition created) - THIS STEP IS CRUCIAL FOR INSTALLING Win7 as a secondary OS; B3. Mark the 1st partition as active from Terminal; C. Install Snow Leopard after using and starting the computer on Bootable CD for Inspiron 6400 C1. Start computer with BootCD created for Dell Inspiron 6400 C2. Change the CD with the Snow Leopard DVD C3. Press F5 in order to recognize the genuine DVD C4. Start clean installation of Snow (perhaps an ERROR message appears at the end - ignore it and restart); C5. Restart system keeping the BootCD in the unit for Chameleon options on starting the system; C6. Create your user with admin&full rights on Snow; C7. Copy & install the two kexts mentioned at the beginning; C8. Create and copy the directory Extra/Extensions from the BootCD to the partition where Snow was installed; C9. Modify and make them identical, all the files com.apple.Boot.plist (in 3 places - the regular in /Library/Preferences/SystemConfiguration ; second in the /Extra subdirectory and third in subdirectory /Extra/Extensions) - you need these modifications in order to start as 32b not 64b; - include following lines in the plist files after the lines for Kernel Flag: <key>arch</key> <string>i386</string> D. Update with 10.6.2 combo package (IF YOU HAVEN'T CHANGED THE com.apple.Boot.plist your screen doesn't start - remain as black screen) D1. Install the Chameleon 2.0 in order to have a boot selector at boot-time; D2. If you forgot to make the changes you still can start BUI and you can make the changes with Terminal and sudo nano to edit the plist files.
  4. Thanks azimutz, it worked for me on an ASUS P5GC/MX-1333 that has two ethernet cards (one built-in AttansicL2 and second Accton EN5038A that is a clone of RTL8139) and Leopard installed with XxX 10.5.6 final (containing PPF4).
  5. Attansic L2 Driver

    Hi reader02, works fine under Leo 10.5.6. Thank you
  6. i-Bench to test your Mac

    For all fans of this forbidden bitten fruit. System info Operating system: Mac OS X 10.5.6 (Build 9G55) Model: Hackintosh Processor: IntelĀ® Core2 CPU 6300 @ 1.86GHz Frequency: 2.33 GHz Total CPU number: 2 Physical CPU number: 1 Bus frequency: 1.33 GHz Memory size: 4.00 GB Memory type: 0 MHz SDRAM Compiled with: GCC 4.2.1 (Apple Inc. build 5564) Tests results Composite result: 3.46 iBench_fp test suite Householder transformation: 3.57 Gaussian blur: 3.81 Mandelbrot set generation: 3.56 Numerical integration: 3.51 JPEG compression: 3.62 LU decomposition: 3.32 Edge detection: 4.11 Fast Fourier Transform: 3.56 Eigenvalue: 3.26 Partial result: 3.58 iBench_int test suite MD5 hashing: 3.98 Blowfish cypher: 3.91 Kruskal tree search: 2.95 Integer factorization: 3.46 ZIP compression: 2.86 N Queens problem: 3.93 Maximum Common Divisor: 3.64 Quick sorting: 3.21 Binary searching: 3.07 Bubble sorting: 2.55 Prime numbers calculation: 3.60 Partial result: 3.35
  7. Installing Leopard on Inspiron 1525

    Hi Dell owners. I was asked by a friend to set an Inspiron 1525 to work with Leopard. It took sometime to figure out how to upgrade to the latest cat 10.5.5, but it worked. The installation I started with Leo4All v3 10.5.2 and was no problem to work with (except as you guess LAN Marvell 88E8040, card reader 3in1 and wireless Intel 3945 A/B/G - there are no viable solutions yet for these devices). Before upgrading to 10.5.5 I had to patch the PS2, because the keyboard and touchpad are PS2 (in the first installation I couldn't solve to fix these because it was not possible to launch any package - I have introduced a system admin password so even using a USB mouse that worked I did not had a USB keyboard in order to patch the PS2 problem). Packages of PS2 kexts are attached. After upgrading without patching the PS2, the computer comes out of the black screen only by attaching a USB mouse. In order to have a fine "About This Mac" report and also in benchmark software I had to install those small packages from the Leo4All v3 10.5.2 DVD, namely AppleSMBIOS, AboutThisMac, by using Pacifist. The Audio can be fixed in 10.5.5 with Taruga's v1.16 and 1525_codec.txt (the card is Sigmatel with identification 0x284b8086 but is working without internal microphone). The graphic card associated GMA X3100 is working fine with QE/IC at highest resolution accepted 1280x800x32b. The CPU Centrino Core2Duo is working with both cores without problems (this is solved now for new Dell notebooks), and the Geekbench score is really good ~2400. For those non-believers, there is a captured screen attached. Thank you methamp for the tutorial published it helped a lot. Working_Kexts.zip
  8. Hi folks, yesterday the new 10.5.5 cat was launched and again I managed to install it respecting the method used for 10.5.2 , 10.5.3 and 10.5.4 Combo update packages. All parts are working (except 3in1 card reader) by using only one core (settings to start in com.apple.Boot.plist) are good, the speed is fine. The Intel GMA950 needs AppleIntelIntegratedFramebuffer.kext (192 kb/29.09.2007) otherwise the screen turns black after gray starting apple. The sound had to be patched (Taruga's v1.20 with dump file of Sigmatel9200.txt), and the IONetworkingFamily.kext (2.6 MB/11.11.2007) needs to be replaced. In order to have a good report of About This Mac needs replacing AppleSMBIOS.kext (52 kb/23.06.2008), the exact model of my Dell Inspiron 6400/E1505 it is shown MM061. Again I attached a screen capture to prove it.
  9. Hi folks, yesterday the new 10.5.5 cat was launched and again I managed to install it respecting the method used for 10.5.2 , 10.5.3 or 10.5.4 (see some guides in the forums to this link http://forum.insanelymac.com/index.php?showtopic=107340#). Just Audio has to be reinstalled (ALC882 from the older kext). Everything works out of the box. Capture attached for proving the result.
  10. Leo4all - Asus P5PL2 - no sound

    Hi Alex, have you tried these solutions? http://forum.insanelymac.com/index.php?showtopic=32859 with this dump code http://psykopat.free.fr/apple/AppleHDA/ADI/AD1986a.txt Just try it and see how it works.
  11. Hi folks, yesterday the new 10.5.4 cat was launched and again I managed to install it respecting the method used for 10.5.2 and 10.5.3 (see some posts above). All parts are working (except 3in1 card reader) and scores reported by XBench 103 or GeekBench 1860 by using only one core (settings to start in com.apple.Boot.plist) are good, the speed is fine. Again I attached a screen capture to prove it. Wonderful job from developers of Leo4All v3, thank you guys.
  12. Anyone knows when a new chapter for HCL 10.5.3 will be launched on wiki.osx86project.org/wiki/index.php/Main_Page ?
  13. Hi all you Dell lovers. Finally I had enough time and I was able to update my Inspiron 6400/E1505 from 10.5.2 to 10.5.3 with the Combo Update. http://forum.insanelymac.com/index.php?s=&...st&p=653838 I used the indications that were also used for updating to 10.5.2. http://forum.insanelymac.com/index.php?s=&...st&p=761779 First problem with the Intel 945GM card was solved by replacing the AppleIntelIntegratedFrameBuffer.kext and then for system correct recognition (as it was produced by Dell with factory associated code MM061) by replacing AppleSMBIOS.kext and finally I repaired permissions. How to change it was not difficult but a bit tricky. I used MacDrive from Windows Vista to replace the first kext for Intel 945GM and then I used install DVD Leo4All-v3 to repair the permissions for it. I chose this way because the laptop entered in a black screen after the gray apple boot screen, without possibility to make any changes in the system. I forgot to mention that sound (Sigmatel9200) was solved using Taruga's v1.20 and the dumpcode specifically for this on-board card. So, I succeeded to have the up-to-date version and everything is working fine. The screen capture for those non-believers is attached.
  14. 10.5.3 Available as an update!

    Hi to the community. My computer build up from parts, posted with guide about installing and functionality, has been reported. http://forum.insanelymac.com/index.php?s=&...st&p=631191 I succeeded to update Leo to 10.5.3 respecting exactly the tutorial as it was for 10.5.2 and posted here http://forum.insanelymac.com/index.php?s=&...st&p=761779 Thank you all contributors.
  15. peptonite, try this dump code with the v1.20 of Taruga's patcher. http://psykopat.free.fr/apple/AppleHDA/sig...igmatel9200.txt This one was THE ONLY ONE working for me (yes I have tested the others too, in order to make microphone to work).