Jump to content
InsanelyMac Forum

Colin MacKenzie

Members
  • Content count

    7
  • Joined

  • Last visited

About Colin MacKenzie

  • Rank
    InsanelyMac Protégé
  1. Colin MacKenzie

    ¿How to fix boot on macosx?

    Oh Thank god! I have my blessed Mac Back! FYI You dont need the startupfiletool anymore. Read the readme file in: /usr/standalone/i386 on the install cd It has the instructions to do an fdisk to overwrite the MBR and if needed the partition boot sector too. It's pretty easy. I wouldnt have found that readme without your post though...so thanks a bunch! Also, I see a lot of people complaining about write problems to the drive...dont forget to umount the disk before writes. This solves the gptsync "data write failed at position 0: Bad file descriptor". Find out what is mounted with the "mount" command.
  2. Colin MacKenzie

    nForce LAN driver

    FYI: I was having a lot of kernel panics and I thought it might be related to the HPET or MSI signaling. Unfortunately, having the normal mac kernel panic provides*NO* information at all!!! I downloaded the latest voodoo xnu kernel and was happy to see actual debug information during a kernel panic! Appears my problems are not with the nForce driver at all but with the nForce ATA! After some searching it appears some ATA drivers may have a RAM >2.5GB problem. I took out a stick to go down to 2GB and for the first time I got up in the morning without a kernel panic on the screen. So, for those with nForce LAN on board, you probably have nForce ATA too...so beware! C MSI p7n Diamond on Q6600 Quad Core Intel 780i (North) & 570i (South) SLI Chipset 4GB RAM MCP55 Series nForce LAN nForce ATA
  3. Colin MacKenzie

    iATKOS 5i 10.5.5 Intel DVD

    I finally have my MSI p7N Diamond Installation working!!!! Oh man I am relieved!!! I seem to have everything working...My GeForce 9600GT worked after adding my PCI device ID to info.plist in NVDANV50Ext.kext (included with the "Graphics Update" package.) and I had to add the EFI String to the boot config file. My Creative Labs 5.1 SB Live! is working using kxAudioDriver. My NVidia MCP55 Ethernet (from 590i chipset) is working with the nForceLAN.kext. Not sure what is left not working right now and its time for bed...My System Profiler keeps crashing on startup...I will have to fix that later. Colin
  4. Colin MacKenzie

    iATKOS 5i 10.5.5 Intel DVD

    (( Edit: Never mind, I figured this out...I am editing this with my MacOS installation! Wahoo! )) I hope someone can lend me a hand, I am not sure where to go next. I get through the installer fine, but when it goes to boot Darwin it loads all the kexts but then reboots. I am using GPT EFI V9 bootloader, tried both the EFI and Kabyl Enablers. My system details are at the bottom of this post. Here it goes: 1. POST, GPT Bootup is OK 2. F8 for boot prompt, enter "-v -f cpus=1 maxmem=2048" 3. I see all the kexts loading, the last kext is the TMSafetyNet.kext (for time machine) 4. Then it says Loading "DSDT.aml" (my patched DSDT overlay) 5. Then it says "Starting Darwin x86" 6. Then bammm! reboot From my reading of osx startup sequencing this appears to be when the INIT routine is executed. I've tried all the switch combinations: -x -v -f cpus=1 maxmem=2048 I've been through the installer multiple times using various options. Patching DSDT Attempts: The cpus=1 is required to boot. Without it, computer instantly reboots before even loading the kexts. Apparently, CPU ALIASs present in the DSDT cause Darwin to fail, thus, cpus=1 bypasses this problem by ignoring the other cores. In the installer log I see that it, decompiles and patches my DSDT although it skips two CPU ALIASs. However, I used iasl/acpidump utilities in Ubuntu to take the DSDT file patched by the installer and repatch, i.e, decompile it again, remove the CPU ALIASs and recompile, then place back in the root filesystem. I also tried using the DSDT from my bios directly. In both cases, I still have to use cpus=1. I would be ok with cpus=1 for now, but I also wonder if my DSDT is still the source of my failure to boot the Darwin kernel as well. Graphics Card: The installer works fine, I expect this means that the most basic graphics should work with MacOSX too. I have a GeForce 9600GT. Could lack of a graphics driver cause Darwin to reset after loading kexts? Thanks in advance for your help! Colin MSI P7N Diamond using Q6600 Quad Core Intel 2.4GHz Northbridge 780i SLI, Southbridge 570i SLI (MCP55 series), nForce SATA 4GB RAM GeForce 9600GT 512MB 160 GB SATA
  5. !-- @page { size: 8.5in 11in; margin: 0.79in } P { margin-bottom: 0.08in } -->I can boot the latest iATKOS 10.5.5 only with the cpus=1 boot option. Could you please prepare a bios for me for this motherboard? (I checked the existing list, no luck.) MSI P7N Diamond My specs: Intel Core2 - Quad Core Q6600 2.4GHz 4GB Memory nForce 780i SLI (Northbridge) nForce 570i SLI (Southbridge) nVidia Geforce 9600GT 512MB 250GB SATA on nForce SATA (in 570i chipset) Link to bios: http://global.msi.com.tw/index.php?func=do...5&type=bios
  6. Colin MacKenzie

    Kalyway install problems on EVGA 780i

    xfidelity: I have an MSI P7N diamond too, can you tell me what version of the install you used...iATKOS, iDeneb, Kalyway, etc...and any patching, injecting you needed to do to get it working? If you point me in the right direction I should be good to go. I did notice your sig details, but you have two computers so not sure which of them the patches apply to. Thanks, Colin
  7. Colin MacKenzie

    MSI P7N nForce 750i SLi Dual boot Vista Leopard.

    This thread is stale...anyone figure out if the P7N can run hack osx yet? I noticed Kabyl hasnt yet generated moded p7n bios...though no one seems to have asked yet. Looking for a status as I am downloading a few of the iso's to try now. C
×