Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About djhansel

  • Rank
    InsanelyMac Protégé
  1. Toshiba R845-S80 HD 3000 HDMI out only!

    Finally!!!! I did a fresh re-install, updated to 10.8.3, applied the EDID DSDT injection patch described here, and my laptop's LCD got recognized by OSX. As far as steps I followed this post:
  2. Toshiba R845-S80 HD 3000 HDMI out only!

    Well something is wrong because now I always get the "SNB Framebuffer did not show up, unload" even without DSDT or any patches. I'm going to re-create my install stick and do another re-installation. Once I get everything working, I'll post a guide with the steps I took.
  3. Toshiba R845-S80 HD 3000 HDMI out only!

    OK I'm doing a fresh re-install and trying this solution, I will post if it works for me or not. Thanks for the find stacyk819!
  4. Toshiba R845-S80 HD 3000 HDMI out only!

    OK, so I tried getting the EDID with linux and it didn't work I got all kinds of errors. I used some software in Windows and was able to pick up an EDID not sure if real or not. Here is the EDID I got: Time: 0:12:44 Date: Sunday, March 31, 2013 EDID Manager Version: ___________________________________________________________________ Block 0 (EDID Base Block), Bytes 0 - 127, 128 BYTES OF EDID CODE: 0 1 2 3 4 5 6 7 8 9 000 | 00 FF FF FF FF FF FF 00 51 F3 010 | 91 50 01 00 00 00 0E 10 01 03 020 | 80 1F 11 FF 2F 00 00 A0 57 49 030 | 9B 26 10 48 4F 00 00 00 01 01 040 | 01 01 01 01 01 01 01 01 01 01 050 | 01 01 01 01 30 1C 56 A0 50 00 060 | 12 30 30 20 35 00 35 AE 10 00 070 | 00 18 00 00 00 FC 00 49 6E 74 080 | 65 72 6E 61 6C 20 4C 43 44 0A 090 | 00 00 00 FD 00 00 3C 00 B7 08 100 | 00 00 00 00 00 00 00 00 00 00 110 | 00 00 00 00 00 00 00 00 00 00 120 | 00 00 00 00 00 00 00 96 (8-9) ID Manufacture Name : TOS (10-11) ID Product Code : 5091 (12-15) ID Serial Number : N/A (16) Week of Manufacture : 14 (17) Year of Manufacture : 2006 (18) EDID Version Number : 1 (19) EDID Revision Number: 3 (20) Video Input Definition : Digital (21) Maximum Horizontal Image Size: 31 cm (22) Maximum Vertical Image Size : 17 cm (23) Display Gamma : 3.55 (24) Power Management and Supported Feature(s): Active Off/Very Low Power, RGB Color, sRGB, Preferred Timing Mode, Default GTF Supported (25-34) Color Characteristics Red Chromaticity : Rx = 0.625 Ry = 0.336 Green Chromaticity : Gx = 0.281 Gy = 0.602 Blue Chromaticity : Bx = 0.148 By = 0.062 Default White Point: Wx = 0.281 Wy = 0.305 (35) Established Timings I (Not Used) (36) Established Timings II (Not Used) (37) Manufacturer's Timings (Not Used) (38-53) Standard Timings (Not Used) (54-71) Detailed Descriptor #1: Preferred Detailed Timing (1366x768 @ 60Hz) Pixel Clock : 72.16 MHz Horizontal Image Size : 309 mm Vertical Image Size : 174 mm Refresh Mode : Non-interlaced Normal Display, No Stereo Horizontal: Active Time : 1366 Pixels Blanking Time : 160 Pixels Sync Offset : 48 Pixels Sync Pulse Width: 32 Pixels Border : 0 Pixels Frequency : 47 kHz Vertical: Active Time : 768 Lines Blanking Time : 18 Lines Sync Offset : 3 Lines Sync Pulse Width: 5 Lines Border : 0 Lines Digital Separate, Horizontal Polarity (-), Vertical Polarity (-) Modeline: "1366x768" 72.160 1366 1414 1446 1526 768 771 776 786 -hsync -vsync (72-89) Detailed Descriptor #2: Monitor Name Monitor Name: Internal LCD (90-107) Detailed Descriptor #3: Monitor Range Limits Horizontal Scan Range: 0kHz-183kHz Vertical Scan Range : 0Hz-60Hz Supported Pixel Clock: 80 MHz Secondary GTF : Not Supported (108-125) Detailed Descriptor #4: Defined by Manufacturer (126-127) Extension Flag and Checksum Extension Block(s) : 0 Checksum Value : 150 ___________________________________________________________________ System Information Summary: Processor : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz Operating System : Microsoft Windows 7 Ultimate OS Version : 6.1.7600 Service Pack : 0.0 Video Controler: Device ID : VideoController1 Name : Intel(R) HD Graphics Family Adapter Compatibility: Intel Corporation Video Processor : Not Available Video RAM : Not Available Availability : Offline Driver Version : PNP Device ID : PCI\VEN_8086&DEV_0116&SUBSYS_00041179&REV_09\3&11583659&0&10 Resolution : Not Available Max Refresh Rate : Not Available Min Refresh Rate : Not Available Current Refresh Rate : Not Available Current Scan Mode : Not Available Status : OK ___________________________________________________________________ I tried to do an override and now I get the "SNB Framebuffer did not show up, unload" so that means that something else is happening. Oh and I also tried to do the whole edid-rw thing but that didn't work. I'm gessing that is because linux is having issues with reading the EDID. I will keeep on trying and will post any updates.
  5. Toshiba R845-S80 HD 3000 HDMI out only!

    Ok, I did a little bit of digging and found this thread I'll give it a try once I get home and report back.
  6. Toshiba R845-S80 HD 3000 HDMI out only!

    Hi mengrh, Thanks for your response. Do you know if it's possible to do any type of EDID injection, or to replace the LCD panel with one that does output EDID information? I was thinking on replacing the panel with a higher resolution one anyways.
  7. Hi guys, I recently installed Mountain Lion on my toshiba laptop. When I boot the laptop screen turns black and it only outputs video through the HDMI port. I tried different DSDT hacks as well as hex editing AppleIntelSNBGrpahicsFB.kext custom connector, but had no luck. If I remove the IntelHD kexts it comes up on the laptop's monitor but i get no hardware acceleration. I attached my IORegistryExplorer, any help or guidance will be greatly appreciated. I can give any other information about my system upon request. MacBook Pro.zip
  8. GMA4500 Solved Native Resolution!

    My Computer is a Dell Inspiron 1545, I believe I installed Iatkos 10.5.7, or IPC and then update and applied the kexts and is running like a charm.... of course no qe/ci. About that.... I don't have any experience developing any kind of drivers, but with the right tools to develop in osx we could study how the gma950 and the gma3100 are made and just change values and the Ids for the gma4500. they are video cards, is not like we are trying to make a video driver from a sound driver....... also they are the same manufacturer and family so they shouldn't be so different one from another. Is there anybody that may know a lil bit more about the subject and could correct me if am wrong.
  9. GMA4500 Solved Native Resolution!

    Here's a fix for the GMA4500, its been out there in different threats but here is what i used in my inspiron 1545 with GMA4500 dev id: 2A42. Try it and let me know if it works. Now for CI/QE is there any way to start developing a driver for this card since apple is not intending to use it in the future. I don't have any experience making drivers, but if somebody that has a little knowledge on the subject points me in the right direction I'm going to try to get it done... There's a lot of laptops that use this card and it would be nice to have CI/QE on them. I almost forgot.... Use the kexthelper to install the kext files and put the DSDT.aml on the root of your drive. reboot with -f flag, and you should have native resolution without any artifacts.. GMA4500_Native_Resolution.zip
  10. Help with Inspiron 6000

    OK after days of trying i successfully got leopard 10.5.5 running on my inspiron 6000!!!! my specs Intel Pentium M 1.7 GHz 512MB RAM Intel GMA 915gm Method used: iaktos v5i To boot you need the external vga dongle, what i did was use two paper clips and put them like this installed iatkos and used the intel gma 950a driver. the other options i leave it to your choice i tried like 5 different setups until it worked. After is installed use kexthelper and copy the kexts attached, reboot and you should have full CI and QE support DVD player works, audio works, ethernet works, intel wireless not working, but i already bought a DELL TrueMobile 1450 waiting for it to arrive to try it. With only 512MB RAM it runs very smooth and fast. i get a lil bit of mouse tearing when using a big application, i don't know if is because of the RAM or the video but im really happy with the way is working.. Attached the kexts for the video card... Intel_915gm_leopard.zip
  11. i don't know men im kind of new on this.. that happend to me once but not even the installation worked, it was the motherboard, i got me an intel one and everything worked out. sorry i don't have a lot of help for you.
  12. hey men that is a problem with the way u have conected the hard drives and the cd rom try changing the cables around or try disconnecting some and leave just one hard drive on the master and one dvd rom on the slave.
  13. Hi im trying to install leopard using iatkos v5i and i can get it to boot the installation using a paper clip stick on the ext vga, but after i install and try to boot i get stuck at the blue screen, any help will be appreciated, thanks. Im sorry about my english
  14. Help with installation on GA-K8NNXP

    is anyone going to at least say something....
  15. OK, Im trying to install leopard on an AMD machine the specs are these: Motherboard: GA-K8NNXP Chipset: NVIDIA nForce3 150 realtek 8110s gigabit ethernet controller realtek 8201 phy lan chip realtek ALC 658 Audio CA'97 Video Card: ATI Radeon 9200 Possessor: AMD Sempron 3400+ 2.0 GHz 1.5 GB Ram I have tried Kaliway 10.5.2, Ideneb v1.1, Zephyroth Leopard 10.5.2 AMD, but when i manage to finish the installation without hanging at the end, when i boot up it starts loading and then the monitor goes off like no signal or something... i dont know how but kaliway worked one time and it booted and everything was working except ethernet. and when I restated it did the same thing with the video any idea of what it may be?.... im not sure what patch or kernel i have to use and if thats the problem... thank in advance for any input..