Jump to content

rimkashox

Members
  • Content Count

    14
  • Joined

  • Last visited

About rimkashox

  • Rank
    InsanelyMac Protégé
  1. rimkashox

    Safari hangs computer on some videos

    Just to confirm, I'm under 10.12.1 using HD4600 embedded in processor i7 4790K. The patch above works for safari video crashes. Can't confirm for Beats1 because not supported in my country, but theoretically it might very well solve this problem too. Used the following in clover config.plist under kextsToPatch > array : <dict> <key>Name</key> <string>AppleIntelFramebufferAzul</string> <key>Comment</key> <string>Isolate IntelAccelerator HD4600 10.12.x</string> <key>Find</key> <data>SImLqAAAAA==</data> <key>Replace</key> <data>kJCQkJCQkA==</data> </dict> And to sweeten the deal and get trailers and everything on iTunes working, I guess Beats1 too, use Shiki.kext by the same Russian hacker vit9696 who discovered the path above.. I inject it via clover. Works wonders ! You can download it here: https://github.com/vit9696/Shiki/releases
  2. rimkashox

    Safari hangs computer on some videos

    This is exactly it.. Does the same when trying to play Beats1 in itunes, total freeze.. it's a DRM issue with HD4600
  3. Indeed man, Ibooks and Instruments.app not working, giving transparent screen. It a signature problem in Nvidia metal drivers, they know about it, let's keep on pushing them via the support system so that they ship the fix in the next update.
  4. rimkashox

    [Solution] Yosemite Blued crashing

    Alright guys, for 50 bucks I got the original apple Wifi AC with Bluetooth 4.0, all works good continuity etc... I utilised the continuity fix tool.. Wasn't sure if absolutely needed but worked good. http://www.ebay.es/itm/391030111797 and https://github.com/dokterdok/Continuity-Activation-Tool/
  5. rimkashox

    DSDT tweaks for GA-z97x-UD3H

    Alright people, for me things are much better with my mobo GA-z97x-UD3H, with in bios XMP Profile 1 + memory enhanced stability option. I'm using Crucial ballistic tactical. Dual channel setup.. Cheers
  6. rimkashox

    DSDT tweaks for GA-z97x-UD3H

    Anyone ? My system is good, but not 100%, especially after sleep, random application close and kernel panic... And sometimes on shutdown panic also !
  7. Hello people, Please allow me to grab some good karma in here. If you are like me and tried to use a cheap bluetooth dongle under Yosemite, you will have noticed that no surrounding device are detected, and if you go to Console app, you'll see that blued, the bluetooth daemon has crashed... The solution is simple, use the Mavericks's blued (attached) below. Backup and replace Yosemite one with Mavericks one, in /usr/sbin. Then repair permissions with disk utility. Reboot, and your Bluetooth should be working fine then, no more crashing of Blued. Keep backed up Yosemite blued safe, just in case. Enjoy ! mavericks blued.zip
  8. Hello people, I have a working build and patched DSDT for my build running: GA-z97x-UD3H with latest F8 bios i7-4970K (with custom SSDT to enable PM) Angelbird SSD with native TRIM Integrated HD4600 graphics (AZUL B patch from Toleda to use HDMI properly, even HDMI audio). Integrated ALC1150 (used Toleda RealtekALC). I use both Clover and Chimera, both installed, clover as EFI only. Respective config files totally empty. With patched DSDT and SSDT (latter only to enable PM). Clover appears most stable, the only option i use in Clover is XMPDetection=Yes (to detect RAM correctly) under clover configurator and iMac 15,1 5K definition My minimal issues: I only notice ramdom bugs or kernel panic after sleep, but not always. Can you check my WAK method ? Or anything that might be causing that... Also I was not successful in renaming GFX0 to IGPU, everytime i did it I got a freeze or kernel panic at boot. Finally, I'm not sure about the OSI definitions. I don't see darwin in there. Issue 1 is the only real priority. Can you guys please take a look at my DSDT and fix anything you see isn't right ? Or advise me otherwise... Attached is my present working DSDT, SSDT (just in case you need it, but normally needs no change), and IOJones output. Cheers GA-z97x-UD3H DSDT and more.zip
  9. rimkashox

    Intel HD 4600 QE/CI Yosemite

    Hey man, I installed pm after making the first post.. here's my present ioreg with pm on both... I'll try again to rename GFX0 to IGPU.. Thanks ! iMac 5K.iojones.zip
  10. rimkashox

    Intel HD 4600 QE/CI Yosemite

    Ok perfect, so if I understand you correctly, because I have more then 8 GB of RAM (I have 16), the system allocates 1536 MB of VRAM instead of 1024. For the ig-platform-id, I inject it in DSDT.. Here's my code, I stayed with GFX0, if I renaming it to IGPU in any way possible, but I get a kernel panic every time : / ... I have power management, thanks to your post, and it seems to work well, even for GFX0 so I guess it's good for now.. Device (GFX0) { Name (_ADR, 0x00020000) // _ADR: Address Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LEqual (Arg2, Zero)) { Return (Buffer (One) { 0x03 }) } Return (Package (0x04) { "AAPL,ig-platform-id", Buffer (0x04) { 0x03, 0x00, 0x22, 0x0D }, "hda-gfx", Buffer (0x0A) { "onboard-1" } }) } }
  11. rimkashox

    Intel HD 4600 QE/CI Yosemite

    Toleda, azul-b patch worked like a charm... azul-a didn't make the trick, so I installed origin framebuffer kext and retried again with azul-b, that did the trick. Also I'm using your RealtekALC patch for my onboard ALC1150, after patching with azul-b, audio HDMI automagically appeared and working well. When I look into iojones, now I have HDMI DP HDMI. I'm connected to port-number 0x5. So 2 problems solved, no more 10 sec fuzzy screen and HDMI audio fully working ! Thanks man... One question, my graphic card appears as "Intel Iris Pro 1536 MB", even before the patch, that's not a problem right (allocated memory etc), the VRAM seems more then the normal 1024 MB for an HD 4600 no ?
  12. rimkashox

    Intel HD 4600 QE/CI Yosemite

    Hello guys, first of all I want to say a big THANKS to all of you devs and hackers who are making our lives so much better every day ! Too many names come to mind Netkas, RehabMan, Toleda... And anyone actively searching for solutions to get mac running on pc ... You guys are INSANELY GREAT I have a new build running almost perfectly: i7 4790k on GA-z97x-UD3H with latest bios F8 Using integrated HD 4600 Connected to HDMI to Asus VX239W SMBios is iMac 15,1 Framebuffer looks like Azul native and QE/CI appear to be working fine, no flickering, chess game ok etc.. all good, just a very annoying of 10 sec of FUZZY analog signal before login screen... It has not changed from the very beginning of my install, same with Clover, Chameleon, DSDT-free or even patched DSDT. Now I'm not using any injectors just a more or less clean DSDT, and am injecting directly this: Device (GFX0) { Name (_ADR, 0x00020000) // _ADR: Address Method (_DSM, 4, NotSerialized) { If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) } Return (Package() { "AAPL,ig-platform-id", Buffer() { 0x03, 0x00, 0x22, 0x0D }, "hda-gfx", Buffer() { "onboard-1" }, "device-id", Buffer() { 0x12, 0x04, 0x00, 0x00 }, }) } } On the boot log, I can see something interesting, it's trying to match the display or something... Please take a look: 31/05/15 12:01:34,205 WindowServer[135]: Found 21 modes for display 0x00000000 [21, 0] 31/05/15 12:01:34,207 WindowServer[135]: Found 1 modes for display 0x00000000 [1, 0] 31/05/15 12:01:34,209 WindowServer[135]: Found 1 modes for display 0x00000000 [1, 0] 31/05/15 12:01:34,209 WindowServer[135]: mux_initialize: Couldn't find any matches 31/05/15 12:01:34,212 WindowServer[135]: Found 21 modes for display 0x00000000 [21, 0] 31/05/15 12:01:34,219 WindowServer[135]: Found 1 modes for display 0x00000000 [1, 0] 31/05/15 12:01:34,220 WindowServer[135]: Found 1 modes for display 0x00000000 [1, 0] 31/05/15 12:01:34,283 WindowServer[135]: WSMachineUsesNewStyleMirroring: true 31/05/15 12:01:34,316 WindowServer[135]: Display 0x1a48a060: GL mask 0x1; bounds (0, 0)[1920 x 1080], 21 modes available Main, Active, on-line, enabled, boot, Vendor 469, Model 23e1, S/N 5821, Unit 0, Rotation 0 UUID 0xed66da45394f2facad90d3e148bb16b9 31/05/15 12:01:34,316 WindowServer[135]: Display 0x003f003f: GL mask 0x8; bounds (0, 0)[4096 x 2160], 2 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 3, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 31/05/15 12:01:34,316 WindowServer[135]: Display 0x003f003e: GL mask 0x4; bounds (0, 0)[0 x 0], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 31/05/15 12:01:34,316 WindowServer[135]: Display 0x003f003d: GL mask 0x2; bounds (0, 0)[0 x 0], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 31/05/15 12:01:34,322 WindowServer[135]: Set a breakpoint at CGSLogError to catch errors as they are logged. 31/05/15 12:01:34,322 WindowServer[135]: WSSetWindowTransform: Singular matrix 31/05/15 12:01:34,322 WindowServer[135]: WSSetWindowTransform: Singular matrix 31/05/15 12:01:34,324 WindowServer[135]: Display 0x1a48a060: GL mask 0x1; bounds (0, 0)[1920 x 1080], 21 modes available Main, Active, on-line, enabled, boot, Vendor 469, Model 23e1, S/N 5821, Unit 0, Rotation 0 UUID 0xed66da45394f2facad90d3e148bb16b9 31/05/15 12:01:34,324 WindowServer[135]: Display 0x003f003f: GL mask 0x8; bounds (2944, 0)[1 x 1], 2 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 3, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 31/05/15 12:01:34,324 WindowServer[135]: Display 0x003f003e: GL mask 0x4; bounds (2945, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 31/05/15 12:01:34,324 WindowServer[135]: Display 0x003f003d: GL mask 0x2; bounds (2946, 0)[1 x 1], 1 modes available off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0 UUID 0xffffffffffffffffffffffffffffffff 31/05/15 12:01:34,324 WindowServer[135]: CGXPerformInitialDisplayConfiguration 31/05/15 12:01:34,324 WindowServer[135]: Display 0x1a48a060: Unit 0; Vendor 0x469 Model 0x23e1 S/N 22561 Dimensions 20.04 x 11.26; online enabled, Bounds (0,0)[1920 x 1080], Rotation 0, Resolution 1 31/05/15 12:01:34,324 WindowServer[135]: Display 0x003f003f: Unit 3; Vendor 0xffffffff Model 0xffffffff S/N -1 Dimensions 0.00 x 0.00; offline enabled, Bounds (2944,0)[1 x 1], Rotation 0, Resolution 1 31/05/15 12:01:34,324 WindowServer[135]: Display 0x003f003e: Unit 2; Vendor 0xffffffff Model 0xffffffff S/N -1 Dimensions 0.00 x 0.00; offline enabled, Bounds (2945,0)[1 x 1], Rotation 0, Resolution 1 31/05/15 12:01:34,324 WindowServer[135]: Display 0x003f003d: Unit 1; Vendor 0xffffffff Model 0xffffffff S/N -1 Dimensions 0.00 x 0.00; offline enabled, Bounds (2946,0)[1 x 1], Rotation 0, Resolution 1 Could suggest a fix for this ? Attached is my patched DSDT.dsl, original DSDT.aml, and IO Registry output from IOJones... If you need anything else, don't hesitate !!! Files.zip
  13. rimkashox

    ati radeon mobillity hd3470

    yeah me too... I need it for Mobility hd 3650!! Looks like if apple doesn't release their next versions of macbook pro with those cards... we're damn screwed!!
  14. rimkashox

    ATI mobility radeon HD 3850 ? laptop

    Yeah guys... there's a lot of us out there with radeon mobility hd... mine is Mobility hd 3650... The ones who have the required knowledge... please do something!! :'( Netkas has done an amazing job for almost all radeon hd cards... but not for the Mobility versions... we should perhaps offer him a laptop with a Mobility radeon hd so he can play around and save us all!!
  15. Taruga, please don't let us down!! :'( The community needs you!!

    You're one of the most important people in the

    OSx86 world!! Without you, hackintoshs have no sound!! Please put the site back online!! Pleaseeeee... We'll make a lot of donations... Promised... Please come back!! :'(

×