Jump to content

mattcurtis

Members
  • Content count

    87
  • Joined

  • Last visited

  • Days Won

    1

mattcurtis last won the day on March 18 2012

mattcurtis had the most liked content!

About mattcurtis

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  1. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    Quick note for anyone who ends up here later, always check the Clover Configuration guide when you're updating things between releases of macOS and Clover. EDID properties have moved to config.plist/Graphics/EDID.
  2. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    How can I tell that the gradients are back? After I interrupt the screensaver, the background is grey (before I could tell because the wallpaper's blur had banding in it).
  3. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    This is the same as using a screen corner to trigger the login screen, right? I have it set up like you do, with 'Require Password' set to immediate. When I trigger the screen-off state via that corner, I don't see the gradients on the login screen.
  4. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    Success! Injecting the EDID above worked Thanks for all the work involved, everyone!
  5. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    What did you use to convert the data to base64? Edit: Used this (http://base64converter.com/) on the .bin file, got this. Booting into OS X to make config.plist edits... AP///////wANr6cVAAAAAB8UAQSQIxN4CgAlnldSmSkVUFQAAAABAQEBAQEBAQEBAQEB AQEBEhtWZFAAFDAQIiYAWMEQAAAYAAAA/gBOMTU2QkdFLUwyMQogAAAA/gBDTU8KICAg ICAgICAgAAAA/gBOMTU2QkdFLUwyMQogAIQ=
  6. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    I'm pretty sure I've made changes correctly but to be sure, here they are: https://i.imgur.com/UBm51Nw.png Steps performed: Extract EDID from registry Switch to EDID 1.4 Open Hexa Editor Change first basic parameter from 80 to 90 Close it, Deltacast EDID will prompt for checksum fix, hit OK Done
  7. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    OK, I used Deltacast EDID to extract my EDID. I'm not sure if it's worth noting, but during extraction it showed a popup saying that there was an "Extension number error" but that by continue it would be fixed. 00FFFFFFFFFFFF000DAFA715000000001F140103802313780A00259E5752992915505400000001010101010101010101010101010101121B5664500014301022260058C110000018000000FE004E3135364247452D4C32310A20000000FE00434D4F0A202020202020202020000000FE004E3135364247452D4C32310A2001940000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 Screencap: https://i.imgur.com/ZlP9uPt.png I'm reading up on EDID now, but I'm still unsure what changes I need to make.
  8. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    Never edited/injected an EDID before. Any guides? So far I've extracted my EDID using IORegistryExplorer, now I am trying to find out how to edit the version/other data... <00 ff ff ff ff ff ff 00 0d af a7 15 00 00 00 00 1f 14 01 03 80 23 13 78 0a 00 25 9e 57 52 99 29 15 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 12 1b 56 64 50 00 14 30 10 22 26 00 58 c1 10 00 00 18 00 00 00 fe 00 4e 31 35 36 42 47 45 2d 4c 32 31 0a 20 00 00 00 fe 00 43 4d 4f 0a 20 20 20 20 20 20 20 20 20 00 00 00 fe 00 4e 31 35 36 42 47 45 2d 4c 32 31 0a 20 00 95> <00ffffffffffff000dafa715000000001f140103802313780a00259e5752992915505400000001010101010101010101010101010101121b5664500014301022260058c110000018000000fe004e3135364247452d4c32310a20000000fe00434d4f0a202020202020202020000000fe004e3135364247452d4c32310a200095>
  9. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    Oh wow, I'll have to give this a shot. Thanks for all the work, ahmed, and for the EDID suggestion vusun. So if I'm understanding, the EDID injection will solve the gradients problem, but upon reboot what happens?
  10. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    With this same graphics card? What laptop/machine? And not on an external monitor - but on the laptop's own built-in display? There's also several comments below that mention possible solutions....
  11. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    Wow. I thought I was having a slightly different issue from you guys as mine always showed the banding, but I just switched to UEFI Boot in the BIOS and now I have the same behavior, with banding not being present initially but occurring after the display goes on and off. Interesting.
  12. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    On my laptop, a Lenovo G510, the gradient banding is there from boot to Finder-ready. So I'm not sure that the trigger is screen on/off (at least for me).
  13. Intel HD4600 banding/gradient/16-bit colors issue Y510p

    BUMP - any updates? I've also posted this issue over at the here for additional support.
  14. VoodooHDA 2.8.5 for Mavericks (Slice + AnV) (Signed!)

    Tried this with my Intel HDA on my Lenovo G500, got rid of the bass/static issues with the last version of VoodooHDA (except slight, almost unnoticeable crackle that appears randomly, might be a result of my settings and not this) Thanks for the impressive work!
×