Jump to content

mitch1

Just Joined
  • Content Count

    18
  • Joined

  • Last visited

About mitch1

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. mitch1

    Darkwake issues since Catalina

    see here - I tried a few things including clean install - and found some others with the same issue - it seems to be a Catalina issue /bug not hackintosh related - I have resorted to scheduled reboot once a day for the time being.
  2. Unfortunately the clean install is doing the same again . 1st night fine then second night turns into an insomniMac ! May try the voodooHDA Kext next else just switch back to Mojave .. don’t like admitting defeat though. I've just been playing with the log and using pmset -g log|grep -e " Sleep " -e " Wake " -e " DarkWake " reveals a bit more info. A bit of googling found this https://www.tonymacx86.com/threads/catalina-odd-wake-behavior.286554/ and https://discussions.apple.com/thread/250859699 which is the exact same issue. [*process=dasd request=Maintenance ... seems to be the issue - no resolution yet but restarting everyday seems to stop it occurring. I'm thinking this is a Catalina bug rather than EFI problem.
  3. Hmm not sure that’s the same as mine ? Much less frequent and no Darkwakes in the log. Extract from my brand new install onto new Hdd attached - no wakes overnight and the couple in the day was me touching keyboard. Will see again tonight if it stays asleep. Really no mega odd 3rd party software on the problem build except Tuxera NTFS driver and VNC server so of it stays asleep without these I’ll look here next.
  4. pmset -g log | grep -iE "wake from|entering sleep"
  5. VirtualSMC no different here either. Also unplugged optical drives and wifi card just in case- Same result - goes all night to from 22:47 - 6:56am every few minutes. Is yours the same or no problem? next up I will try clean install on a spare HDD.
  6. Yes switched to your latest clover folder from post 1. Kept my usb ssdt as I have a mini tower. If yours is not having the same issues I can only assume it’s hardware related - if no change with VirtualSMC I will unplug BDdrive next (although was no issue in Mojave)
  7. unfortunately no change with the slimmed down driver folder or removal of sensor kexts. Just switched to VirtualSMC to see if that makes any difference.. will report back. Its such a tedious process as it always sleeps fine the first night to start doing the same tonne of darkwakes on the 2nd night
  8. If it ain’t broke don’t fix as they say ... but I am intrigued
  9. Thanks - i'm giving the stripped down version a shot now. I'm already using DW=8. If this doesn't solve i'll start removing SMC sensor kexts. Seems virtual SMC is the newer way to go - have you tried that one at all?
  10. Hi @Donw35 i'm still having sleep issues since catalina upgrade - detailed post below. I just thought i'd recheck my clover folder vs your latest in post 1 - it seems like you have only ApfsDriverLoader.efi and OsxAptioFix3Drv.efi in drivers in the latest iteration? I'm still using a few from a previous iteration - can I ask what made you tweak them down to just the 2 above? anything here likely to help solve my sleep / darkwake issue?
  11. Really frustrating issue with sleep since Catalina on my HP 800G1 This was all working fine on Mojave. Wondering if it is because I upgraded in situ (after updating clover and kexts)? I’ve tried toggling FixRTC etc and bootflags darkwake=8 , 10 , 0 , no 2 USBports are mapped and showing under the port limit I’ve checked NVRAM is working and I have also tried putting the Darkwake flags directly in NVRAM Using “sudo nvram boot-args="darkwake=8”. It stays persistent following reboot I remove the flag (either from clover bootargs or NVRAM), wake on lan only ever wakes the machine to Darkwake state (I use wake on lan so don’t wan’t to disable) Also manually updated mDNSresponder.plist with -disablesleepproxy The machine will stay asleep overnight once then on second night goes back to waking every few minutes for 45secs 2019-11-24 21:56:54 +0000 DarkWake DarkWake from Normal Sleep [CDN] : due to RTC/Maintenance Using AC (Charge:0%) 45 secs 2019-11-24 21:57:39 +0000 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 14974 secs 2019-11-25 02:07:13 +0000 DarkWake DarkWake from Normal Sleep [CDN] : due to RTC/Maintenance Using AC (Charge:0%) 45 secs 2019-11-25 02:07:58 +0000 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 209 secs 2019-11-25 02:11:27 +0000 DarkWake DarkWake from Normal Sleep [CDN] : due to RTC/Maintenance Using AC (Charge:0%) 45 secs 2019-11-25 02:12:12 +0000 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 385 secs 2019-11-25 02:18:37 +0000 DarkWake DarkWake from Normal Sleep [CDN] : due to RTC/Maintenance Using AC (Charge:0%) 45 secs 2019-11-25 02:19:22 +0000 Sleep Entering Sleep state due to 'Maintenance Sleep': Using AC (Charge:0%) 221 secs 2019-11-25 02:23:03 +0000 DarkWake DarkWake from Normal Sleep [CDN] : due to RTC/Maintenance Using AC (Charge:0%) 45 secs Pmset-g assertions shows assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 0 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 114(hidd): [0x000020fe00098990] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:100000467 name:AppleUserHIDEventSe product:USB Receiver eventType:3" Timeout will fire in 600 secs Action=TimeoutActionRelease Kernel Assertions: 0x104=USB,MAGICWAKE id=500 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.1d100000 owner=IOUSBHostDevice id=501 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.1a100000 owner=IOUSBHostDevice id=505 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14300000 owner=USB Receiver id=506 level=255 0x100=MAGICWAKE mod=25/11/2019, 06:56 description=en0 owner=en0 Idle sleep preventers: IODisplayWrangler pmset -g sched shows nothing I've googled pretty much everything I can think of.. Next I might try a fresh install / roll back - but I don't like admitting defeat! Any other ideas? Attached current config.plist and EFI (had to remove something.scap from EFI/apple/firmware to get below size limit config.plist EFI 2.zip
  12. mitch1

    Clover problems report & features request

    It seems that RC scripts are not working for me in Catalina? Specifically 70.disable_sleep_proxy_client.local. I noticed my mac was waking up every 2 hrs. Seems /System/Library/ read only in Catalina so if I tried manually to run the script all I get is errors. had to do "sudo mount -uw /" then run "killall Finder" and copy a modified version over so sleep issue now gone.
  13. Updated my Mini Tower to Catalina and noticed I was getting the machine wake up every 2hrs then go back to sleep. (previously was working fine with Mojave) Found that there is a script in Clover ( v2.5k r5096 ) which is used to stop this called "70.disable_sleep_proxy_client.local" but this was not getting applied. Catalina has broken it. I found some other ways that although manual should apply the same.. "sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist ProgramArguments -array-add -DisableSleepProxyClient" This didn't work either - as Catalina makes /System/Library/ read only all you get is errors In the end I found this "sudo mount -uw /" then run "killall Finder" This remounts and makes writable (until reboot). So you can now modify the com.apple.mDNSResponder.plist to add "-DisableSleepProxyClient" or just swap yours for mine attached. It is Likely you'll have to redo on each update unless it gets fixed in clover. During this whole process I also created a USBmap.kext and removed Injectall kext which might also be useful for those with a MT. On another note... Anyone tried to get Sidecar working yet??! I have tried the various tweaks I found but no success yet.. defaults write com.apple.sidecar.display allowAllDevices -bool YES defaults write com.apple.sidecar.display hasShownPref -bool true open /System/Library/PreferencePanes/Sidecar.prefPane com.apple.mDNSResponder.plist USBMap.kext.zip SSDT-UIAC.aml
  14. Anyone updated to 10.14.5 ? This will be my first update so want to make sure I don’t miss anything. Clover and kext update first needed?
×