Jump to content

machinist

Members
  • Content count

    77
  • Joined

  • Last visited

About machinist

  • Rank
    InsanelyMac Protégé
  1. And it's like this: I have a non-airport wifi dongle which is my only working network device. I do not have an additional wired ethernet connection. I routed the compact adapter (displaying as not connected in Network prefs) through en2 (displaying as active in Network prefs), and can access the App Store. No "additional wired ethernet connection at EN0 with the built-in property set is required," simply some clever configuration.
  2. Obviously. Thought your point was "(The App Store app) will not work with wireless cards that aren't recognized as "Airport"? It will work with any compatible wireless card, whether recognized as "Airport" or not. Perhaps I'm missing your point?
  3. My Linksys (Ralink RT73) USB dongle is of course not recognized as an "Airport," yet I have no problem logging on to the App Store. Simply rerouted the feed through one of my ethernet ports, so it appears to be a hard line, though it's entirely wi-fi.
  4. OS X 10.7 (Lion) install on Dell Optiplex 745

    Post your boot plist (and other pertinent info), BugsB, and we can all have a go at it? Much quicker to access your PCI Card's fb info through system information, btw, rather then dvd player etc.
  5. OS X 10.7 (Lion) install on Dell Optiplex 745

    You are welcome to it. Kudos. Enjoy. Try out the other frame buffers and have fun. This "community" has provided me with much and it's my pleasure to reciprocate at least a little. Good work.
  6. OS X 10.7 (Lion) install on Dell Optiplex 745

    Vlad, when you open Terminal and enter ioreg -l | grep -15 "AppleACPIPCI" | grep "_UID" what do you get?
  7. OS X 10.7 (Lion) install on Dell Optiplex 745

    Vlad: Have you tried PCIRootUID=4 (or whatever "grep" indicates is your PCIRootUID?) Which iteration of OS X are you running?
  8. OS X 10.7 (Lion) install on Dell Optiplex 745

    Empirically 100%. Deleted key, rebooted, and was greeted by the generic RadeonFB. Tried "PCIRoot" with same outcome. Now I'm back with Uakari as my FB and "PCIRootUID=1" in my plist. So, yeah, I'm sure. Edit: Stray thought; try removing AppleACPIPlatform.kext from your system(s). Also, have you tried "safe booting" (-x)?
  9. OS X 10.7 (Lion) install on Dell Optiplex 745

    BugsB: Well, at least chameleon is responding to your efforts? The rom is NOT being "loaded" by your Dell, it's merely being read by chameleon. But it's progress? You do have GraphicsEnabler enabled? Not that makes any difference, but would you please give PCIRootUID its own key, and 4 its own string? (Tidier:less kludgey)
  10. OS X 10.7 (Lion) install on Dell Optiplex 745

    Keep trying? Sometimes a reboot or two is necessary for the changes to take effect. Remove "Baboon" first and see if it still hangs, then remove the rom call. Run ioreg -l | grep -15 "AppleACPIPCI" | grep "_UID" to discover your pciuid, if you haven't already? Don't know that you are doing anything "wrong," but these are a few of the things you can try?
  11. OS X 10.7 (Lion) install on Dell Optiplex 745

    BugsB, Vlad, et al: Attached is my bin/rom extracted in Win7(64) by trixx, sapphire's oc utility. It is NOT a zip file, so simply rename it to bin or rom. Can't be bothered compressing a ~60kb file. Notably, it is a couple kb smaller then extracts from other tools. Bought my card through Newegg a couple/few weeks ago. I think BugsB "Amazon" card was sourced through them at that time? UseAtiROM is a Yes/No command whereas AtiConfig summons the Monkeys. A fb can't be forced on a card the system doesn't recognize. And the rom only acquaints the system with the card's specs. If it could override the system's read of the card we'd all be using the function to oc our gfx. Previous testing was with 10.6.8. With 10.7.3 Uakari is a strong contender to displace Baboon as my fb of choice. I'll be monkeying about with it for a while I suspect? I'm using Uakari right now. Vlad, perhaps you might want to not use the kernel cache in your boot.plist? While it speeds booting, it won't automatically reflect changes made in the system. BugsB, there are more then those two options. 5450M was recognized in 10.7+ without adding in device ids, so I suspect they are already in the appropriate kexts. GE is necessary, of course. I'll run some trials with different configs and see what's the least one needs do to get the 5450M recognized. Park5450M.zip
  12. OS X 10.7 (Lion) install on Dell Optiplex 745

    Vlad, your boot.plist looks fine. Add PCIRootUID=1 (or 0, whichever works) and that should be good. Chameleon is seeing and identifying your 5450, but not matching it up properly to your board. The ioreg indicates you are loading the generic RadeonFb. Try the PCIRootUID argument and see if that flies?
  13. OS X 10.7 (Lion) install on Dell Optiplex 745

    BugsB: I'm certain our cards are the same. - Make sure device id 0x68E11002 is present in ATIRadeonX3000 and ATI5000Controller kexts. Continue to say "Yes" to the GraphicsEnabler. (remove any injectors or inserters) - Try PCIRootUID=1 and PCIRootUID=0. <key>PCIRoot</key> is not the same as <key>PCIRootUID</key> and would not have and will not work. You did it right the first time, but with a wrong command. I use the Property List Editor found in Apple's free Developer package, but if you simply enter, precisely, PCIRootUID=X when your chameleon volume choice presents, it reads as a boot argument. Your PCIRootUID value may be 0 or 1; try both. If you'd like, upload your boot.plist and I'll review it for you? - Add Wait=Yes to your boot.plist so you can see which fb loads. It's not the card. No offense, but you're likely making a very simple error somewhere, as when you previously entered PCIRoot for PCIRootUID, or reversed the order of the subsysid and subsys. For an alternate rom to be read, for example 1002_68E1_3000174b.rom, it must be in that specific format. Though it doesn't matter in this instance whether "E" or "b" is in caps or not, it does when you enter UseAtiROM=Yes, or AtiConfig=Eulemur/Baboon/Hoolock/OtherMonkey. Good luck.
  14. OS X 10.7 (Lion) install on Dell Optiplex 745

    BugsB et al: I feel your frustration. I suspect yours is a PCIRootUID issue. Chameleon r1897 reports "our" card as a 5430M Cedar while r1908 displays it as a 5450M Cedar. It's purely cosmetic and makes no difference in performance. Whether it's in a laptop or desktop, it's still a 5450M "Park". It's a "Mobility Series" AMD chip. However, using the "Baboon" fb improves performance by every metric in every test. Save for weaknesses in opengl extensions 1.2 through 1.4, the 5450 performs almost as well as it does in Windows. Haven't edited every fb monkey personality yet for testing, but "Eulemur" is the worst by far thus far. Maybe one of the other "monkeys" will surprise me and "outdo" "Baboon"? This Sapphire card however, does overclock solidly to 750/850 in Windows without any additional cooling, and I'm using it at 800/850 right now with no issues, though I've a small fan trained on the heat sink. Once I'm sure it's solid, I'll flash it in Windows so it will run this way in OS X. Cinebench results improve dramatically, from ~9fps to 13+fps, which of course is not "great," but it is a $14.99 card, not $149. I for one like to squeeze every fps of performance from my hardware. Try using PCIRootUID=1. Hope you get your rig working.
  15. The Best Bootloader

    If you happen to have a Gigabyte mb, you may find Cartri's Mac Bios project to be of interest. http://cartri.net/blog/mac-bios-status-table
×