Jump to content

an3k

Just Joined
  • Content Count

    33
  • Joined

  • Last visited

Everything posted by an3k

  1. an3k

    AppleALC — dynamic AppleHDA patching

    Awesome, thank you very much!
  2. an3k

    AppleALC — dynamic AppleHDA patching

    If that is what real Macs do and only if you want and it doesn't cause to much work I'd love it
  3. an3k

    AppleALC — dynamic AppleHDA patching

    It's working now! No headset connected: output device -> "Internal Speakers" -> working input device -> "Internal Microphone" -> working input device -> "Line-In" -> not working Headset connected: output device -> "Headphones" -> working input device -> "Internal Microphone" -> working input device -> "Line-In" -> working Internal Microphone as well as Line-In needs 90% input volume to be as loud as normally and automatic switching from Internal Microphone to Line-In isn't working (I don't know if genuine Macs do that).
  4. an3k

    AppleALC — dynamic AppleHDA patching

    Yes, now it works again. Maybe just forum maintenance Will test now
  5. an3k

    AppleALC — dynamic AppleHDA patching

    Oh noes, the SSDT-CX8200.aml isn't available anymore.
  6. an3k

    AppleALC — dynamic AppleHDA patching

    I re-installed Windows on the Laptop because I wanted to gather some other data (mostly CPU FrequencyVectors) but also to test the headset jack in Windows (it's the only thing we haven't tested for functionality yet). Is there anything I can do to get more data you could need? I'll reinstall macOS later and test the above. I got all my configs, EFI, etc. so it will be the same system
  7. an3k

    AppleALC — dynamic AppleHDA patching

    Thank you very much so far. You definitely helped even if it's not 100% perfect. Before the headset jack wasn't working at all. I kept every kext you sent and made notes so I know which one of the working ones is the best Again, thank you! I would be absolutely fine with that, if you ask me!
  8. an3k

    AppleALC — dynamic AppleHDA patching

    exactly the same.
  9. an3k

    AppleALC — dynamic AppleHDA patching

    No headset connected: output device -> "Internal Speakers" -> working input device -> "Internal Microphone" -> working input device -> "Line-In" -> not working Headset connected: output device -> "Headphones" -> working input device -> "Internal Microphone" -> working input device -> "Line-In" -> not working
  10. an3k

    AppleALC — dynamic AppleHDA patching

    I verified the headset has a microphone and that it is working. I plugged it into the PS4 and I heard audio in the headset and saw the microphone input level moving as I spoke. I have no other microphone attached. I also connected the headset to my computer that runs Windows and it works there too. With "Audio is too quiet" I mean the Internal Speaker. However I'm not 100% sure it is louder on Windows (it's a super thin laptop so not much room to generate audio).
  11. an3k

    AppleALC — dynamic AppleHDA patching

    No headset connected: output device -> "Internal Speakers" -> working input device -> "Internal Microphone" -> working Headset connected: output device -> "Headphones" -> working input device -> "Line-In" -> no working
  12. an3k

    AppleALC — dynamic AppleHDA patching

    again, no change. Sorry for having such a weird codec causing so much trouble.
  13. an3k

    AppleALC — dynamic AppleHDA patching

    Yes, it's a single jack which supports either headphones or headset. Headphones: Headset:
  14. an3k

    AppleALC — dynamic AppleHDA patching

    Ok, have a good night and thank you very much!
  15. an3k

    AppleALC — dynamic AppleHDA patching

    No headset connected: output device -> "Internal Speakers" -> working input device -> "Internal Microphone" -> working Headset connected: output device -> "Headphones" -> working input device -> "Internal Microphone" -> working However now the microphone is super quiet and I had to put the "input volume" slider from stock 50% to 90% to approx. get the same volume.
  16. an3k

    AppleALC — dynamic AppleHDA patching

    No headset connected: output device -> "Internal Speakers" -> working input device -> none -> not working Headset connected: output device -> "Headphones" -> working input device -> none -> not working
  17. an3k

    AppleALC — dynamic AppleHDA patching

    No headset connected: output device -> "Internal Speakers" -> working input device -> "Internal Microphone" -> working Headset connected: output device -> "Headphones" -> working input device -> "Internal Microphone" -> working
  18. an3k

    AppleALC — dynamic AppleHDA patching

    Again the same No headset connected: output device -> "Internal Speakers" -> working input device -> none -> not working Headset connected: output device -> "Headphones" -> working input device -> none -> not working
  19. an3k

    AppleALC — dynamic AppleHDA patching

    Yeah, I was told that yesterday evening and moved everything from L/E to EFI/CLOVER/Other. I never put anything into S/L/E. I edited my previous posting and said I was just mentioning L/E and S/L/E so I'm (and you are) absolutely sure there aren't multiple AppleALC.kexts in place. I'm absolutely sure that every test I've done with your help and kexts was done correctly. The very first kext you made for me was the best so far. Everything worked beside Headset audio input. Would it help you if I quickly install Windows and do some stuff? You'd have to tell me what you'd need.
  20. an3k

    AppleALC — dynamic AppleHDA patching

    I am. Deleted all the AppleALC.kexts I had (in /System/Library/, in /System/Library/Extensions and in EFI/CLOVER) then re-downloaded the last kext and "installed" it. This is the result :/ EDIT: Well, I didn't had multiple AppleALC.kexts installed, was just making sure I actually didn't
  21. an3k

    AppleALC — dynamic AppleHDA patching

    Exactly the same behavior as with the previous kext.
  22. an3k

    AppleALC — dynamic AppleHDA patching

    I made sure I'm doing the right thing and used the AppleALC which worked for Audio-Out but not for Audio-In and yes, I'm doing the right thing (I wasn't sure either ;)). I get the same result with your latest kext as with the previous one, no audio devices. With these two new kexts we're still at layout-id 21 I assume?
  23. an3k

    AppleALC — dynamic AppleHDA patching

    no Audio-Out or Input devices anymore.
  24. an3k

    AppleALC — dynamic AppleHDA patching

    Stupid me had a Headset (somewhere tucked away). As with Headphones plugging in a Headset works perfectly for Audio-Out. For Audio-In however while it changes from "Internal Microphone" to "Line-In" there is no actual audio input (tried system settings as well as voice recorder). I made sure that both the port as well as the plug are using the same layout.
×