Jump to content

namisloc

Just Joined
  • Content Count

    6
  • Joined

  • Last visited

About namisloc

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Male
  • Location
    Florida, USA
  • Interests
    Music
  1. namisloc

    Lenovo ThinkPad T420 with UEFI Only

    @tluckI was having issues with firefox application windows freezing when moving (note: HD3000) and noticed that others were seeing the problems fixed when they used 2e3 config. I tried this and it fixed the exact issue that was causing the graphics glitch. I decided to take it a step further and delete the other configs from my EFI so it could only load this working config.plist. However, now when I boot it's a very slow booting window that freezes at a black screen. I can boot Ubuntu from USB, but I can't access the EFI drive (at least I don't know how). ------------------------------------------ Problem solved. Nevermind, I was able to plug in the bootdrive to my PC and using minitool partition wiz and explorer++ I added the configs back to the EFI and I'm booted up with my random freeze issue seemingly solved. Cheers!
  2. namisloc

    Lenovo ThinkPad T420 with UEFI Only

    Cheers, appreciate the help! Trackpad is blank in system preferences. Ran both scripts, here are the results. $ kextstat|grep voodoo 49 2 0xffffff7f82af9000 0xb000 0xb000 org.rehabman.voodoo.driver.PS2Controller (1.9.2) 39822203-AB99-38FA-85DB-A83BA02A60CA <11 7 5 4 3 1> 69 0 0xffffff7f82b3f000 0xc000 0xc000 org.rehabman.voodoo.driver.PS2Trackpad (1.9.2) E616F856-B251-31D5-8A8F-767E322E1C24 <49 41 15 7 6 5 4 3 1> 70 0 0xffffff7f82b4b000 0x6000 0x6000 org.rehabman.voodoo.driver.PS2Keyboard (1.9.2) 3D5B784B-4D8C-3838-BD2F-3AB5E20742A9 <49 41 15 7 6 5 4 3 1> $ ioreg -l -w0|sed -n "/o ApplePS2SynapticsTouchPad/,/RM,Build/p" | | +-o ApplePS2SynapticsTouchPad <class ApplePS2SynapticsTouchPad, id 0x100000259, registered, matched, active, busy 0 (114 ms), retain 11> | | | { | | | "StickyMultiFingerScrolling" = No | | | "UnitsPerMMX" = 50 | | | "DisableZoneBottom" = 4200 | | | "HIDPointerConvertAbsolute" = <00> | | | "IOProviderClass" = "ApplePS2MouseDevice" | | | "HIDScrollResolution" = 52428800 | | | "MomentumScrollTimer" = 10000000 | | | "SwipeDeltaY" = 800 | | | "HIDResetPointer" = Yes | | | "ScrollDeltaThreshY" = 10 | | | "BogusDeltaThreshY" = 800 | | | "HIDClickTime" = 500000000 | | | "ZoneRight" = 5200 | | | "IOClass" = "ApplePS2SynapticsTouchPad" | | | "FakeMiddleButton" = No | | | "StickyVerticalScrolling" = No | | | "UnsmoothInput" = Yes | | | "HIDInterfaceID" = 5 | | | "DisableZoneRight" = 1700 | | | "VendorID" = 1452 | | | "MaxTapTime" = 100000000 | | | "HIDPointerResolution" = 209715200 | | | "MomentumScrollMultiplier" = 98 | | | "UnitsPerMMY" = 50 | | | "HWResetOnStart" = Yes | | | "DoubleTapThresholdX" = 150 | | | "TrackpointScrollXMultiplier" = 1 | | | "Revision" = 24 | | | "RM,Build" = "Release-" | | +-o ApplePS2SynapticsTouchPad <class ApplePS2SynapticsTouchPad, id 0x100000259, registered, matched, active, busy 0 (114 ms), retain 11> | | | { | | | "StickyMultiFingerScrolling" = No | | | "UnitsPerMMX" = 50 | | | "DisableZoneBottom" = 4200 | | | "HIDPointerConvertAbsolute" = <00> | | | "IOProviderClass" = "ApplePS2MouseDevice" | | | "HIDScrollResolution" = 52428800 | | | "MomentumScrollTimer" = 10000000 | | | "SwipeDeltaY" = 800 | | | "HIDResetPointer" = Yes | | | "ScrollDeltaThreshY" = 10 | | | "BogusDeltaThreshY" = 800 | | | "HIDClickTime" = 500000000 | | | "ZoneRight" = 5200 | | | "IOClass" = "ApplePS2SynapticsTouchPad" | | | "FakeMiddleButton" = No | | | "StickyVerticalScrolling" = No | | | "UnsmoothInput" = Yes | | | "HIDInterfaceID" = 5 | | | "DisableZoneRight" = 1700 | | | "VendorID" = 1452 | | | "MaxTapTime" = 100000000 | | | "HIDPointerResolution" = 209715200 | | | "MomentumScrollMultiplier" = 98 | | | "UnitsPerMMY" = 50 | | | "HWResetOnStart" = Yes | | | "DoubleTapThresholdX" = 150 | | | "TrackpointScrollXMultiplier" = 1 | | | "Revision" = 24 | | | "RM,Build" = "Release-" sed: RE error: illegal byte sequence
  3. namisloc

    Lenovo ThinkPad T420 with UEFI Only

    Sorry friend, I meant to put my build in my signature before making my last post. Bluetooth is working, however I'm unable to access any trackpad preferences. My BIOS was 1.49, and I downloaded what I thought was a 1.52 whitelisted mod, however it rolled my BIOS back to 1.41. Now, it's a modded 1.41, I have access to the advanced menu and whitelist removed. Sierra installed smoothly so I decided to just leave it be. I wanted the modded BIOS because I have 2x8gb DDR3 and an AR9280 on the way. The EFI folders were copied to ESP.
  4. namisloc

    Lenovo ThinkPad T420 with UEFI Only

    Weird thing, I can't access trackpad int he system pref. Bluetooth: This can't be accessed in the BIOS by chance, can it? I guess I'll have to make a USB bootable OS
  5. namisloc

    Lenovo ThinkPad T420 with UEFI Only

    Thank you, Goodguess. I'm running installs while I wait for the new wireless card. I'm not getting any bluetooth right now, are there steps to get the onboard bluetooth working? Also, my trackpad is working, but I'm not getting single touch, just x and y movement. Any ideas? Synaptics hardware, I believe.
  6. namisloc

    Lenovo ThinkPad T420 with UEFI Only

    Hi T420 peeps! I'm a first time hackintosh builder and I could use some help getting my machine off the ground. I've researched for about a week and I've spent a couple days just trying to get a mountable USB to use (and I'm not even sure if I did that correctly). To some extent I followed TLuck's guide, but I had to create some workarounds for limitations - I'm not sure if maybe I skipped something vital that is creating my current road block. Pertinent information 83ET79WW BIOS 1.49 41786vu intel i5-2520 2.5ghz Intel HD 3000 x Nvidia NVS 4200m 1600x900 BIOS settings Album Creating the USB... After many attempts to create a working USB install directly from my windows desktop using things like R-drive, rufus, win32diskimager, etc., I ended up creating a Mojave environment in VM Workstation. However, I cannot download a copy of Mac OS from the app store, for some reason it keeps returning with an 'incomplete' error even though it's up-to-date. At any rate, I downloaded a .raw file from olarila and used etcher to flash it to my USB. I then ran Clover r4726 pkg from the 10-31-2018 utilities and plugged it into the T420. USB finally working... I boot to clover and the initialization scripts run - I finally see the "Install Mac OS" and disk utility. Which brings me to my current road block: I cannot write to my internal disk. I have unplugged it and swapped it into my desktop to reformat to no avail. I also swapped in a spare clean drive with no luck. My gut feeling is that something in the BIOS is stopping the USB installer from speaking to the hard disk. Any ideas? EDIT: I'm so dumb. "diskutil eraseDisk JHFS+ disknamehere disk0" formatted it with no issues. However now it says that I can't install 10.14 on this computer... ERROR_F236DD3E91 --------------------------------------------------------------------------------------------------------------------------------------------------------------------------- When I run "diskutil list", I'm met with about 30 "drives" including my 160gb install drive and the USB, but also ~28 weird drives of varying sizes. Attempted First aid: Running First Aid on "" (disk0s1) Repairing file system. volume is already unmounted. performing fsck_exfat -y -x /dev/rdisk0s1 checking volume. checking main boot region. main boot region is invalid. trying alternate boot region. checking alternate boot region. alternate boot region is invalid. the volume could not be verified completely. file system check exit code is 1. restoring the orignal state found as unmounted file system verify or repair failed Operation failed... Attempting to format/erase:
×