Jump to content

EngLearnsh

Just Joined
  • Content count

    19
  • Joined

  • Last visited

About EngLearnsh

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    6 days after adding mem to 16gb, the freeze and glitches are finally gone. Now I enjoy with the latest beta version of Mojave, works really awsome:) 通过我的 MI 8 上的 Tapatalk发言 Thanks@tluck, great improvements to solve glitches. I will try the latest clover and AppleALC later. 通过我的 MI 8 上的 Tapatalk发言
  2. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    add mem to 16gb helps, no more glitches and freezes 通过我的 MI 8 上的 Tapatalk发言
  3. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    freezing at last, snb-platform-id injection does not help:( 通过我的 MI 8 上的 Tapatalk发言
  4. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    Do you get freezes on your T420, or just glitches and artifacts? 通过我的 MI 8 上的 Tapatalk发言
  5. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    Also i wonder if the different cpu will cause glitches and freezes, my x220 is i5-2540m, hearing some of users from our chinese hackintosh forum, most of i7 users do not have these problems. 通过我的 MI 8 上的 Tapatalk发言
  6. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    Sorry, i regard dw1502 as dw1520...For ar9285, simply just use FakePCIID.kext and it will work 通过我的 MI 8 上的 Tapatalk发言
  7. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    I have x220 with i5, 4GB ram, AUO TN display originally, I install 10.13 in June and it is terrible of glitches and freezing. This summer, i replace 4GB ram to 8GB(1 stick) and replace au to lg ips display. It seems way way better but still some glitches and freezing occures. I search on google and someone says that freezing is caused by mismatch between framebuffer and physical ports, so I add snb-platform-id to my dsdt and so far there is no freezing(dont know if it is really the solution, no idea) Maybe I nned to buy another 8GB memory stick to get 16GB ram totally. Just a guess:) Also I use the same method to inject edid into dsdt 通过我的 MI 8 上的 Tapatalk发言
  8. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    rehabman has kexts that will make unauthorized bcm wifi card work. check his bitbucket 通过我的 MI 8 上的 Tapatalk发言
  9. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    Rehabman says that hd4000 or above does not have artifacts, but for some situations i still need to continue using my x220, I have been searching for the solution after 10.12 and no luck 通过我的 MI 8 上的 Tapatalk发言
  10. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    It is a clover bug, we cannot do anything except adding slide=0 to reduce them or downgrade to 10.11.3. Even Rehabman says it is normally to have artifacts on hd3000:( 通过我的 MI 8 上的 Tapatalk发言
  11. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    By create a custom AppleBacklightInjector, the following steps are in the guide 通过我的 MI 8 上的 Tapatalk发言
  12. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    maybe your esp partition is less than 200mb? apple disk utility will fail in that case. 通过我的 MI 8 上的 Tapatalk发言
  13. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    keep these config originally. open config.plist and find there are "screenresolution""screenresolution-alt1""screenresolution-alt2", remove alt1 and alt2 then rename 960x600 to 1366x768 通过我的 MI 8 上的 Tapatalk发言 It works on my x220, if there's something else blocking the gui installation, maybe you need to check the data's integrity? 通过我的 MI 8 上的 Tapatalk发言
  14. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    Well try to remove other screen resolution in comfig.plist and set only one to 1366x768 which is your mative solution. Clover may boot in 1024x768 depends on t420 bios and dont worry while the gui installation starts, it will go to 1366x768 通过我的 MI 8 上的 Tapatalk发言
  15. EngLearnsh

    Lenovo ThinkPad T420 with UEFI Only

    Well I update HS to Mojave, everything seems working fine except some problem with ssdt. Is it caused by SMBIOS that is not macbookpro8,1(i use the new config in your recent release which is macbookpro11,1) 通过我的 MI 8 上的 Tapatalk发言
×