Jump to content

unrealpants

Just Joined
  • Content Count

    25
  • Joined

  • Last visited


Reputation Activity

  1. Like
    unrealpants got a reaction from MacPeet in [Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)   
    it worked! I’m so delighted! Thank you so much! 
  2. Like
    unrealpants got a reaction from MacPeet in [Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)   
    > Optiplex780 is still working with Catalina.
     
    Great - there goes my weekend plans.
  3. Like
    unrealpants got a reaction from chris1111 in [Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)   
    I am no expert at this caper -- far from it --  but I am tenacious... and after about four days of effort, I have finally successfully set up Mojave current production (10.14.2) on my old Dell 780.
     
    I'm very pleased to report that 
    * audio is working
         -  with custom boot flags and rolled back HDA kext, cachce refreshes (kextutil) and reboots, so many reboots
    * video is working 
        -  not 100% what the real difference was between my previously functional High Sierra setup and this one but as with HS, I ran through the install process until I could go no further, did the kext rollbacks but still I couldn't get the right resolution.  In the end, I kept trying different intaller processes and used Chris1111's installer which had the InjectATI flag set (for HS I had to *unset* this).  Anyway, it now looks good.
    * wifi is working
        - I had to add the injectatheros kext into the clover setup after running the installer AirPortAtheros40 installer 1.0.1.zip (see Downloads), refresh (kextutil), reboot
    * usb limit
         -  I came across what appears to be a failry common problem where not all of the USB sockets are functional.  I had to apply custom patches for correct OSX version in config.plist AND make sure usbinjectall kext was in the Clover folders
     
    Forgive my lack of detail (correct file names?) but essentially, I am posting this here so that if anyone else is trying to setup a 780 with the same or similar components, I am very happy to share my configuration files that are working.
     
    For those who know more than me, I'd like to explore a couple of extras at some stage
    1) is there any way I can explicitly specify the screen resolution or is it only ever going to use the default for the connected display?  I've tried changing the resolution in the config.plst of clover but nothing changes.  I'm considering changing monitors or even connecting a soon-to-be-replaced TV screen
    2) I haven't managed to get my Ethernet connection working.  It's not essential but I'd like to have the option if I need it.  I'm using the standard on board adapter for the 780 SFF.  Currently I get a message about the Ethernet cable being connected and an IP address had been obtained but no internet connection.  AppleIntelE100e v3.3.6 is loaded.  Is that all I need?  Does this suggest something to do external from the Hackintosh? (cable/modem config/??)?
    3) My CPU - the Core2 Q9400 is apparently overclockable.  Has anyone worked out if it's possible? worth it?
     
     
  4. Like
    unrealpants got a reaction from chris1111 in [Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)   
    I am no expert at this caper -- far from it --  but I am tenacious... and after about four days of effort, I have finally successfully set up Mojave current production (10.14.2) on my old Dell 780.
     
    I'm very pleased to report that 
    * audio is working
         -  with custom boot flags and rolled back HDA kext, cachce refreshes (kextutil) and reboots, so many reboots
    * video is working 
        -  not 100% what the real difference was between my previously functional High Sierra setup and this one but as with HS, I ran through the install process until I could go no further, did the kext rollbacks but still I couldn't get the right resolution.  In the end, I kept trying different intaller processes and used Chris1111's installer which had the InjectATI flag set (for HS I had to *unset* this).  Anyway, it now looks good.
    * wifi is working
        - I had to add the injectatheros kext into the clover setup after running the installer AirPortAtheros40 installer 1.0.1.zip (see Downloads), refresh (kextutil), reboot
    * usb limit
         -  I came across what appears to be a failry common problem where not all of the USB sockets are functional.  I had to apply custom patches for correct OSX version in config.plist AND make sure usbinjectall kext was in the Clover folders
     
    Forgive my lack of detail (correct file names?) but essentially, I am posting this here so that if anyone else is trying to setup a 780 with the same or similar components, I am very happy to share my configuration files that are working.
     
    For those who know more than me, I'd like to explore a couple of extras at some stage
    1) is there any way I can explicitly specify the screen resolution or is it only ever going to use the default for the connected display?  I've tried changing the resolution in the config.plst of clover but nothing changes.  I'm considering changing monitors or even connecting a soon-to-be-replaced TV screen
    2) I haven't managed to get my Ethernet connection working.  It's not essential but I'd like to have the option if I need it.  I'm using the standard on board adapter for the 780 SFF.  Currently I get a message about the Ethernet cable being connected and an IP address had been obtained but no internet connection.  AppleIntelE100e v3.3.6 is loaded.  Is that all I need?  Does this suggest something to do external from the Hackintosh? (cable/modem config/??)?
    3) My CPU - the Core2 Q9400 is apparently overclockable.  Has anyone worked out if it's possible? worth it?
     
     
  5. Like
    unrealpants reacted to MacPeet in [Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)   
    Audio is activated in the BIOS ???
     
    DSDT.aml is in EFI/Clover/ACPI/patched/ ???
     
    Check System Information Extensions in Utilities:

     
    Let KextUtility run again for cache rebuild
  6. Thanks
    unrealpants reacted to MacPeet in [Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)   
    Since the first beta's 10.13.4, the audio codec AD1984A has problems with AppleALC + Lilu (only Optiplex780 and 760).
    With rollback AppleHDA from 10.13.3 it works well.
    AppleHDA.kext_rollback10.13.3.zip

    I have not found the error yet.
×