Jump to content
InsanelyMac Forum

franksanderdo

Just Joined
  • Content count

    8
  • Joined

  • Last visited

About franksanderdo

  • Rank
    InsanelyMac Protégé
  1. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    @tluck I have worked a bit further and made sure that the T470p is working with your EFI folder. The only difference is the patched DSDT and the SSDT patches. In drivers64.efi I am using the new AptioMemoryFix instead of the OsxAptiofix, never the less I tested with OptAptioFix as well and it is working fine. All in all good news, because right now no changes in your image required The bad news is that I have tried to upgrade from 10.13.4 to 10.13.4. SU.... with no success. Some thing must have changed in the KBLFramebuffer driver and with that the DVMT patch is not working any more. I will look into that later. Even though you guys are using SKLFramebuffer there is a chance that you might face the same issue. Just be careful All the best Frank
  2. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    why do I have to ask for the obvious??? Sorry for being a bit slow thinking this days. I will prepare the zip with only diffs this weekend Good you remind were I have seen sleep watcher already. Reduces the searching time a lot As I said, I am a bit tired and slow thinking this days. All the Best Frank
  3. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    @tluck sleep watcher... I will find it and test it. Even though I have no problem with sleep and ethernet. It is only when starting / restarting the system ethernet has to be plugged in to be detected properly. If I don't do that and plug it in after starting only, it detects the cable for a second and than say no cable and again cable detected and a second later no cable.... weird thing that is Let me see what sleep watcher can do For HDMI being connected to the Nvidia that is a good idea. I will try to find some more detailed docs on the T470p. Reports will follow ;-) Any Idea how I get the EFI Folder zip to you as it is to large for the 10 MB limit here? All the Best Frank
  4. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    Hi @tluck as I promised I wanted to upload my EFI folder but it is > 10MB (zipped) so I am wondering How I can get it to you? Today I tried, just for curiosity, the HDMI port..... it did not work. gives me a new project and renders my todo list to be: a) adapting for docking station (I will do when I have Audio working) b) Ethernet only works if plugged in during start. after that I can remove and / or sleep and it is ok c) HDMI not working so presentations / movies on my beamer see you soon and all the Best Frank
  5. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    Hi tluck you are right... I should have copied my EFI folder as well. I can do that tonight. I had to replace the Broadcom kexts against the latest ones as I have the BCM943602BAED and it did not want to work with your set. in addition I am using the modded AppleALC.kext from djydaw. As soon as I find out what he did to make the the ALC298 working I want to document that. As I have left as much as even possible original in your package, there is now a config-t460.plist, config-560.plist and a config.plist which I would rename to config-t470p.plist. Maybe this way we can keep the package working for everybody!? I am working right now on some cosmetics (have a look at the ssd-arpt.dsl) were I am trying to have OSX filling the PCI tab in the system report properly. Not really needed, but I like it to have the information in place Thanks a lot for all the effort you have put in the guide. This made my build possible All the Best Frank
  6. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    Dears I am so happy!! My Todolist from last time: a) Audio (ALC298) were (being a beginner in this hack) I still don't understand what to do. Done thanks to @djydaw b) adapting for docking station (I will do when I have Audio working) c) final adjustments for USB power (start working on that today) Done, thanks to my OmenX were I have kind of learned how to do it d) wifi & BT.... waiting for the Broadcom card I have ordered Done, thanks to a german supplier not afraid to send parts to Middle East e) Facetime & iMessage f) Autologin with Apple Watch is not yet working. Started working now and I don't know why g) Ethernet only works if plugged in during start. after that I can remove and / or sleep and it is ok The docking station stuff has to wait until I get my station back. (need it in the office for the next weeks) For those who are interested, I have attached the folder "DSDT.T470p" which belongs were the T460 and T560 folder are. If I did not mess things up, it would work out of the box on any T470p with recent bios. All the Best Frank DSDT.T470p.zip
  7. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    Hi tluck after fiddling around for some time I have the t470p working in some parts based on this instructions. missing right now: a) Audio (ALC298) were (being a beginner in this hack) I still don't understand what to do. b) adapting for docking station (I will do when I have Audio working c) final adjustments for USB power (start working on that today) d) wifi & BT.... waiting for the Broadcom card I have ordered I just figured that in the beginning of the process I must have messed with my clover configs so I will have to merge my settings into your config.plist everything else I managed to keep adjustments in the t470p folder I created based on your t460 folder. So I guess soon I can send you the folder, that you can add it to your archive. Thanks a lot for all the effort you have put into the guide. It helped me a lot in learning!! All the Best Frank
  8. franksanderdo

    [GUIDE] Lenovo T460 macOS with Clover

    Hi diydaw I am right now working on a T470p which has the same audio codec. may i know what you have modified in applealc? All the Best Frank
×