Jump to content
InsanelyMac Forum

Anonymous03

Members
  • Content count

    13
  • Joined

  • Last visited

About Anonymous03

  • Rank
    InsanelyMac Protégé
  1. So as far as I understand all usb ports on my motherboard (2 USB2.0 Intel, 2 USB3.0 Intel, 2 USB3.0 ASMedia - 6 total) routs it's USB2.0 devices to Intel EHCI chip (even in ASMedia port) that (with IOProbeScore -1) controlled by AppleUSBEHCI, correct? And even if System Information -> USB -> Host Controller Driver says GenericUSBXHCI in fact iPad at ASMedia port really routed to Intel EHCI chip and controlled via AppleUSBEHCI driver, so extra current works in any port. With IOProbeScore 1 all ports routs to XHCI(intel chip for intel ports, asmedia chip for asmedia ports)/EHCI chip and controlled only via GenericUSBXHCI with no extra current Am I correct? Please correct me if I'm wrong.
  2. As I can see on your screenshot, extra-current on USB2.0 is not working for you too. Try changing IOProbeScore from 1 to -1 in GenericUSBXHCI.kext/Contents/Info.plist and fix permission, rebuild cache. You will have proper ipad charging and faster iphone charging.
  3. Oh wow! I made IOProbe = -1 on GenericUSBXHCI kext and now extra-current works on both Intel AND ASMedia ports. So now it's like: Generic (-1) -> ASMedia (Generic) works + Intel (Apple native) works + extra-current works Generic (1) -> ASMedia (Generic) works + Intel (Generic) works + NO extra-current Native -> ASMedia (Generic) NOT works + Intel (Apple native) works + extra-current works All devices USB2.0 and mounted on Hi-speed bus. Don't have usb 3.0 devices to test.
  4. so is it possible to enable extra current? With Intel kext and on my macbook it also shows as high speed device, but adds extra operating current EDIT: Attached screens with native intel kext. Archive.zip
  5. Seems it's not work, extra operating current @500mA for iPhone is not appeared in System Information -> USB Can't test for iPad now. attached screenshot of System Information and xhcdump Archive.zip
  6. I hope it will help xhcdump.txt
  7. Hi, thanks for your awesome work. I have 99% perfect working system except for extra-current. Still can't enable it. I have ASUS P8Z77-M Pro with intel/ASM1042 USB Is there any way to make it work?
  8. Tried clearing kext cache, same thing, extra-current not working
  9. It supersede them. At least for me. Want that too so Also after installing this universal kext I've lost extra-current feature (that worked well on CalDigit's kext and Intel) so I can't normally charge my iPad anymore. Is there a way to enable extra-current on this kext? Or at least on intel ports?
×