Jump to content

Thane5

Members
  • Content count

    16
  • Joined

  • Last visited

About Thane5

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

254 profile views
  1. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    Booting the installer? Do you mean i have to reinstall it for this to work? I already tried to do that with the installed MacOS partition and it didnt change anything.
  2. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    I've tried these several methods of booting into clover, but it still skips. I even double checked that i was using your Clover folder. Bios settings should be the same too... this is getting really strange here.
  3. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    Strange, i'm using a regular 16 gb USB to boot from, but it simply doesnt work. No clover, nothing. it just skips it.
  4. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    Its booting and i'm getting the Apple loading screen, but halfway through it gets black again. Maybe you could send me your entire EFI to make sure its not a kext issue?
  5. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    Do you have the i7? Because my i5 8Gb cant boot from that one at all.
  6. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    No luck with that either. Most of these changes have no effect, but the new "ig-platform-id" again disables any graphical output and gives blackscreen.
  7. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    It does boot if i use my Config, but only with inject intel active, but the Graphics acceleration still wont work then.
  8. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    i unchecked "inject Intel", same result.
  9. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    The kexts of that folder seem to be working, but something in your config gives me a blackscreen after a while of the boot process. I also can't find these boot options that you are describing in my version of clover.
  10. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    Nope, doesnt work. Says "Graphics Driver Failed to load: could not register with framebuffer driver!" during the boot process
  11. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    That one Send me Thane5-MacBook-Pro.zip
  12. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    Big thanks for your help so far; the problem was in fact that the Surface can't boot from the microSD slot right now. If plugged into the USB port via a hub, it works as it should and i can boot into macOS. And amazingly, The touchpad and Keyboard work without problems, but of course touchscreen, touchpad gestures and pen don't. but thats for a later time. What i need to get fixed now is the graphics. for some reason, it runs in the native monitor resolution 8just like clover, idk why), and the intel hd 620 graphics are listed in the "About my Mac" window, though with most likely inaccurate video ram amounts. Also the general Ui is very laggy, animatiosn slow, and strong screen tearing plague it, just like you would expect it with disabled graphics. i'll try to find out more about that tomorrow. Most recent EFI attached here. EFI.zip
  13. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    That one finally lets me use the installer and install macOS sierra on my SD card, and on the first boot (where you only see the apple logo with a loading bar on white background) it finishes the installation, but then shuts down. If i restart, it now only gives me the microsoft logo and attemtps to restart. I think that this could be related to the Surface pro beein unable to boot from an SD card, so i'll probably try to install it on an SSD partiiton of the same size.
  14. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    It's the "New" Surface Pro from 2017, with a Kabylake i5 7300U and Intel HD 620. Running on a 256 Gb SSD, 8Gb of Ram. I want to run this thing on my 64Gb micro SD card. https://imgur.com/a/iKzYPThis is what i see last with your clover folder, then the screen goes black, even with restart after kernel panic disabled. i've had this before with different changes i've made to my config, but i assumed this is worse than my first result where it stops at "kdp_poll: no debugger device"
  15. Thane5

    Lets Hackintosh the Surface pro 5 (2017)

    It made sense to me that this could be the reason, but no, still stuck at the same spot.
×