Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Piplodocus

Members
  • Content count

    16
  • Joined

  • Last visited

About Piplodocus

  • Rank
    InsanelyMac Protégé

Profile Information

  • Gender
    Not Telling
  1. More iCloud Not Working Advice?

    YES!!!! I followed this... http://www.insanelymac.com/forum/topic/284684-icloudfacetimeappstore-login-errors/ I'd put SystemID in chameleon.boot.plist, not SystemId!!!!
  2. YES!!!!!!!!!!!!! I love you! I could give you babies in the bum! Been stuck on this for ages, and found in IORegistryExplorer I had no system-id, and had put "SystemID", not "SystemId" as the boot flag thing. Thanks so much!
  3. Hello! My iCloud doesn't work with the good old-fashioned "This AppleID exists, but isn't set up for iCloud" kinda message. It has the latest Chemeleon on. 1) Tried PCIRoot = 0 2) tried PCIRoot=1 3) Tried the delete all interfaces in OSX, then delete the network preferences file, then reboot. 4) Tried 3 with a suggestion of adding a hardware ID flag from another internet post that just made it crash. 5) BuiltInEthernet flag set to Yes SMBIOS.plist says it's a mac pro 3,1, and it's been given a UUID. Tried again with another UUID/Serial courtesy of champlist. It's got a DSDT I made and edited for multiple things. Haven't found anyone else with a DSDT for this mobo online. :/ I don't think the DSDT says it has built in internet. Does this matter because of "5" above? Shall I try to edit it anyway? I guess I can follow this... http://www.insanelymac.com/forum/topic/140085-how-to-set-the-network-adapter-to-en0-through-dsdt-edit/page__st__20#entry1822013 What changes (if any) should I make to those instructions for my mobo (see signature), or should that just work as is? Any other suggestions? Other info I can remember: IOAHCIBlockStorageInjector.kext loaded. Possibly rolled back AppleIntelCPUPowerManagement. I'm typing this all from memory so apologies for any inaccuracies!
  4. C2D and P35 hack overview?

    I'm an old Hackintoshist who had Leopard running with a load of hacks/fiddles/kexts, and don't know which are working still since it's mostly been collecting dust. So I figured I'm due an update and to clean all the junk out of this setup (especially since I bought Lion for my macbook!). Since I'm a bit out of the loop though these days I had a few questions on the current state of things and the general system config. The wiki etc are kinda helpful, but still doesn't have an overview of the best current "hack architecture" as such. So what is the general system overview for a Vanilla Kernel on C2D processors? Even if a magic installer does it all for me I'd like to get an idea what it's done.... 1) AHCI in BIOS is obviously a given (based on the last stuff I did a few years back)? 2) MBR or GUID on the destination drive? (Think it was GUID for the last experiments I did a couple of years back) 3) Are the latest installers putting stuff in the hidden EFI partition still? Or does it look in the main boot partition? Does that hold the Extras folder too? 4) I think I saw somewhere I should set my BIOS to HPET enabled, and to 64 bit. What's this for? Never did that before! 6) Is it fair to say I just use the most popular editor from the DSDT forum section? I'm using a DFI Bloodiron (P35+ICH9R), so haven't seen much/anything done with it in terms of DSDT or any guides. I have a DSDT I patched here years ago but have no idea if it works properly because of the mess this machine's in. I also haven't seen a DSDT patch for ALC885 sound. How would I make one, or can I get away with another ALC patch? 7) So, what is the basic setup then for the most vanilla setup? Bootloader in EFI partition, with vanilla install, and some other system-specific kexts to sort audio etc? Are there any basic kexts that you MUST use regardless for all Hackintosh e.g. in "Extras" just to get it to boot, or can these all be overcome by the correct DSDT (obviously with respect to my hardware, rather than it's possible with stuff I don't have). Any other useful info, links, or suggestions, based on my hardware/chipset/etc? What won't work, and what is your suggested route. Thanks!
  5. Trying to install Lion via UniBeast

    Mine was a USB key called USB as per the instructions and I got the same. Mine's a DFI bloodiron mobo. No reply to my post on tonymacx86's forum yet either.
  6. Trying to install Lion via UniBeast

    Yep, same problem here. Had other complaints when I didn't try all those flags, but with them all (single user, verbose, safe, and GraphicsEnabler=No) I got the same waiting for root message...
  7. Hello! I'm stuck! I've been running leopard on this machine for a year or so, and I've tried updating to SL without much luck. It's my birthday tomorrow, so having Snow Leopard for my birthday would be nice! :mellow: My Hackintosh has "evolved" into its current working state! I started with an iAtkos install, but since then I have a DSDT patch here, and other fiddled kexts there, the sound now works, and it's running vanilla Kernel. I'm not exactly sure of everything I've done though as it's been in dribs and drabs! I'm trying to get to Snow Leopard but it's not happening very well. What kexts/boot.plist/DSDT file can I use from my current install? Are any compatible or do I need new boot.plist etc due to leopard drivers being 32bit and Snow 64bit? Do I need an SMBIOS or AppleHDA patch of a new file? I've been attempting this with a 16GB USB key, a retail DVD, and my DSDT file from the Leopard install. After the USB key boots with chameleon, after the options it then gives me a Kernel panic. Any tips on what thing causes this? Any quick reminders and pointers for a forgetful out-of-touch ex-n00b? Anyone got any files that would help for my stuff detailed below? What's the minimum things I need on my USB key/new partition? Can't find many posts on this mobo, although it should be similar-ish to a few of the popular ones out there. Other things to note: Every time it does this KP it resets all my BIOS settings to default. I have my leopard install on a separate drive so I can experiment as I like with it. I have a 2nd partition with a copy of my current basic Leopard install, so I can experiment with that to work out what's doing what, without breaking my important drive, in case this is only working from custom or disabled kexts that I'm not aware of. My leopard works fine, but I notice it's often noticeably slower at opening things up than a friends 2.53GHz macbook pro with leopard on. Is this to be expected due to the BIOS-EFI interpretation, or other good reasons, or is there something making this current install run a bit slow. What might it be? Thought this might help pinpoint any other issues I have going on... Once I can get it booting into Snow by itself from the HDD, I can then iron out any other problems myself (probably)! P.S. Thanks!
  8. I've recently installed chameleon RC2, and put mu DSDT.aml in my EFI partition. I want to put the kexts I need in there too, but first want to clear out old kexts that I don't need, some of which have been on here since the beginning and I'd rather get rid of what I don't need. Can anyone tell me what these do and whether to bin them, put them in EFI or re-enable them: AppleAC97Audio.kext AppleAC97AudioIntelICH.kext AppleACPIPlatform.kext AppleAHCIPort.kext AppleAPIC.kext AppleAzaliaAudio.kext AppleDecrypt.kext AppleEFIRuntime.kext AppleHWsensor.kext AppleIntelCPUPowerManagement.kext AppleNDRV (folder) AppleNForceATA.orig - this has been removed at some point ApplePS2Controller.kext - this has been removed at some point AppleSMBIOS.kext AppleSMBIOSEFI.kext AppleVIAATA.kext Disabler.kext HDAEnabler.kext IntelCPUPMDisabler.kext IO80211Family.kext IOPlatformPluginFamily.kext LegacyAppleAHCIPort.kext LegacyAppleIntelPIIXATA LegacyHDAController LegacyHDAPlatformDriver LegacyIOAHCIBlockStorage LegacyJMicronATA.kext Natit.kext - this has been removed at some point OpenHaltRestart.kext SiliconImage3132.kext Titan.kext.orig - folder - this has been removed at some point
  9. Installed RC1 on friday but not edited anything in extras or put my DSDT in (I made friday too). Gonna try RC2 tonight. Time for my n00b-ish questions... How to I mount my hidden FAT32 EFI partition? I only found instructions for HFS formatted ones!?! The MKext file needs ONLY the modded exts right, not all of them? Also (n00bish question of the lot), does Chameleon install on my main "Mac" drive partition, or is actually on another hidden partition on the same disk? I just chose to install RC1 on the "Mac" drive and it worked, but I'm tying to work out how it doesn't get overwritten if you format/install with a normal boot disk (or do you not format it after)!?! Or should I have created and installed to a separate Chameleon partition that I should point the BIOS to? Thanx!
  10. There's a MountEFI.kext about somewhere! Ran into that earlier after not being here for a long while and wondering if I can get sleep working finally (along with loading the new Chameleon 2 RC1, and DSDT patching). So I've never tried it myself, but I read about it in my last hours of post reading!
  11. I've got a BFG too. Nvflash --check says it's 64K. Is that what you got? Did you use the 2D3D.rom one posted here, with the BFG?
  12. How to find out if a PC has BIOS or EFI

    I've just been reading that Intel 945 boards have EFI support on them. I can't seem to find much out though. I read that most, although compatible theoretically, don't have firmware installed to support it though. How would you set the motherboard to EFI mode? In the BIOS? or would it just work automatically? Would this mean you could run Darwin without EFI emulation and the Vanilla Kernels with no problems?
  13. How do you add signature

    Ah-ha! Great! I was wondering this too! I'm capable of installing osx86 on my pc, but I'm too stupid to add a signature! lol
  14. iatkos upgrade to 10.5.3 fail

    I also used iATKOS 2.0i, and had everything working. I had sound too. I then used an update to 10.5.3 that Mysticus C* mentioned (via a trumpet!) posted somewhere on a forum to get to 10.5.3, assumed it worked completely, then used apple update to 10.5.4, and everything seemed ok. Then I opened iTunes, and found that same "iTunes is unable to browse album cover on this computer" message, and my sound was broken. Annoyingly I backed up all my 10.5.3 kexts over the top of my working 10.5.2 kexts, as I thought everything worked! Doh! I have an external firewire soundcard with proper apple driver so the sound doesn't bother me too much (although I'd like to fix it), but the no coverflow is annoying. I assume it's to do with graphics, as they're a nice 3D graphics thing. I heard a rumour that SSE3 is used for some graphics things though. I'm not too sure what graphics I had before in iATKOS 2.0i, but it worked. When I did the update to 10.5.3 I checked the NVinject 512MB option (I have a BFG 512 8800GT card). I have quartz graphics enabled via osx86tools utility, but have tried both enabled and disabled. Also since the updates it no longer shuts down or reboots and I need to use hold the power button, or press the reset button after the screen goes off. Any clues? BTW, when I used the update to 10.5.3 I mentioned I chose vanilla kernel. If the 10.5.4 changes kernel, then that was from apple, so will be vanilla too.
  15. iATKOS v2.0i

    I tried the Kalyway combo update to 10.5.3. I chose one of the Kernels. Rebooted. Shagged it! Then I reinstalled iAtkos 2.0, tried Kalyway update again. Didn't choose a Kernel. Shagged it! I then tried both the apple combo update to 10.5.4 and tried doing it the way Netkas said to update to 10.5.2/3 by deleting the AppleIntelPowerManagement.kext (I think it was) as soon as it appears, then editing the update script. Shagged it again! Doh! Back to 10.5.2 again for now...
×