Jump to content

geekingoff

Members
  • Content Count

    3
  • Joined

  • Last visited

About geekingoff

  • Rank
    InsanelyMac Protégé
  1. geekingoff

    Kernel Panic - AppleACPIPlatform

    The laptop is from 2005, so about 12 (probably near 13) years old. Actually, it came pre-installed with XP and it was surprisingly snappy. I actually just tried installing Leopard and it installed with no problems! It is surprisingly fast, but Leopard can even run on a 867MHz G4, so that's not too much of a surprise - I'm just not sure what is faster... A 1.2GHz Pentium M or an 867MHz G4. During the installation of Leopard, I noticed some kexts were available for it (I think patched AppleACPIPlatform + AppleAPIC). Of course they're for Leopard, but AppleACPIPlatform is the exact kext I had issues with, so just out of curiosity, I put them on the SL installer, and I'm seeing what happens right now. Thank you very much for the advice! I'm actually not going to be using this machine at all for everyday use, although it would be pretty awesome to do some basic stuff on it. I have many modern computers, including a triple boot (Windows 7 Ultimate, Ubuntu, and macOS Sierra) Hackintosh laptop with an i3-6100U, 128GB SSD, and 8GB RAM. I also have a 27" 2011 iMac, and a gaming PC that I plan on making a Hackintosh as well. Here's the reason why I want to do this: It's a 7" "laptop" that is really a UMPC (ultra-mobile personal computer). I got the idea that it would be super cool to run OS X on such a small machine. Here, I attached two pictures, one with a DVD on the keyboard to give you an idea of how small this now Hackintosh is. Thanks for the reply!
  2. geekingoff

    Kernel Panic - AppleACPIPlatform

    Yeah, I mistakenly put this in post-installation, when I meant to put it in the other one. I added it to the other one and intended on deleting the other, but didn't see the option. But this actually fits post-installation better. I know you guys don't support tonymacx86, but I don't believe I really mentioned anything to do with him/them. If you're just warning me, then I understand. And if you can elaborate more on the distros, I'd appreciate it. If you guys don't allow the discussion, then that is fine, but I've seen loads of posts involving them, so I didn't know. The reason I included it is because it got me the farthest, but in the end it gave me the same kernel panic (but at least it allowed me to install...) Thanks!
  3. Hello everyone, this is my first post here. I have a pretty old laptop that I'd like to get Snow Leopard running on. At first, I tried booting Nawcom's ModUSB with a retail DVD image, but I would always get kernel panic, no matter what I tried (I couldn't even get to the installer). So I decided to try a distro, after trying many different things with ModUSB. I decided to use Hazard's 10.6.1-10.6.2 SSE2/SSE3 Intel/AMD distro. I was shocked when it booted to the installer with no issues! I formatted the HD as Mac OS Extended (Journaled), GPT. I then installed Snow Leopard. After a while, the installation succeeded, and I was happy. It went ahead with the restart necessary for the installation, and... kernel panic. The same kernel panic I got before when trying ModUSB. I was really disappointed. I've tried many things: boot flags, such as: acpi=off arch=i386 GraphicsEnabler=No PCIRootUID=0 -f -s -x (and more, including verbose mode of course) booting the installer again after successful installation, and then going to System/Library/Extensions on the HD in terminal, then: "chmod 755 *.*" as well as "kextcache -a i386 -m *.*" reinstalling with no customize options selected apart from the boot loader (first installation, things such as the legacy kernel and specific kexts were specified) and probably some other things that I can't remember right now The thing is, if the installer can load with no issues, then Snow Leopard should work fine too, because they're theoretically (don't know for sure) using the same components (kernel, kexts, etc.). If I boot the installer in verbose mode, it gets right past the part where it kernel panics after installation just fine. This makes me think that something is configured differently after it is installed - something that the installer does not have - which is causing the kernel panic and preventing the boot. Here are the specs of the laptop I'm trying to install this on: Intel Pentium M 753 ULV @ 1.2GHz 1GB RAM 855GME Graphics/Chipset I know that this probably isn't the most compatible with SL, and I know the chipset/graphics are unsupported. However, I think I will be able to get it to work eventually, I just need some input on what might be going on. Looking at the kernel panic, it points toward AppleACPIPlatform.kext, but I don't know what's exactly wrong with it that is causing the kernel panic. Please take a look at the verbose mode image I have attached. I appreciate any and all help I receive!
×