Jump to content

hnak

Members
  • Content count

    323
  • Joined

  • Last visited

  • Days Won

    2

hnak last won the day on September 9 2012

hnak had the most liked content!

About hnak

  • Rank
    InsanelyMac Sage

Profile Information

  • Gender
    Male
  1. It exists as a PCI device, of course. Thanks to the Mieze patch, it now appears as an Ethernet card on 10.13.4.
  2. I updated to 10.13.4, the device is not recognized, and no related messages in system.log or dmesg.
  3. It stopped working in 10.13.4 beta 4. The device is not recognized, while the same PC works with 10.13.3.
  4. I purchased ASUS XG-C100C (0x1d6a/0xd107) and applied 10.3.3 update so that its device ID as modified to 0x1d6a/0x07b. and It works ... It is now recognized as Apple AQC107-AFW. I did not disable on-board NIC ( 0x8086/0 x15b7 ), did not change machine type to iMac18 either ( still using iMac17,1 ). As I do not have 10G switch, it is connected to a 1G switch and the connection is 100baseTX, I will switch default connection back to my on-board NIC. I also confirmed ASUS Windows drives does not work as the device ID has changed. EDIT: The reason of slow connection was a loose cable. I got 1G speed.
  5. hnak

    [pre-release] macOS High Sierra

    HD7950, which has been working without any patch/injection so far, ceased to work on this build.
  6. No, it does not appear in dmesg. The driver works anyway.
  7. I recently got Fujitsu P772/E ( used pc, released in 2012 ) and succeeded in macos sierra (10.12.4 beta) installation. Clover version is r4012. 0. HW spec. CPU: Core i5-3320M ( Ivy Bridge ) GPU: HD4000 Memeory: DDR3L-1600 SO-DIMM x 2 Ethernet: i82579V Sound: ALC269 ? 1. It must have dual-memory configuration, i.e. must have equally-sized 2 so-dimms, otherwise Clover fails in allocating memory. 2. As I installed EFI/HFS partitions by copying working image from another PC, I do not know how-to install macos from scratch. 3. Used kexts: FakeSMC (S/L/E), VoodooPS2Controller (/S/L/E), USBInjectAll (/L/E), ACPIBatteryManager (/L/E), AppleIntelE1000e(/L/E), VoodooHDA (/S/L/E), AppleHDADisabler (/S/L/E), Sinetek-rtsx (/L/E) ( the latest ones as of 2017-02-20 ) 4. DSDT patch - only 1 for KBC, which is necessary for VoodooPS2Controller to recognize. You do not need DSDT patch for the battery manager. from: Device (KBC) { Name (R101, 0x0303D041) Name (R106, 0x2003D041) Method (_HID, 0, NotSerialized) // _HID: Hardware ID { If (SIDF) { Return (R101) /* \_SB_.PCI0.LPCB.KBC_.R101 */ } Else { Return (R106) /* \_SB_.PCI0.LPCB.KBC_.R106 */ } } to: Device (KBC) { Name (_HID, EisaId ("PNP0303") /* IBM Enhanced Keyboard (101/102-key, PS/2 Mouse) */) // _HID: Hardware ID Name (_CID, EisaId ("PNP030B")) // _CID: Compatible ID Or, you can completely avoid editing DSDT by adding "PNP0303" to VoodooPS2Controller's Info.plist. 5. Graphics injection: As the vram allocation size is fixed to 64MB, I chose the following configuration and generated EDID for the LVDS using linux utilities. <key>Graphics</key> <dict> <key>Inject</key> <dict> <key>ATI</key> <false/> <key>Intel</key> <true/> <key>NVidia</key> <false/> </dict> <key>ig-platform-id</key> <string>0x01660003</string> <key>EDID</key> <dict> <key>Custom</key> <data> AP///////wAx2AAAAAAAAAUWAQNtIRR46l7ApFlKmCUgUFQAAACBAAEBAQEBAQEBAQEBAQEBKhwAulAgFDAYIEQATdAQAAAeAAAA/wBMaW51eCAjMAogICAgAAAA/QA7PTAyCAAKICAgICAgAAAA/AAxMjgweDgwMHg2MC4wCgAY </data> <key>Inject</key> <true/> </dict> </dict> 6. AsusAICPUPM = true. 7. Other than VGA, most devices should work, including USB3.0, touchpad, LCD brightness, SD card reader ( you might need edit IDs in Info.plist ). 8. I use MacBookAir5,1 as it seems the closest hardware. I also installed RT2870 USB wifi and re-branded bcm4322 pcie wifi card.
  8. My laptop has 10ec:5229 and the driver works by ID modification. System = 10.2.4 beta.
  9. hnak

    AppleIGB.kext

    I happens when promiscuous mode does not work correctly. You need to debug and fix the code.
  10. hnak

    R9 and R7 support in 10.10 (Finally)

    Sapphire R9 285's primary DP works. Secondary DP requires unplug-replug. HDMI/DVI do not work.No patch applied. - edit 2014/11/21 I found the problem is caused by ga-b75-d3v bios. After changing the mb, all ports work.
  11. The driver knows nothing about the way it is shutdown. It just expects disable/stop invocation at shutdown and start/enable at power-on. I have no information for driver writers other than ordinary published documents ... almost nothing.
  12. hnak

    GTX750 Dual Monitor?

    I connected 3 monitors to Gigabyte GTX 750 (dp, dvi, hdmi ) and all of them work on Yosemite. I use NVidia web driver, clover 2953 without injection.
  13. I have never had recognition problems with my motherboard. I have used various version of Clover ( 2953 now ) and set FixLAN_2000=true. The only things I do after Clover installation are setting kext-dev-mode=1 and copying boot/bootx64.efi as Suse/elilo.efi so that I can choose "SuSe" in setup, otherwise I cannot boot in UEFI mode. You should try booting without the kext and manually loading by kextutil. Before booting, removal of Library/Preferences/SystemConfiguration/NetworkInterfaces.plist is recommended.
×