Jump to content
InsanelyMac Forum

minimaltech

Members
  • Content count

    5
  • Joined

  • Last visited

About minimaltech

  • Rank
    InsanelyMac Protégé
  1. minimaltech

    AppleHDA patching in Mountain Lion

    It's been 4 days since I'm trying to make the OS X 10.8.3 running on my Lenovo B590 laptop. Managed so far: - Clover UEFI booting, using patched dsdt.aml. - Intel HD4000 working due to dsdt.aml patching. - Realtek [RTL81xx@0x2000:rtl8168_init_board] NIC identified as RTL8168E-VL/8111E-VL (mcfg=16) - a bit buggy but it's good enough. - VoodooPS2 and VoodooBattery for keyboard/touchpad and battery. All working fine. - Native speedsteping and sleep due to dsdt.aml patching. Though I find a bit weird the following WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3a -- power management may be incomplete or unsupported Well, all good so far, just untill I get to the ALC269VC Realtek sound board. I've been reading and trying the tutorials for patching but I came to no success, mainly due to the fact that I don't fully comprehend the terminology used... I'm a bit dumb, I know . SO: got myself codec_dump from linux mint 14 converted to dec got myself regedit keys from windows, converted them got around to parse the linux codec_dump so to get the verbs list (which is awfully weird) started patching and I managed in getting a kernel panic . For the moment, due to dsdt.aml, in system information: Intel High Definition Audio: Audio ID: 269 Speaker: Connection: Internal External Microphone / iPhone Headset: Connection: 1/8-Inch Jack using HDEF Device (HDEF) { Name (_ADR, 0x001B0000) Device (HDEF) { Method (_DSM, 4, NotSerialized) { Store (Package (0x06) { "hda-gfx", Buffer (0x0A) { "onboard-1" }, "layout-id", Buffer (0x04) { 0x1C, 0x00, 0x00, 0x00 }, "PinConfigurations", Buffer (Zero) {} }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } OperationRegion (HDAR, PCI_Config, 0x4C, 0x10) Field (HDAR, WordAcc, NoLock, Preserve) { DCKA, 1, Offset (0x01), DCKM, 1, , 6, DCKS, 1, Offset (0x08), , 15, PMES, 1 } Method (_PRW, 0, NotSerialized) { Return (GPRW (0x0D, 0x04)) } } Can anyone help me in getting the sound going? Attaching the original .kext, codec_dumps, verbs, dsdt.aml + dmesg export (a few weird things over there too). The annoying thing ---> in iAktos ML2 sound works with AppleHDA.kext. If I extract from the install DVD that kext and install it here, nothing works. I'm grateful for any ideas that pop up. I don't mind patching the damned thing myself, but I don't know where in the hell I screw up SPECS: Intel I5-3210M - 2,5GHz Intel HD4000 (VGA+HDMI) 4GB RAM ALC2629VC (Sound) (USB 3.0 not working) files.zip
×