Jump to content

AjTesh

Members
  • Content Count

    4
  • Joined

  • Last visited

About AjTesh

  • Rank
    InsanelyMac Protégé
  1. AjTesh

    Lenovo W540 Battery Invisible

    Did that. Same behaviour.
  2. AjTesh

    Lenovo W540 Battery Invisible

    I have that in /Library/Extensions. Please see the attached contents on /L/E and /S/L/E. I deleted all the kext files from the EFI/CLOVER/kext/Other after copying them to /L/E and FakeSMC to both /L/E and /S/L/E and ran Kext Utility. I don't have an option to disable discrete graphics on the BIOS. content_le.txt content_sle.txt
  3. AjTesh

    Lenovo W540 Battery Invisible

    Please find the attachment. EFI.zip
  4. AjTesh

    Lenovo W540 Battery Invisible

    Hi, I have also been trying to get my W540 to work with Sierra. I could enable the battery thanks to you. But I am still not able to get my display work with HD4600 properly. I was facing problem even during the installation as the screen would go blank before mac installation starts. Following RehabMan's suggestion I changed ig-platform-id to something invalid which led me to succesfully install Sierra. But with the invalid ig-platform-id I only see 7MB Video memory. If I use 0x0a260006 as ig-platform-id, the laptop screen goes blank. Did you face such issues ? Full details of my problems - https://www.tonymacx86.com/threads/lenovo-thinkpad-w540-sierra-installation.231567/page-2. I am using below config from RehabMans repository - https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD4600_4400_4200.plist
×