Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

  1. Photoshop CS4 OpenGL Performance

    Thank you so much. You saved my Photoshop CS4!
  2. Photoshop CS4 OpenGL Performance

    That would not be a solution. That would be surrender... If I have to buy a new card, I would first solve this problem and then buy a new one, after I'm satisfied.
  3. Photoshop CS4 OpenGL Performance

    I think we should try to find a kext other than Natit or EFI strings, to produce better QE performance. So far, no success. I've tried NVdarwin, NVkush, NVinject, but all of these kexts gave me no QE at all. Please keep us updated if you have any results.

    Meanwhile, I have totally changed my configuration, hardware and software. I don't use an Epson scanner (I switched to Canon), I am not using Tiger, as I used to (now I have Leopard) and I am not using CS2 (now I have CS4). I have even formatted the hard disk I had when I started this topic, so I cannot help georgeorange. Sorry!
  5. Thank you so much for this information. System Pref./Energy Saver/Put the hard disk to sleep didn't work (I had already tried before posting my problem) HDAPM works PERFECT! So you've solved my problem. Thank you again.
  6. Photoshop CS4 OpenGL Performance

    It's not that. I've tried the three options: 1) Only Natit.kext; 2) Only EFI Strings; 3) Both But nothing has changed. I saw on the Net that I'm not the only one having this problem with Photoshop CS4. The others have "solved" it by just disabling OpenGL drawing, but there must be another way to solve this issue! Other ideas?
  7. Hey guys. Have you noticed about Photoshop CS4 having performance issues with 256 Mb NVidia GPU? The images don't refresh properly, they get black, they return normal after clicking out of their frame, they become difficult to work with, unless you deselect "use OpenGL", from the Preferences of Photoshop CS4. Well, my MacBook Pro has also 256 Mb of GPU, but it works perfect. This means that the issue I'm having with my desktop PC may depend on NATIT.kext, or on the EFI strings I inserted in com.apple.boot.plist. Does anybody know how to solve this? Thank you! (PS: you can see my specs from my signature).
  8. hey, slashack, you didn't reply to my question here. Does it mean you don't know a solution to this problem?
  9. In my case, the solution was substituting my "new" leopard JMicronATA with the "old" one, modded from Tiger. I have a problem, though (this is for you, slashack): after awhile I have stopped using a drive, it "goes to sleep", i.e. I cannot wake it up, it even freezes the programs which try to open it and eventually even the finder. Is there a way to solve this problem? I remember in the case of Tiger, in "SystemPreferences/Energy" there was something to choose not to make the CD drives go to sleep, but in Leopard there is nothing similar. Any idea?!?
  10. VERY useful indeed! I was sick of typing everything each time.. I have re-written the last line of umount to erase Volumes/EFI. Why did you write it could be dangerous to do that?
  11. In my case, it works perfect. You might have some problems with your Internet provider or your configuration.
  12. OK, I will tell you my experience. I was able to use the dsdt properly. The first version of it I produced was inappropriate for my system. In order to get it working properly, I had to drag the patcher in the Terminal and type "-newHPET". So I had to use a different way to patch HPET, otherwise, without IntelCPUPMDisabler my system would not boot. I have eliminated IntelCPUPMDisabler from the list of my efi kexts. The present ones are: JMicronATA LegacyAppleIntelPIIXATA LegacyIOAHCIBlockStorage LegacyAppleAHCIPort LegacyHDAController LegacyHDAPlatformDriver HDAEnabler OpenHaltRestart AppleDecrypt SMBIOSResolver Do you guys think there is something else I could take off? (dsdt patcher left 3 text files called rtc_fixed, dsdt_fixed and hpet_fixed) Thank you
  13. I am also totally new about DSDT. I've been out for awhile and I don't know much about it. So far I've downloaded the last version of the patcher, I double clicked and I got my dsdt.aml. I have the nice feeling that by using dsdt I can avoid loading IntelCPUPMDisabler. What about the other kexts? At the moment, I am using: JMicronATA (as a driver for IDE DVD burners --for 3Gb and more of RAM) LegacyAppleIntelPIIXATA (for ICH10 chipset) LegacyIOAHCIBlockStorage (not to see SATA HDDs as network drives) LegacyAppleAHCIPort (not to see SATA HDDs as network drives) LegacyHDAController (for audio) LegacyHDAPlatformDriver (for audio) HDAEnabler (for audio) IntelCPUPMDisabler (nonHPET) OpenHaltRestart (restart problems) AppleDecrypt SMBIOSResolver Please let me know, my friends.
  14. Hey Slashack, I have solved my problem! THANK YOU. Apparently, it was not working because I was making a terribly stupid mistake. I was loading JMicron in a wrong way. At the moment, I am loading your version from the EFI partition. I have modified the strings, in order to load only the IOPCIPrimaryMatch I need (0x2368197b). The others were creating conflicts. I noticed the bin file is different from the one of Leopard. Is it from Tiger? Is there a way to use the bin from Leopard, so that I can load only the plist file from the EFI partition? Please let me know.