Jump to content

Chibi Delenn

Members
  • Content count

    8
  • Joined

  • Last visited

About Chibi Delenn

  • Rank
    InsanelyMac Protégé
  1. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    Already gave it a try. No good. OpenCL still crashes.
  2. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    NVIDIA GeForce GTX 780: Chipset Model: NVIDIA GeForce GTX 780 Type: GPU Bus: PCIe Slot: J6B1 PCIe Lane Width: x16 VRAM (Total): 3072 MB Vendor: NVIDIA (0x10de) Device ID: 0x1004 Revision ID: 0x00a1 ROM Revision: preset 1.0.0 Displays: L2410NM: Resolution: 1600 x 1000 @ 60 Hz Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Rotation: Supported Television: Yes
  3. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    OK, I have the ROM zipped for you. My stepping says A1, so it doesn't look to be a GK110B unless you know otherwise. Edit: This says my board is based on the B1 stepping, but GPU-Z disagrees. Yay? GK110.zip
  4. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    I'm assuming I'll need to run GPU-Z in Windows to get a proper dump of the ROM. I have Windows 7 Pro 64-bit installed, so I can use that if I have to. I'll go ahead and do that and see if it lets me attach the ROM here. You may be right and if so, then these cards are just "too new" for ML/Mavericks and we'll need to wait for the nVidia Web drivers. I'll post back here when I have the requested info. In the meantime could you link the GTX 780 thread you just referenced so I can bookmark it?
  5. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    I've tried Clover and Chameleon both to no avail. I've always used the GraphicsEnabler=No option specifically because nVidia cards are supposed to be supported out of the box. Mine works for everything but OpenCL. I'm really beginning to think it's because this card is too new. I have a feeling the 780 Ti being released by EVGA will suffer the same. Unfortunately 10.9.1/10.9.2 seeds are being released internally only so paid ADC members like myself cannot access them to see if newer drivers resolve this. The reason I am thinking my card is too new is that not one version (any) of HWSensors/HWMonitor lets me see the GPU Fan or GPU Temp diodes even though GPUSensors is loaded. The card just doesn't appear to be supported yet due to being too new and too few people use it. This is frustrating beyond belief that I might have to downgrade my card (in addition to eating any restocking fees) because one of the most powerful versions is just "too new".
  6. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    The driver version is exactly what you posted. Even booting from a Clover install on my USB drive causes this. My system profile is that of a Mac Pro 3,1. But even an iMac 14,2 has the same problem (and has issues of its own). Everything works except OpenCL. Any app that calls OpenCL crashes instantly the moment it does so. Preview.app, Pacifist, Cornerstone SVN, and LuxMark are among those apps. Preview crashes when attempting to view graphics files. Even QuickLook instantly crashes on graphics files. I'm still trying to find out why this happens. It occurs both in 10.8.5 (including supplemental update 1.0) and in Mavericks. Only OpenCL causes the crashes. Other GTX 780 cards seem to work, but those are all cards released before the one I have. Now I didn't expect 10.8.5 to have real OpenCL support, but the crashes are a real problem.
  7. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    Unfortunately even a vanilla install with only FakeSMC.kext and HWSensors installed results in OpenCL crashing immediately on any app that uses it. Boot to safe mode and OpenCL based apps don't crash anymore. And since the only driver that is disabled in Safe Mode for the nVidia GPUs is GeForce.kext, that puts the onus squarely on Apple's driver. Unfortunately without that driver loaded I get no acceleration either and the entire UI is choppy to say the least. Mavericks' drivers are older than ML 10.8.5's stock drivers. Why the DP versions of Mavericks had awesome drivers and the release got drivers that are a year old is what's making me scratch my head.
  8. OpenCL fix for non-GF100/GF110 cards (aka CC/SM 2.1+)

    Yewwo I'm stuck in the same boat as many others here - I have an EVGA GTX 780 w/ ACX Cooler and the fixes here aren't working in the retail 10.9 drivers. It seems that the 10.9 drivers are a regression and are actually older than the stock 10.8.5 drivers, yet somehow modified with GK110 code. The DP versions of Mavericks seem to have worked for people here, but the release version has regressions and none of the fixes here work. Has anybody gotten 780 cards working in Mavericks w/ OpenCL? There is a lot more that uses OpenCL now, especially Preview when viewing anything other than text/pdf, and having the apps just crash outright because of OpenCL (or Apple's pathetic implementation of it) is a total productivity killer. Any help would be greatly appreciated.
×