Jump to content

DSM2

Members
  • Content Count

    81
  • Joined

  • Last visited

Everything posted by DSM2

  1. DSM2

    AMD Radeon Vii in macOS Mojave

    Well what do you think Vega64X is??? Of course its a VII just clocked down or where do you see a faster Vega 64? Just name is different it doesnt mean that its not the VII.
  2. DSM2

    AMD Radeon Vii in macOS Mojave

    Strange... Still using Legacy install on this build ?
  3. DSM2

    AMD Radeon Vii in macOS Mojave

    Like I already explained to you in the German Community. Just because you set output to PEG the onboard Chip is not disabled at all!!! Yes my card runs UEFI BIOS but it doesnt matter since exactly same behaviour is happening in legacy mode.
  4. DSM2

    AMD Radeon Vii in macOS Mojave

    You still forget that your CPU has an iGPU and just because you didnt configure it by yourself it doesnt mean its not initialized by WEG. How ever... Its 6 o' clock in the morning here in Germany. Bed time!
  5. DSM2

    AMD Radeon Vii in macOS Mojave

    The black screen is not related to weg or an SSDT or anything else... Trust me If I say that.... I did alot of testing...
  6. DSM2

    AMD Radeon Vii in macOS Mojave

    You should read again I didnt state that the card works only If you have an IGPU. If you edit the 5000.kext you need an helper Card. Otherwise it will Not Work until Apple release the final Driver
  7. DSM2

    AMD Radeon Vii in macOS Mojave

    Time to make things clear... As already mentioned by me in the German community @trueadm posted in the thread of @KGP-iMacPro that the VII only runs when the IGPU is on in the bios. The whole thing didn't leave me any peace today and I wanted to know it exactly, so I set up a small test setup. Since I was missing a CPU cooler, I had to improvise a little, as you can easily see. Don't worry all parts live and CPU was kept constant at 53/54 degrees What turned out now ? Yes, the card has acceleration when you edit the kext but ONLY!! : if... a) the IGPU is active or b) basically there is a helper card in it If both are not available then the behavior already determined by @KGP-iMacPro or myself mentioned from day one.
  8. DSM2

    AMD Radeon Vii in macOS Mojave

    Because your Config is faulty.
  9. DSM2

    AMD Radeon Vii in macOS Mojave

    @Gigamaxx : Guess what I am using! ;-)
  10. DSM2

    AMD Radeon Vii in macOS Mojave

    @sl0wtarget : My card had uefi support even before amd released the patch... So not related to me or my card... @Gigamaxx Strange... Just have a black screen if I try to boot with any modded amd5000 kext or try to spoof the IDs with other methods.
  11. DSM2

    AMD Radeon Vii in macOS Mojave

    Still strange why it doesnt work UEFI Mode....
  12. DSM2

    GetmacOS

    Download of older OS is not possible...Keeps telling me that macOS Sierra is not available
  13. Thanks! Will test it asap! The kext has to be in L/E but I will also try via Kext Injection. Unfortunatly doesn't fix my issue... hmm... This is my problem: 2019-02-03 00:33:29.252097+0100 0x38d0 Default 0x0 0 0 kernel: (VRS8AudioDriver) AEsiAudioEngine[]::CreateAudioStream() failed to allocate IOBufferMemoryDescriptor 2019-02-03 00:33:29.252099+0100 0x38d0 Default 0x0 0 0 kernel: (VRS8AudioDriver) AEsiAudioEngineIn[]::initHardware(), failed to create all streams. 2019-02-03 00:33:29.252100+0100 0x38d0 Default 0x0 0 0 kernel: (VRS8AudioDriver) AEsiAudioEngineIn: failed to create analogInputStream! 2019-02-03 00:33:29.252103+0100 0x38d0 Default 0x0 0 0 kernel: (IOAudioFamily) - IOAudioEngine[<private>]::start(<private>, <private>) 2019-02-03 00:33:29.252104+0100 0x38d0 Default 0x0 0 0 kernel: (IOAudioFamily) - IOAudioEngine[<private>]::start(<private>) returns 0 2019-02-03 00:33:29.252108+0100 0x38d0 Default 0x0 0 0 kernel: (IOAudioFamily) - IOAudioDevice[<private>]::activateAudioEngine(<private>, 1) returns 0x<private> 2019-02-03 00:33:29.252109+0100 0x38d0 Default 0x0 0 0 kernel: (IOAudioFamily) + IOAudioEngine[<private>]::free() 2019-02-03 00:33:29.252124+0100 0x38d0 Default 0x0 0 0 kernel: (IOAudioFamily) - IOAudioEngine[<private>]::free() 2019-02-03 00:33:29.252124+0100 0x38d0 Default 0x0 0 0 kernel: (VRS8AudioDriver) AEsiAudioDevice[<private>]::initHardware: failed! 2019-02-03 00:33:29.256646+0100 0x38d0 Default 0x0 0 0 kernel: (IOAudioFamily) - IOAudioDevice[<private>]::start(<private>) Maybe you have an idea what I could try...
  14. Good Evening @PMheart Unfortunately I can't find any information about an issue I have so I though I should ask you here. I wanna add a driver to LiluFriend but I don't understand how it should look like in the end. Could you maybe help me in creating it ? I attached the info.plist of the driver which I wanna insert to LiluFriend. How the final LiluFriend kext would look like with this data ? Info.plist
  15. DSM2

    Decompiled original Apple DSDTs

    Anyone here around with an MacBookPro15,3 Vega 16 or 20 ? If so a full darwin dump would be awesome!
  16. @BalamutSure, why they shouldnt? Was it succesfull with your X550-AT2 ? Which enps values did you use in the end?
  17. @KGP-iMacProThere are two entries and have to be patched both... otherwise it will not work! Like I see he use aswell an WS X299 Sage/10G so it can't be different then on my build Besides from the enp of course...
  18. @Balamut sudo ethtool -E enp225s0f0 magic 0x15638086 offset 0x242 value 0x0a sudo ethtool -E enp225s0f0 magic 0x15638086 offset 0x243 value 0x00 sudo ethtool -E enp225s0f1 magic 0x15638086 offset 0x242 value 0x0a sudo ethtool -E enp225s0f1 magic 0x15638086 offset 0x243 value 0x00 but check if your enp is correct. This example is from my WS X299 Sage/10G and this way it works on my build without any problems.
  19. DSM2

    [pre-release] macOS Mojave 10.14.1

    Copy the related kext for your gpu to to extension folder and repair the rights...
  20. DSM2

    [pre-release] macOS Mojave

    Anyone out there who got the trackpad fixed on t480 under Mojave ? No tap settings etc...
  21. Maybe you get just a bad one... mine works perfect, no issues at all
  22. DSM2

    Intel UHD 620 QE/CI problems..

    try following EFI EFI.zip
  23. DSM2

    Intel UHD 620 QE/CI problems..

    Will tell you as soon as the "problem device" arrives today and I will get my hands on at night...
  24. DSM2

    Intel UHD 620 QE/CI problems..

    Ok, really interesting...
×