Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×

JHeartyP

Members
  • Content Count

    16
  • Joined

  • Last visited

Everything posted by JHeartyP

  1. JHeartyP

    WhatEverGreen Support Topic

    Hi! I have a lenovo kaby lake laptop. Framebuffer set to 32mb in bios and can't be set higher. Bios is locked and rewrite protected. Framebuffer memory is also set to 32mb with whatevergreen. Does minstolensize patch still work since that was the (only) way to enable 4k30 output before whatevergreen or is there an alternative way to enable 4k output? -cdfon boot flag doesn't do anything and graphics memory is already set to 2048mb.
  2. JHeartyP

    Intel Framebuffer patching using WhateverGreen

    <key>framebuffer-patch0-enable</key> <data>AQAAAA==</data> <key>framebuffer-patch0-find</key> <data>Bf9IRnY=</data> <key>framebuffer-patch0-replace</key> <data>Bf9IRus=</data> I'm having the same problem as you. My laptop has a KBL HD 620 and an eDP connector and no matter what I try I can't get the internal display working with the kaby lake framebuffer driver. Only brightness works and turning off cnconnectoralwaysenabled doesn't help in any way. What if I fake coffee lake ig-platform-id and fakeid intelgfx? Which id's to use?
  3. JHeartyP

    WhatEverGreen Support Topic

    Is there a solution to get the internal display working with a kaby lake HD 620 and an eDP connector on mojave? Currently only backlight works. i found a workaround is to use SKL intelgfx and ig-platform-id but that's only a workaround because i get rare glitches that i don't have with KBL framebuffer. I tried turning off CNConnectorAlwaysConnected but then the screen was all black, not even brightness works.
  4. Hi! Can somebody help me patch the framebuffer data to make my internal display work? I suppose I need to patch this string in appleintelkblgraphicsframebuffer (not 100% sure what I'm doing tho): 00000800 02000000 98000000 01050900 00040000 87010000 02040A00 00080000 87010000 FF000000 01000000 20000000. At the moment HDMI is working. It has the same resolution and refresh rate as my internal display. Internal display brightness can also be controlled but the screen is black. Both displays are shown in about this Mac > Displays. Ioreg: https://drive.google.com/open?id=1mQ1HckXUSwy2r925prJkh0ZnSLpHv186 [email protected] 0x02000000, port number 0x00 [email protected] 0x00040000, port number 0x05 [email protected] 0x00080000, port number 0x06 Internal display works just fine with fakepciid and skylake ids. Only difference I've found comparing the ioregs with fakepciid and native is in iofbtimeranges in [email protected] Skl fakepciid: <00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 2d 31 01 00 00 00 00 80 74 d2 1a 00 00 00 00 00 00 00 00 0f 00 00 00 0f 00 00 00 08 00 00 00 00 00 00 00 ff ff ff ff 00 00 00 00 ff ff ff ff ff 1f 00 00 ff 1f 00 00 00 00 00 00 00 00 00 00 01 01 01 01 01 01 01 01 01 01 01 01 01 01 00 00 00 00 00 00 00 20 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 00 0c 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00> KBL native <00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 2d 31 01 00 00 00 00 80 74 d2 1a 00 00 00 00 00 00 00 00 0f 00 00 00 0f 00 00 00 08 00 00 00 00 00 00 00 ff ff ff ff 00 00 00 00 ff ff ff ff ff 1f 00 00 ff 1f 00 00 00 00 00 00 00 00 00 00 01 01 01 01 01 01 01 01 01 01 01 01 01 01 00 00 00 00 00 00 00 20 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 00 0c 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 ff 1f 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0f 00 0e 00 87 01 0b 00 00 00 00 00>
  5. JHeartyP

    [pre-release] macOS Mojave

    QE/CI enabled, HDMI output works, notebook internal display is detected but blank? Brightness works. Injected EDID after loading the frame buffer internal screen is still black debug_13830.zip
  6. JHeartyP

    [pre-release] macOS Mojave

    Hi! Would anyone look at my troubleshooting files? I'm using minstolensize patch for kbl frame buffer and I'm booting to a black screen... I'm using a very similar clover config to what I used with high Sierra. On high Sierra I had literally 0 problems. I will see if hdmi output works. debug_25877.zip
  7. JHeartyP

    [pre-release] macOS Mojave

    Yep. Quick preview is working fine here on my hack as well. Keychain access is laggy however. Choosing Safari -> Preferences > Passwords completely freezes safari for a while. Authentication windows also sometimes freeze for 10 seconds or so.
  8. JHeartyP

    [pre-release] macOS Mojave

    So I tried 4 different kbl ig-platform-ids and 7 different kbl fakegpuid's and still didn't get past that problem. I think it successfully booted but failed to load the frame buffer. Anyway, it's still a beta. I managed to get acceleration working with my kbl HD 620 using fakepciid and fakepciid intel hd graphics kexts with skl fakeid/intelgfx 0x19168086 and ig-platform-id of 0x19160000. Would somebody with a KBL notebook and an hd 620 be nice enough to tell me what ig-platform-id and fakeid/intelgfx they used? Anyway I'm happy so far. Everything seems to be working just fine, including audio (haven't tried hdmi yet).
  9. JHeartyP

    [pre-release] macOS Mojave

    I do have RTL8111 working. I'm using this kext. RealtekRTL8111.kext.zip
  10. JHeartyP

    [pre-release] macOS Mojave

    Tried different FakeID's for gpu. Still end up on a black screen. In kexts/other I have applealc, appleps2smarttouchpad, fakesmc, lilu, usbinjectall, voodootscsync. Boots normally with an invalid gpu ig-platform-id. config.plist
  11. JHeartyP

    [pre-release] macOS Mojave

    My Kaby Lake (Intel HD 620) system boots to a black screen with minstolensizepatch enabled. The screen blinks and goes black. Boots normally with a fake gpu id however. :/
  12. JHeartyP

    AppleALC — dynamic AppleHDA patching

    Internal MIC is not working. I need assistance! AppleALC 1.2.2 on Lenovo v510-15ikb. ALC236, injected layout id 11 through config.plist. Vendor Id: 0x10ec0236 Subsystem Id: 0x17aa3893 Revision Id: 0x100002 CodecDump.zip CLOVER.zip ioreg.zip
  13. JHeartyP

    [pre-release] macOS High Sierra

    Hi! What is the correct ig-platform-id for Intel HD 620? HDMI isn't working with 0x591b0000 that I'm using right now. I don't know if I'm using the correct id...
  14. JHeartyP

    [pre-release] macOS High Sierra

    Clover 4097. High Sierra dp2 install for uefi booting only install clover in the esp themes - bgm drivers64uefi - emuvariableuefi-64 drivers64uefi - osxaptiofixdrv-64 then placed apfs.efi and hfsplus.efi into drivers64uefi make sure you chose the correct install location for clover also you need to place all the essential kexts into clover/kexts/other folder (fakesmc, etc).
  15. JHeartyP

    [pre-release] macOS High Sierra

    I successfully installed High Sierra onto my Kaby Lake Lenovo v510, however I'm struggling with graphics - what is the proper ig-platform-id I should be using to load the kaby lake graphics drivers? I completed the installation with a bogus ig-platform-id since I wasn't sure which one to use and it would kp otherwise. i5-7200u, Intel HD 620. my first guess would be 0x59160000, is this correct?
×