Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


  • Content count

  • Joined

  • Last visited

About Sangx

  • Rank
    InsanelyMac Protégé
  1. Marvell Yukon Drivers

    I was reading the guide to port Linux drivers to Mac if the source code is available. I came across these drivers released by Marvell for Linux (2.6 Kernel). Can this be ported and made into a generic Marvell Yukon Kext (something like a Voodoo Project?) MarvellYukon_generic_linux.zip
  2. Hi, I made a custom boot cd (with preboot.dmg) using BootCDMaker, which boots fine and launches my Lion partition absolutely fine. But it also shows me the list of all available partitions which I don't want. I tried the following to hide the partitions, but there was no effect (Lion is installed on disk0s6) 1) <key>Kernel Flag</key> <string>rd=disks06</string> (tried with boot-uuid=xxxxxxxxxxxxxx, no result) 2) <key>Instant Menu</key> <string>Yes</string> <key>Hide Partition</key> <string>hd(0,1) hd(0,3) hd(0,5)</string> (tried with labels as well, no result) and <string>hd(1,1) hd(1,3) hd(1,5)</string> 3) <key>Instant Menu</key> <string>No</string> This option show me "Boot CD" only until I press F8 When I press TAB at bootscreen here is what I get hd(32,0) Boot CD hd(0,1) hd(0,2) System Reserved hd(0,3) Windows 7 hd(0,5) Windows NTFS hd(0,6) Lion I read somewhere that the device from where chameleon boots up is device0 and the hard disk would be device1. Also, how do iAtkos or EasyBCD autoselect the Mac partition? Please help!
  3. @MacNB I didn't try that before. I forgot that I had forced EDID in SL as well ... Forced EDID in Lion and now EVERYTHING works. It is as flawless as a Macbook Pro now! Thank you.
  4. Nope, I have not found a fix yet. Tried several framebuffers that claim to make internal screen work, tried patching the personalities etc. I am still stuck.
  5. I managed to install Lion on my Sony Vaio which has a ATI Radeon 5470 mobility. Installation was possible only via HDMI cable being attached to an external screen. Almost everything seems to work, but the main problem is that the internal display won't work (goes black). I read countless threads on various places and saw that only "desktop" versions are supported as the port for the internal screen on laptops differs from that on macbooks. I also came across a post about editing personalities in framebuffer to make the screen work, although I am not sure if that would be possible in Lion. So is there a way to make the internal screen work? (maybe a patched framebuffer?) Thanks!
  6. I too had this error ... Solution - Replace OSInstall.mpkg in System/Install/Packages with this one (courtesy : MaLd0n) I have a wierd problem. I managed to install 10.7 on my Sony Vaio with almost everything working (except LAN Marvel Yukon 88E8059) but there are few problems : 1) Atheros card is unstable in connection (using the same kext that worked in SL) 2) Internal display won't work, but I can see full QE/CI for my ATI Radeon 5470m (512MB) on an LCD connected via HDMI (with translucent bar, etc etc) I have added ATIConfig=Hoolock and GraphicsEnabler=Yes in com.apple.boot.plist. Any help appreciated.
  7. Yes you are right, I connected my laptop's HDMI port to a LCD and I could see the installer.
  8. I followed this guide exactly. In the end, when the "Boot" partition loads, there is a wait at [PCI Configuration Begin] and then the screen goes blank (no kernel panic). Any idea why this happens?
  9. [100% Working] ATI Mobility Radeon HD 5470

    Yeah maybe because of 10.6.8 SL. Will 512MB be bug free on Lion as well, or just the 1Gb version? I am waiting to purchase the disk as soon as it releases.
  10. [100% Working] ATI Mobility Radeon HD 5470

    jamesst20, I am speechless, overjoyed and full of respect! THANK YOU so very much. It works on my Sony VAIO with ATI 5470m 512MB Graphics Card. Tested and confirmed. Front Row works, translucent menu bar, proper detection of graphics card in system profiler and full acceleration for games. Mods, sticky this? EDIT : One more addition, there is a small bug. Sometimes the transparency is replaced by white opaque color, especially in the dashboard's ripple effect. Is it because I am using 889 trunk of chameleon? Well after using it for a day, I can say it is still buggy. At least for 512MB ATI Radeon Mobility. But hey, at least a step closer to perfection!
  11. ATI Native drivers

    The links in the first post are not working, is it just me who can't download? Sangx.
  12. Sony Vaio VPCEA46FG

    Hi all Sorry for a late reply. I assume all the kexts have been shared except trackpad. I have used the same kexts that tonymacx86 has used in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. I will upload them as soon as I reach home. No other kexts works for multi touch on vaio afaik. For sound, I am using ALC272 kexts from kexts.com (if you have Intel high definition audio, this most probably will work). I still am on VGA mode, and Hakoudbato, I would appreciate if you can help me fix the graphics problem. About battery indicator, I don't have it as it is not really important factor for me (the laptop light blinks when it is 15% left .. hehe) EDIT : Your battery kext works fine! Thank you. Have you noticed that VAIO runs at about 57-60 degrees on snow leopard whereas it is 45-50 for Windows 7? I have tried almost everything, but this temperature does not come down and the fan makes audible noise as well.
  13. Sony Vaio VPCEA46FG

    I was able to get it working with chameleon RC5 (with some minor modifications). It works in VESA mode as of now. There is a strange problem that I face. The Realtek Chip that this notebook has is ALC269. The device is detected when booted from [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url](shows controls in Settings) but there is no sound. When I boot from Chameleon, the device is not detected! I have tried modified AppleHDA for ALC269, VoodooHDA and almost all other combinations of these two. Any pointers? EDIT : The realtek sound chip was ALC272 (phew..). Tried various kexts for all realtek chips and finally this one worked from another kext repository website. So ALL is working now USB - 100 % (USB 2.0) Sound - 100% (Speakers,Headphone,Mic) Wireless - 100% Graphics - 50%? (no QE/CI , but proper resolution. ATI 5470 Kext/rom waiting..) Trackpad - 100% (with multi touch gestures) Ethernet - Waiting for 88E8059 Yukon kext. At the end the fan speed is more than that on Windows 7 installation. Looking for the "proper" kext to fix it. Cheers.
  14. Sony Vaio VPCEA46FG

    I also think that the problem is in the video. But do you think it has something to do with the motherboard? I am using retail installation on my hard disk. Also, no version of chameleon(RC4, Aserebln,RC5 or Kabyl) can boot up my install even while using GraphicsEnabler=no, it's just [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] that can boot it up. Although I got 1366x768 resolution by the good old kernel flag "Graphics Mode"="1366x768x32".I have to type that each and every time I boot up, as [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] is using a Preboot.dmg. Any idea how to add this kernel flag to [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] image, as I cannot boot from chameleon even when I compiled a custom Preboot.dmg for RC5(or added it to boot.plist on hard disk). Spent like more than 12 hours (continously) on this yesterday. I will still look out for something once I get back home from work. Thank you so much MaLd0n for your help, I got to learn something new from you PS : The notebook that I am using closely resembles a Macbook white in looks (and that's why I purchased it) and if Snow leopard works fine on it, it is a very good cheap alternative to Macbook.
  15. Sony Vaio VPCEA46FG

    I did all that you mentioned. When I use chameleon, it boots up but then after starting darwin the screen goes blank. I tried using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] CD, and the OS booted just fine. But in this way DSDT is not loaded, neither is any modification done from above is useful, right? PS : I have formatted my entire hard drive, no windows installation exists So I am still waiting for this to work. Sangx.