Jump to content
InsanelyMac Forum

Dradis

Members
  • Content count

    66
  • Joined

  • Last visited

About Dradis

  • Rank
    InsanelyMac Protégé
  1. Iris 540 in new MacBook Pro. Will 530 work?

    haven't tried anything yet, just planning for a new build. I've already got a motherboard and will have a CPU soon. Just hoping that some proper drivers will be available before i get it built.
  2. Iris 540 in new MacBook Pro. Will 530 work?

    just noticed that the new 15" models have Intel HD 530 along with the AMD GPU. I'm hopeful that this will mean full support for desktop 530's once those models are available.
  3. Sorry to beat a dead horse, but i can't find this exact question asked. I know support for Intel HD 530 graphics is currently limited (flickering, no wake from sleep), but I noticed that the new macbook pros with touch bar that just came out a few days ago use Intel Iris 540. I realize that Iris 540 is a higher performance GPU than the HD 530, but it is in the same family. As far as i know this is the first Apple product to use any sky lake graphics. Any chance a simple mod of the Iris drivers will make the HD 530 fully functional?
  4. BIOS to UEFI Pros and Cons

    I would also like to know about creating the EFI VBIOS. There doesnt seem to be one available for my ATI HD5750. Any help would be appreciated.
  5. HD 5450 on Mavericks

    Just had a similar problem with my 5750, hope my solution also works for you. First make absolutely sure that you have the correct device ID (sorry if that goes w/o saying). Putting it in ATI5000Controller.kext should give you full resolution support. Putting it in AMDRadeonX3000.kext should give you QE/CI support. In AMDRadeonX3000 there are sections for various graphics card families or code names. Be sure to put you DevID in the correct section. Your card should go in the AMDCedarGraphicsAccelerator section. (I do not have this card, so I cannot verify that it is Cedar). Also, I don't think your card is a natively supported card, so you may need GraphicsEnabler=Yes. Try both Yes and No. I hope there's something here that you haven't tried yet. Good luck.
  6. Asus P8P67-m Pro DP4 guide

    No, I still have no sleep on this machine. I believe this will require a sleepenabler.kext for 10.8 or someone with dsdt knowledge far greater than my own. Yes, the i5 ssdt should work for any stock sandy bridge i5, including the 2500. If you are overclocked use the ssdt for overclocked i5/i7. It is prepatched for speeds up to 4.0ghz. If needed it could be modified further for faster speeds. I'm not exactly sure how to do that, but there's plenty of info here and on other sites.
  7. I've already extracted THE dsdt for this board and my others as well. I just like the patched BIOS of my other two because it takes away the need for a few of the kexts and dsdt patches. Makes me feel a little closer to "real" with my macs. Also seem to have fewer problems that way. Funny thing is, after i installed Lion I tried to boot straight in without any modifications or added kexts. Obviously I had a boot loader on another drive. It worked. There was no fakeSMC, no nullcpupowermanagement, no dsdt. I didn't think that was possible. Anyone able to explain?
  8. Sorry if this isn't the right place to post this, but i didnt really see a better place. Does anyone know where I can find a patched BIOS for the Gigabyte GA-G41M-ES2H? I'm using patched BIOSes on my Gigabyte GA-EP43-UD3L and Asus P8P67-m Pro. Both have served me well and I would like to find a patched BIOS for this one too. I've found one for the ES2L made my cartri, but not the ES2H. Cartri has taken down forum, so finding help there has become hard. Please help if you can. Thanks.
  9. AMD Radeon problems DP4

    Have you fixed this problem? I installed my 5750 with no problems once the DevIDs were added, but I just installed a 5450 in another machine and i'm having the same problem. System profiler shows this card as a Radeon 5000 and I seem to have QE/CI working, but I am stuck at 800x600 resolution. Clicking on "scaled" in the display options causes a crash before seeing a list of available resolutions. I mean, those 800x600 pixels each look very nice, but i need a few more of 'em. UPDATE: I found a workaround, but not a solution. I booted the computer with this monitor (a 32" LCD TV) connected to HDMI instead of VGA. Now all resolutions are available. I then plugged in the VGA and unplugged the HDMI. All resolutions are still available. After rebooting the resolution was back to 800x600 and the problem returned. I need VGA for my TV because HDMI requires underscanning which really messes up the image quality. Please PLEASE help if you know a solution.
  10. AMD Radeon problems DP4

    @ RN95 and jmacie, glad I could finally help someone out.
  11. Asus P8P67-m Pro DP4 guide

    Sorry. I did not realize that i was not allowed to mention that site. I am trying to delete it, until I can rewrite without those references. I can't find a delete option, so please delete it if you need to. EDIT: All done. Thanks.
  12. I have just successfully set up Mountain Lion DP4 on my Asus P8P67-m Pro and decided to share what I found with the community. I used a patched version of the latest BIOS (3602) along with the DSDT and SSDT for that version. A modified BIOS is not necessary but should help with speedstep and sleep, and NullCPUPowerManagement will no longer be needed. By using this method I have gotten everything working except sleep (but its close). I found all of this information here and on other forums. I am in no way claiming any of this as my own work, I am simply bringing it all together in one place. Things you will need: A working install of OSX Lion or Snow Leopard A spare USB flash drive, USB hard drive, or internal hard drive (at least 8GB) A copy of Mountain Lion DP4 (Please don't ask me for it. I'm assuming you are a registered developer) Lnx2mac ethernet driver (get it here http://lnx2mac.blogs...osx-driver.html) A mountain lion compatible chameleon boot loader (get the pkg here) My P8P67-m Pro package (attached file) ​This pack includes (You do not need to download the following list, this is just to give credit): FakeSMC and Plugins (found it here: http://www.osx86.net...nd_plugins.html) DSDT for patched 3602 from samisnake Patched BIOS 3602 (not sure who patched it, but i found it here P8P67-M-PRO-ASUS-3602_modified.ROM) Kext Wizard by Janek202 (found it here http://www.insanelym...howtopic=253395) Installing the new BIOS (DO THIS AT YOUR OWN RISK!! I AM NOT RESPONSIBLE FOR BAD BIOS FLASHES) 1) In your existing Lion or Snow Leopard install, replace your existing DSDT with samisnake's DSDT from the download package. 2) Remove NullCPUPowerManagment.kext from S/L/E. 3) Use Kext Wizard to repair permissions. In maintenance section check "System/Library?Extensions". This should automatically check the two sub entries as well. Choose the target disk, it should be the Lion/SL install you are currently in. 4) Install the new BIOS. I did this by putting the BIOS ROM on a flash drive and booting into the flash utility. *****FLASH THE BIOS TWICE****** I'm not sure why this is necessary but according to Asus, IT IS! If you do not do this zombies will eat you. I updated from the flash utility, then rebooted. The system forced me finish the flash, then rebooted again. I then repeated the whole process. No zombies. 5) Reboot as normal into your Lion/SL install. Creating your Mountain Lion installer and installing. To do this I followed eep357's guide from right here on insanelymac: http://www.insanelym...dpost&p=1826183 "My super fast easy method requires you don't install to MBR and that you have a hard drive with chameleon on it already that is new enough revision to boot ML. first, make empty partition available for installing onto on guid only drive, hfs+ formatted. RT click install ML app, mount InstallESD.dmg, navigate to basesystem.dmg and mount it. restore basesystem.dmg from ML install app(to usb or another small partition) via diskutility. Eject basesystem.dmg so u dont get it mixed up with new restored one as it will have same name. [delete packages alias in System/Installation on the new USB drive] Fire up ye mighty terminal and go to bash shell with:sudo -s then copy packages folder from installESD.dmg to System/Installation/ on your newly restored usb like this:cp -R (drag packages folder here) (drag installation folder from usb here) give it a few minutes to finish then do the same copy technique, but this time for mach_kernel from InstallESD.dmg to / of new usb:cp -R (drag mach kernel here) (drag entire usb installer volume here) and done with terminal-yay create /Extra folder on usb and only put in your smbios and org.chameleon.boot.plist, leave your DSDT out use kext wizard to install fakesmc and nullcpupowermanagement [not needed if you used the patched BIOS] to s/l/e on your usb drive, then use kext wiz repair and rebuild cache options reboot as normal, do not change boot drive in bios. At your normal chameleon prompt, choose instead to boot to your new installer (OSX Base system) and use boot flags -v add any other bootflags you normally use that are not already in your org.chamleon.boot.plist install DP4 and reboot back to your old OSX. From there use kext wiz again to install fakesmc to your new DP4 and any other kexts you know are required to boot and copy /Extra folder from installer to your completed installation. I still didn't put my DSDT in it yet reboot, and this time from chameleon prompt choose new OSX DP4 and have fun. Should always use -v to boot until your install is rock solid (with dev preview just always use it)." Thanks, eep. Some notes: My copy of ML was a .dmg file, not an .app file. If you have this, mount the dmg. BaseSystem.dmg is a hidden file at the root directory. You will need to show hidden files. In terminal type "defaults write com.apple.finder AppleShowAllFiles TRUE". Return. Then type "killall Finder". Return. To unshow the hidden files do the same thing but use "FALSE" instead of "TRUE". The packages folder that needs to be copied is also in the root of the mounted ML installer image. I needed to use boot flag PCIRootUID=1 to boot the installer disk, and the installed ML. Installing P8P67-m drivers Once into your new Mountain lion install: Install the chameleon boot loader from the P8P67-m Pro Pack Use Kext Wizard to install all kexts in the P8P67-m Pro Drivers folder of the pack. You can drag multiple kexts into kext wizard. (IOAHCIFamaily.kext is patched for TRIM support and only needed if you use an SSD) Install the Lnx2Mac driver if you need ethernet support Copy the DSDT and SSDT to /Extra (Use the SSDT that is appropriate to your CPU). Add kernel flag PCIRootUID=1 to the boot.plist in /Extra Reboot. You should now be able to boot directly from your new ML install. If you want hardware monitoring such as CPU frequency and temps, use Kext Wizard to install the fakeSMC plugins that were included in the P8P67-m Pro Package. I used ACPISensor and IntelCPUMonitor. Others may be needed depending on what hardware you have and want to monitor. Of course you're on your own for video cards and other hardware. I use an ATI 5750. If you want to see what i did with that, check it out here: http://www.insanelym...dpost&p=1826652 P.S. This is my first guide, so please let me know if there's anything i need to fix. I hope it helps someone. P8P67-m Pro Pack.zip
  13. AMD Radeon problems DP4

    Installed DP4 with little trouble, but i'm still having this graphics issue. Basic low res was working out of the box, then I added my dev id to ATI5000Controller (68be, ati 5750). I've got full resolution but no QE/CI. I tried also adding my dev ID to the AMDRadeonAccelerator.kext just as a guess. No effect. Any more ideas? I remember the days when Mac OS would scale down the eye candy for machines without QE/CI. Now it just laughs at you. Just FYI, I first tried to use my ATI5000Controller from 10.7 since the dev IDs were already there and it worked so well in Lion. Doesn't work. 10.8 requires a newer driver. Second that. How did you fix it? I'm not trying to be rude, but it really helps no one when you say you found a solution, but then don't share it. EDIT: SUCCESS Adding my devID to AMDRadeonAccelerator.kext did the trick. I made a noob mistake the first time and put it in the wrong section. There are many sections in the info.plist which have devIDs. Be sure to put yours under the correct family of card. For example, my card is a 5750 which is a "juniper". If you do not know the family of your card check wikipedia. In short, your devID needs to be in the controller kext (e.g. ATI5000Controller.kext) and in the correct section of the accelerator kext. (5/6xxx cards use AMDRadeonAccelerator.kext, 4xxx cards use ATIRadeonX2000.kext) If you cannot boot to the OS, try booting to your working Lion or SL install. Copy over the kexts that need to be editied, edit, then replace them using kext wizard. Hope this helps someone.
  14. Well, now the other two are having the same issue, so its beginning to look more like a network/router issue. I think i'll put this problem on hold for now...
  15. Still the same symptoms with manual IP. I am able to connect to the wifi and internet just fine. Its only local networking that has any problems. Right now when i go to network 0 computers are listed. I have one other hack and one real mac in the house. Both show up sporadically throughout the day. Usually not at the same time. iTunes just saw my iPhone as a remote long enough to enter the passcode, but now its gone again. This is really bizarre. I have no problems at all with internet, iCloud, etc.
×