Jump to content

zsero

Members
  • Content Count

    17
  • Joined

  • Last visited

About zsero

  • Rank
    InsanelyMac Protégé
  1. zsero

    Lenovo ThinkPad T420 with UEFI Only

    Hi, I'm trying to install this on W520. I have a few beginner questions: 1. What should I use for the 1920x1080 panel? 2. Should I use UEFI or MBR? Which one is more reliable? I have a separate hard drive for OS X, so I don't need to dual-boot Win 7, I can just select from BIOS / F12.
  2. zsero

    DSDT Auto-Patcher

    1000x thanks! I thought send me means PM.
  3. zsero

    DSDT Auto-Patcher

    I have just a quick question: I have an Asus Maximus Formula (1403 BIOS), but I have almost all the integrated peripherials set to Disabled in BIOS: - Audio is disabled - Firewire is disabled - both Ethernet Controllers are disabled - JMicron PATA is disabled - ICH9R is in AHCI mode The only thing I have in the computer is a GeForce 9600M card, everything else is connected by USB. Shell I just use the script as is? I mean, some of the fixes are for audio and ethernet, what I don't have. What's the best way to have an almost vanilla system in my case?
  4. Hi, I would be happy to help you in any beta testing! I dig into it yesterday and here is what I found: There is a History.txt file in the DMX6Fire folder, which starts like this: /*============================================================================= FILE: History.txt ------------------------------------------------------------------------------- DESCRIPTION: PHASE 88, EWS88 MT/D, EWX 24/96 and DMX6fire Driver History (WDM) DATE: 31-Aug-2007 ------------------------------------------------------------------------------- COPYRIGHT: (c) 2000-2007, TerraTec Electronic GmbH. All Rights Reserved. =============================================================================*/ Even if the drivers are different they couldn't be so much if the they were compiled from the same code tree. Something more important, a part from an early DMX6Fire driver: [TerraTec] %DeviceName_TTP7%=TTP7.Device,PCI\VEN_1412&DEV_1712&SUBSYS_1138153B ;%DeviceName_TTP7%=TTP7.Device,PCI\VEN_1412&DEV_1712&SUBSYS_1138153B&REV_02 ;FMB TEST: allow 88MT to load this driver ;%DeviceName_TTP7%=TTP7.Device,PCI\VEN_1412&DEV_1712&SUBSYS_1115153B 3. point is that all the differences in ews.c from ALSA package doesn't seem too complex (from what I understand just some different registers for initializing different parts, but that code didn't look like some complex chip controlling thing). BTW I could install the Phase88 driver in Windows using inf modding, and the driver starts, but the volume control (in control panel) is greyed out in the same way as it is in OS X. I will see what does ASIO say about that, maybe the channels are just remapped somewhere. UPDATE: Using a simple dev id modding, the EWX 24/96 driver works fine with a DMX6Fire under XP! The volume control is greyed out, but everything works as it should!
  5. Can you help me installing or modifying the Envy24 driver for my Terratec DMX 6Fire sound card? It's almost the same as M-Audio AudioPhile 2496 or the big Terratecs or any other Envy24 based card. I run the installer of 0.21 under 10.6.2 and since I have installed it, Envy24 driver appeared in the sound settings, I can see a greyed out volume control, and I hear a tick from the speakers during startup. But no sound playing. There was even a tick during the install process. Write me what kind of informations are you interested in and I will capture and upload them somewhere! Thanks!
  6. How do you test VRAM? Is there such a thing like Memtest86+ for VRAMs? Do you say the only option is to take it to a repair center? Owning a Mac in Eastern Europe is not such a fun as it could be in the USA... I will see what I can do, but it will be a long long time waiting for the repair.
  7. I have an aluminium iMac 24" on which I use clean XP SP3 via BootCamp with the newest BootCamp drivers. I have built PC's in the past years, but this EFI and BootCamp world is so strange for me, that I really don't know if I am facing software or hardware error. On a PC I would be 100% sure, that it's overheating and/or motherboard/RAM problem, but on a mac, I am not that sure. So the problem is the following: after a while, randomly the screen goes to rainbow color, with 50% opacity where you can barely see what's behind the rainbow overlay, but if you try hard you can move the mouse, with Alt + F4 you can close programs, the whole screen just gets a huge rainbow - overheating-overclocked like artifact. This is an issue since I got the computer, but after restarting it always got back to normal. I tried ATITool overclocking for one hour, but it didn't produce errors after restarting. Like it's happening one hour after I cold-start the computer every morning on about 2-3 days a week. But slowly it went worse and worse. Every day, I got stranger and stranger BSODs, always with some heavyweight XP kernel files, not small driver modules, memory errors, segmentation faults, etc. On a perfectly clean, untouched XP SP3 install, with nothing but Boot Camp 2.1 drivers installed. Now I try to reinstall XP, but I don't really hope it works. I will see what happens for a 48 hour memtest but I didn't have the time to do it. All the programs I use are on XP, and I simply cannot play all day in OS X to test if there is any problem or not. I did an EFI 1.3 update, maybe it helps something. Do you think such rainbow colored display problems (fixing with a restart) and segmentation fault BSOD could be software errors on a clean installed XP SP3 with BootCamp drivers, or I shouldn't even try reinstalling the XP, I should take it for a repair? Actually repair is not such a fun in my country, you have to pay for every part they need to test and sometimes you have to wait up to 2 months, thats why I am upset about taking it for a repair.
  8. I installed XP and I use it daily using Boot Camp on a real iMac. I do not use OSX for any time, it just wastes disk space for me. Is there any way to remove it? Like writing 0s on the drives MBR and booting into a XP install CD? Or it wouldn't work at all? My biggest problem is that I cannot use any drive imaging/partitioning program in windows or in BartPE CD mode, because none of them support the mac partition table. Can I convert a real mac into MBR?
  9. If you want to resize your already installed osx partition I found a great guide at ubuntuforums.org As you may know there are some disk partition utilities for mac iPartition and VolumeWorks but they are using non-PC standart partition tables, so we cannot use them. On the windows side, there are very good utils too, (Acnoris, Partition Magic and many freewares) but they only show you id=af for osx drives. Ubuntu on the other hand is a linux distro which is compiled for x86 and PPC too and has read-write hfs+ (osx drive format) support. the original guide is here: http://ubuntuforums.org/showthread.php?t=89960 A. osx part 1. using either the install DVD's console or a working osx's console disable journalling (you can enable it after resize) sudo diskutil disableJournal \dev\disk0s1 //replace disk0s1 with your partition 2. shut down osx B. linux part 1. You need an Ubuntu live distro. There is no Ubuntu Live CD, there is only one cd for installing and for live booting. So grab the newest Ubuntu for "Desktop PC" at http://www.ubuntu.com/download . Just to prepare yourself its a 700 MB ISO file. 2. burn that iso and boot from that cd 3. it asks you 6 options, you need to select the 1. and boot ubuntu 4. after it has booted go to applications\accessories and select terminal 5. type "sudo parted /dev/sda" if your osx partition is on a SATA disk, "sudo parted /dev/hda" if you are on a PATA disk 6. type "print" If everything goes well you get a list about your partitions on that drive. Try /dev/ sdb, sdc, hdb, hdc if you got nothing back 7. type "resize" it will ask you for partition do you want to resize, answer the partition's number you just got from the print command you need to answer for the beginning and the end of partition space, if you are not sure, just imagine your drive from 0 GB to x GB and partitions on that from a GB to b GB. Now that asks you for a and b. 8. wait until it completes (it was 5 minute for me but if your drive is full it might be about an hour. quit. 9. use fdisk to set your partition id to "af" sudo fdisk /dev/sda (same as before) type p to print partition table type t asks for partition number: same as before new type: af 10. make it active: use b to toggle partitions boot flag until only one has a flag to boot 11. write partition table: type b 10. you are done, reboot
  10. zsero

    how can I delete .kext's

    Many users having problem after installing the new JaS 10.4.8 and running into kernel panic or "please reboot now" screens have to delete some kext's because loading them makes the system crash. In my case I couldn't boot even in -s mode! So the solution, with cooperation of the irc channel:
  11. Thanks for the info, it was not the permissions (i did it like it was written here), the error was I left an empty line at the end of the file! Now that I deleted them it works flawlessly!
  12. What's your final solution for getting audio to work? I have a IBM T60, I just patched the kext using default values, but no luck. It says: 2006-11-11 00:52:16.119 kextload[259] CFLog (0): CFPropertyListCreateFromXMLData(): plist parse failed; the data is not proper UTF-8. The file name for this data could be: (UNKNOWN) The parser will retry as in 10.2, but the problem should be corrected in the plist. 2006-11-11 00:52:18.318 kextload[259] CFLog (0): CFPropertyListCreateFromXMLData(): plist parse failed; the data is not proper UTF-8. The file name for this data could be: (UNKNOWN) The parser will retry as in 10.2, but the problem should be corrected in the plist. can't add kernel extension AppleAzaliaAudio.kext (not a bundle) (run kextload on this kext with -t for diagnostic output
  13. I need to delete IOPCCard.kext, because it gives me kernel panic during loading! I only have a dvd console to use. What can I do?
  14. I've just followed that guide ( http://forum.insanelymac.com/index.php?showtopic=11339 ), but the disk utility actually screwed up my one and only HDD's partition table, so I am not happy at all. I am trying to recovert it from nothing, but I don't know if I can find any working app/solution that can do it for me. The error message was something like "can't read partition table" then I tried the partition disk tool (following an advice from the irc channel!) and locked those small locks at the bottom left corner, and after that the partition tool quit with "invalid arguments". At that time, all my partition table was lost! Do you know any possible solution to recover my partition table, and IF I can do it, what do you suggest me next time I try to install OSX, what tool/swithces shell I use?
  15. I've just followed that guide ( http://forum.insanelymac.com/index.php?showtopic=11339 ), which was said to be compatible with 10.4.8 but the disk utility actually screwed up my one and only HDD's partition table, so I am not happy at all. I am trying to recovert it from nothing, but I don't know if I can find any working app/solution that can do it for me. The error message was something like "can't read partition table" then I tried the partition disk tool (following an advice from the irc channel!) and locked those small locks at the bottom left corner, and after that the partition tool quit with "invalid arguments". At that time, all my partition table was lost! Do you know any possible solution to recover my partition table, and IF I can do it, what do you suggest me next time I try to install OSX, what tool/swithces shell I use?
×