Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Just Joined
  • Content count

  • Joined

  • Last visited

About Otakhan

  • Rank
    InsanelyMac Protégé
  1. Hello. Sorry for the "UP" but I think that should help some people. like digitalb0y, I couldn't get my PC-Keyboard back to normal in windows XP after installing the old bootcamp (1.1 I think) [i use this bootcamp because it fit me/my use of the Mac Pro] So If found this Topic, and read about the regedit stuff, and after 1hour of search, I finally found a weird solution : 1.0 - search and destroy : anything named "keymagic" in /Windows/* directory [i found 2 folder "002" and "003" contening the same files : keymagic.sys keymagic.inf keymagic.pnf and a folder i386, I deleted all of them including the folder.] 2.0 - go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts" (not Keyboard Layout, but the one with the "s") you will see a lot of folders, their name starts with three zero like : "00012345" or "00056789" ; Do not delete them. you will also see at the end, Folders begining with a "A" like : "a000748" or "a015486"; Delete them all. (there was 6 folders in mine) 2.5 - here the funny part : I was also trying a solftware called "Sharpkeys 1.1" who was remapping my keyboard and writing in the registry ... I was creating some keyboard mapping with the software... and I rebooted. So I dont, really dont know if this software has done something too... while rebooting... Just try without it 3.0 - So, you rebooted, and should works.. I dont know because I was having a last probleme : I'm a AZERTY Keyboard user 3.5 - now there is a high probability that you keyboard turned in to Qwerty; but is really simple to fix this : just go to the "Control Panel" > "regional and language options" > "Language" Tab > "Details..." button> * clic "add.." * choose your country * choose keyboard layout * clic OK now you should have 2 set of layout * From here I rebooted * delete the US layout (qwerty) and finally back to normal... huff ! ... --- I'm also sorry for the english, I'm not US nor UK hope that post help someone