Jump to content

hotcorez

Members
  • Content count

    111
  • Joined

  • Last visited

  1. Maybe you should try to re create the same graphics issue on intel by disabling things in the kernel until you identifiy the feature that is not working? A different approach
  2. re bluetooth, i would say that something may have changed in the graphics drivers. your framebuffer (amd) or nvcap (nvidia) are wrong for this os or it is another graphics acceleration issue. fixed bluetooth error once on nvidia by removing the nvcap from dsdt and enabling injection to find the right one. in my case, something had changed from 10.8-10.10. good luck! hope at least it will give you some ideas.
  3. Hey. the clock problem sounds like the fsb is set incorrectly. note: cpu fsb and pci bus speed are normally linked unless you can lock/set the pci bus speed manually (impacting connected devices) did you try clover, it auto detects fsb well. maybe you just need to set your fsb manually with your current bootloader / kernel configuration? hope you work it out! btw incredible work here guys!
  4. Would it be possible to make a monitoring kext+app and/or kernel mod for the opemu so that you can get more output from it? Im no expert but it might make it easier to debug. If you could compare the output between intel and amd machines when the real and emulated instructions are executed, maybe it could help alert you to issues? no idea how this could be implemented or if its possible to do this already in software
  5. try disable your graphics injection in bootloader and use dsdt only. it should work if you set it correctly did you also fix the pci0 section? like this on an old intel board : Name (_CID, EisaId ("PNP0A03")) // _CID: Compatible ID Name (_HID, EisaId ("PNP0A08")) // _HID: Hardware ID Name (_UID, Zero) // _UID: Unique ID saves setting pcirootuid
  6. ouch! what will amd users do without you! i appreciate what your saying about macos not necessarily improving, bugs, slower boot times after almost every new release (how fast was leopard!!) alot of good people have moved on from osx and after looking at benchmarks between macos and linux i can see why however, lets hope that your curiosity with macos will get the better of you again sometime! all the best anyways, good to have skilled coder on board at any point in time! good luck with bitcoin stuff! cheers ps. not so much can be done without sourcecode anyways! ......
  7. Well done people for getting this far. Maybe some decent cpu tsc code to fix the old k8, k10 and other quirky cpus could be developed while you wait for the source code? i am not aware of a proper kernel implementation (like linux/bsd) for this yet I cannot code this myself but i am confident that some of you might be in a position to contribute to this thanks some hopefully useful and interesting links http://freebsd.1045724.n5.nabble.com/TSC-Timecounter-and-multi-core-SMP-td3909368.html http://fxr.watson.org/fxr/source/amd64/amd64/tsc.c?v=FREEBSD8 i see tsc.c dissappeared maybe in freebsd 9?
  8. ah, i missed the great work here! thanks for pointing me in the right direction. could the addtional voodoopower system file dependancy be removed by clever coding or patching in clover for instance?
  9. Awesome work guys! Now all that needs to be done is to integrate the various voodoo tsc kext based fixes into the kernel to support procesors that require it and job done! Congrats again to all involved ps. does anyone know if voodoopowermini will work with this kernel or does it need to be rebuilt? thanks
  10. hotcorez

    Clover General discussion

    Yes. Thanks again. I did replace the file as you suggested into /EFI/CLOVER to update it to 2235 so no idea why that wouldnt work unless it was the wrong file or maybe I just needed one of the optional drivers i just installed? no idea but it's great to have the latest release working on 10.6 !
  11. hotcorez

    Clover General discussion

    Thanks for your detailed reply Pene. I downloaded the installer for 2236 and tried to update my existing clover installation. This failed so i backed up my kexts, config and acpi and did a fresh install, selecting all the extra drivers in custom install as well as the af bootloader install option. 10.6 boots fine now so i suspect this problem is fixed in 2236. Great work! Thanks well the wiki page needs updating to include kext injection. in the meantime download mackie100's clover configurator and select the options that apply to you
  12. hotcorez

    Clover General discussion

    Hi Pene. I just replaced the CLOVERX64.efi with the one you provided but unfortunately still cannot boot 10.6.x in 64bit mode (only one i tried) However, i did make a note of the error messages this time, which may have changed now. Im now only getting invalid magic number on VoodooPS2Controller.kext. The kozlek fakesmc (including plugin kexts) try to load but say "failed to load library dependancies" so i assume the injection is still having problems and cant see the main extensions folder or something. I hope this helps. Please let me know if you need any more information. Thanks
  13. hotcorez

    Clover General discussion

    Thanks for your work Pene. Ill try this later when i get a chance!
  14. hotcorez

    Clover General discussion

    Hi Pene, Thanks for testing this out for me. I have been booting with arch=x86_64 and have not tried i386. I will wait to see if the problem can be nailed down before trying anything else. I appeciate your help to debug this and looking forward to the results of your investigations!
  15. hotcorez

    Clover General discussion

    Thanks Pene. I know there is absolutely no problems with the kexts as the same configuration works perfectly with chameleon as well as an older version of clover, so i firmly believe this is clover fault. unfortunately i did not generate a log but do not wish to try it again until the problem is fixed/resolved as it might mess up my disks. please can anyone else try booting 10.6? thanks
×