Jump to content

mulletman13

Members
  • Content count

    80
  • Joined

  • Last visited

About mulletman13

  • Rank
    InsanelyMac Protégé
  1. [GUIDE] Thinkpad T420 with (Mountain) Lion

    Sounds good. I finally got the main OS installed to MBR with an appropriate (and loading!) boot loader. Using the DSDT from the first post results in a kernel panic; likely as a result of the Optimus video switching. Does anybody have one available for T420 that only have the integrated graphics option? My last hurdle would be to get sleep working, and as it runs without a DSDT and with the IntelPM patch, it seems to almost enter complete sleep, but not quite. I imagine the USB power level change would be all that I'd need, I just don't know how to only use that part of the DSDT. Wow, so I didn't realize that DSDT patching was quite easy with standard chipset patches. In any case, if anybody else has a T420 with only integrated graphics, I attached the DSDT I made that lets the computer sleep and enables brightness. Keep in mind that ApplePowermanagement will need to be patched as per the first post as well. T420DSDT.aml.zip
  2. So, first off, here are the specs: i5 2520 at 2.5ghz Intel 3000 Graphics Lenovo T420 I'm tearing my hair out at this point, as I've tried the following installation methods: [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] with both 10.7.2 and 10.7.0 Lion App (this results in a USB Bootable drive, however Chimera loads to a boot0: test, boot0: error) Additionally, when booting with Chimera on the USB drive I installed with, once OSX loads it does not see that drive. If I unplug that drive, there is an instant kernel panic. Lion ESD to USB Drive with Chameleon and Extras folder installed (this resulted in a DSMOS Has Arrived standstill any time I would try to load the disk.) The Lenovo doesn't even recognize the drives when it is partitioned via GUID, so I use nawcom's MBR patch method. Here is the guide I was following: http://www.insanelymac.com/forum/index.php?showtopic=268280&st=0 The most infuriating thing, is that I've installed Lion on a couple of computers already, edited DSDTs and various things, and for the life of me, I cannot get a bootable Lion drive on this computer. I just installed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] on 10.7.2, and now I get several lines pointing to errors in AppleUSBEHCI, leading to an unbootable installation. I'm at my wits end, and have tried to contact several people in the above post, only to hear no response. I suspect there is some sort of issue with my BIOS that I'm using, as it seems to force me to use UEFI and Legacy Bios. Also, it's quite off putting that nobody in that topic seem to be having any installation issues in the slightest. I would truly appreciate any possible help. Thank you!
  3. [GUIDE] Thinkpad T420 with (Mountain) Lion

    Finally got 10.7 to install, but when I reboot I get a KP regarding the AHCI or something talking about the USB. Was the original method using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or was it done with a retail install followed by using Lion Extra packages? Any information would be appreciated.
  4. [GUIDE] Thinkpad T420 with (Mountain) Lion

    Any updates/progress? I just purchased a Thinkpad with a 2520 i5 and integrated graphics; I'm mainly just looking to get QE/CI, sleep, and speedstep working. I'm a little hesitant to update/modify the BIOS, but it seems pretty straightforward? Edit: Sorry, I'm mainly looking to see if the brightness of the screen can be controlled in System Preferences, or if any progress was made on getting the Brightness/Function buttons to work.
  5. Attansic L2 Driver

    Found a 64 bit compiled version that does not crash Lion, but seemingly randomly the internet will drop out and will only be remedied with a *complete* restart. I'm using a WDS setup, but it seems like whenever I am torrenting something it will randomly cut off. Anybody have input?
  6. Strange issue in Photoshop

    Hey all, I have a pretty stable build/installation of Lion, but I'm having a strange issue with Photoshop. QE/CI works well on my system with an injected ATI driver; I'm curious if this is causing that. I have not seen any other sort of artifacting or wrong colors appear anywhere else; even in other Adobe apps. Here is what I'm seeing: The background is supposed to be grey, and the text and filled box are both black. Is there a bug in the software, or is it likely related to hardware acceleration in my graphics card? Any help or suggestions would be appreciated.
  7. 512mb 9400GT Boots into a white screen

    After adding my device ID to NVCDANHal50.kext, and setting 'GraphicsEnabler=Yes', the machine gets through the verbose boot cycle, only to arrive at a completely solid white screen. I have not seen anybody else having this issue; what could it be related to? Also, does NVEnabler require GraphicsEnabler=Yes to be loaded? After adding dev ID to the kext files, I installed NVEnabler in the Extras folder and it was not loaded. Hrm? Update: Here is (seemingly) the problem NVEnabler is running into.
  8. Basic guide about nVidia kexts

    Any update on Lion? NVDAResman does not have the IOPCIPrimaryMatch key; although NVDANHal50 does. When I start up with the devID in NVDANHal, they both show up under loaded extensions in System Preferences, but I still do not get a recognized video card. I also installed NVEnabler 64 but it doesn't seem to be loading on the machine. Any reason as to why this is not loading alongside the included kexts?
  9. Attansic L2 Driver

    Does anybody have any updates on this? I have the Asus P5GC MX-1333, and I saw there is an AttansicL1 driver for the P5GC MX, but not the 'updated' model. The current driver works for 32bit, but seems to crash Lion upon boot. I'd appreciate any information.
  10. 512mb 9400GT Boots into a white screen

    Hey all, Installed a completely vanilla installation of 10.7, and am running one giant snag. Whether I use NVEnabler, GraphicsEnabler=Yes, or an EFI string, I receive a white screen with absolutely no response or cursor upon boot. I am hooked up to my card via DVI. Does anybody have any advice on where to proceed from here? Nearly all of the tutorials/tools are 10.6 specific, and I'm unsure on what will work with 10.7. The card worked perfectly up until 10.6.8. Thanks!
  11. [GUIDE] OSX Lion on non-GUID (works on final too)

    Hey all, I get to the select language part of the Lion installation, then after I select the language, it seems like the installer kills all processes and shuts down the machine. Might this have to do with OSInstall.mpkg finding something wrong? Or does it have to do with a hardware issue? kext loading now disabled Kept unloading now disabled Kept auto unloading now disabled Kernel requests now disabled Com.apple.launchd Syncing disks.... Killing all processes Continuing Done CPU Halted Any help would be wildly appreciated.
  12. Hey all, So I started out with a fresh vanilla GPT single partition of OSX. Then, I installed Windows 7. To be able to boot back into my OSX drive, I used a utility GPTSync to 'fix' the partition scheme. Since then, whenever I boot I get a couple of EBIOS Error 0x01 (this affects nothing, I am able to reach chamelon and boot normally). Now, when I'm trying to update to Lion, DU claims my drive is MBR. I'm running a program called gdisk (http://sourceforge.net/projects/gptfdisk/), which claims to change the partition table from MBR into GPT, however it is claiming that my drive and partitions are GPT. I would appreciate any sort of guidance on where to go from here. I'm really not looking forward to a complete wipe of two partitions; but if I must, then I suppose I will. Any information is very much appreciated. Here is the output that gptsync puts out: bendall-pc:dev bendall$ sudo gptsync disk0 Password: Current GPT partition table: # Start LBA End LBA Type 1 40 409639 EFI System (FAT) 2 409640 855877927 Mac OS X HFS+ 3 875468800 976773119 Basic Data Current MBR partition table: # A Start LBA End LBA Type 1 1 409639 ee EFI Protective 2 409640 855877927 af Mac OS X HFS+ 3 875468800 976773119 07 NTFS/HPFS 4 976773120 976773167 ee EFI Protective Status: Tables are synchronized, no need to sync. .... so there are two partition tables? I don't necessarily follow.
  13. USB 1.1 speeds on Asus P5GC-MX/1333

    In case anybody has this issue in the future: Try to AppleHPET.kext, in combination with disabling Legacy USB. Disabling Legacy USB does not work by itself, the HPET needs to be removed.
  14. Hey all, Vanilla install here. Used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to install with a retail disk, and currently on 10.6.5. VoodooHDA enabled sound, [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] enabled my 9400gt graphics card. The only issue I'm having is USB- the max speed is 12mbps. I'm transferring my 120gb music library over, and would prefer not to wait twelve hours on this. I have not created or patched a DSDT or anything, but can give more information if requested. Thank you for any possible help. PS: I installed the 10.6.2 USB Driver rollback, but it did absolutely nothing. I've had this machine a Hackintosh before, and USB worked just fine with it.
  15. Do you have FakeSMC.kext loading up anywhere? I had a few problems until I put that in S/L/E. Additionally, what SMBios are you running? As for my problems-- I realized (and probably skimmed over this fact in this thread) that IntelCPUManagement alone works for speedstepping, and VoodooPower is completely unnecessary, as it makes the CPU run even hotter. I'm really trying to get Voodoops2Controller.kext to load, but it does not load at startup or anything. ApplePS2Controller and ACPInub don't show up in loaded kexts either... so I'm a bit curious as to how my mouse is working already, and why voodooPS2Controller isn't working. It seems that it's a pretty widespread project... can somebody please post one that works on their system, and gives two finger scrolling?
×