Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

pnoytechie

Members
  • Content count

    29
  • Joined

  • Last visited

About pnoytechie

  • Rank
    InsanelyMac Protégé
  1. Enoch

    I have two HDDs with El Capitan (one is for testing, while the other is for work related stuffs). Both are drives are GPT and being booted by Clover. Let's call them "Workd Drive" and "Test Drive". Current Clover configuration is in ESP of Work Drive. I want to test something in Chameleon, so I started El Capitan in my "Test Drive". Fired up Enoch installer. In Enoch window, under "Chameleon Bootloader", I chose "Install Chameleon in ESP", since I have GPT drive. All went fine. Restart. And I can select and start both Work and Test drives using Chameleon. But if I boot Clover, in Clover screen, my "Test Drive" is no longer there. What happened? How can I bring back my "Test Drive" to be bootable with Clover? Thanks!
  2. Atheros AR9285 fix for Snow Leopard - Mavericks

    thanks for all those who tried to help me, esp. juanerson and LatinMcG. but no matter how i tried (i can no longer count how many), my setup cannot detect the device with DSDT injection. i ended up just editing the Info.plist of AirPortAtheros40.kext and this one worked (150mbps), even AirDrop, even though it just shows as "Wi-Fi" (not AirPort) thanks again.
  3. Atheros AR9285 fix for Snow Leopard - Mavericks

    thank you very much juanerson. i haven't tried it yet, but i will when i get the time. so you mean to say that this DSDT patch for AR9285 will not work without the devicemergenub? thanks again, appreciate it.
  4. Atheros AR9285 fix for Snow Leopard - Mavericks

    I've been trying this. But I'm not good in DSDTing Could anyone tell me how to put this correctly in my DSDT? I'm using ASRock Z77 Extreme4 board with i5 2500k. Atheros 9285 card is TP-Link TL-WN781ND v1. I extracted my DSDT (using DSDTE/DSDT Editor), but when I tried to integrate the DSDT code (from page 1), IASL gives me errors (18 errors to be exact). Could anyone tell me how to correct this? here's the original, unmodified DSDT from my board: dsdt_stock.txt here's the version after I inserted the code in page 1: dsdt_modded.txt and here goes the IASL compilation log, with 18 errors: iasl_log.txt RP07 is where the card is plugged in, as shown in IOReg: Anyhelp will be greatly appreciated. Thanks in advance!
  5. [HOW TO] Pin Config!

    Hi. I attempted to try this... but, there are several configData in the plist file of AppleHDAcontroller.kext. I'm using PlistPro... as shown here: can you tell me what exactly needs to be replaced? thank you very much age_sabres18
  6. GMA X3000 Working with QE/CI/OpenGL/Rotation

    hi theStevo, i really appreciate your effort, thanks for that. however, the last FB file you posted didn't help either. it makes my systems unresponsive... both 10.5.5 and 10.5.4. i managed to get the right resolution (as well as the screen resolution in Display Preferences) in 10.5.5, using ONLY the FB file posted in your first post (the rest of AppleIntelGMAX3100* files are stock 10.5.5), but still my Core Image is software: AppleIntelGMAX3100.kext and AppleIntelGMAX3100FB.kext appeared loaded: mmm... anything else? btw, I've attached the stock AppleIntelGMAX3100 kexts. Just in case you find free time. AppleIntelGMAX3100.zip Thanks!
  7. GMA X3000 Working with QE/CI/OpenGL/Rotation

    10.5.4 - Nov 10 09:02:31 localhost kernel[0]: Jettisoning kernel linker. Nov 10 09:02:31 localhost kernel[0]: AppleRTL8169Ethernet: Ethernet address 00:0e:a6:f4:2f:1c Nov 10 09:02:39 localhost /usr/sbin/ocspd[47]: starting Nov 10 09:02:39 localhost mDNSResponder mDNSResponder-176.2 (Aug 15 2008 14:58:54)[22]: starting Nov 10 09:02:40 localhost kernel[0]: Resetting IOCatalogue. Nov 10 09:02:40 localhost kextd[10]: 0 cached, 401 uncached personalities to catalog Nov 10 09:02:41 mymac configd[35]: setting hostname to "mymac.local" Nov 10 09:02:42 mymac kernel[0]: GFX0: family specific matching fails Nov 10 09:02:42 mymac kernel[0]: Matching service count = 1 Nov 10 09:02:42 mymac kernel[0]: Matching service count = 2 Nov 10 09:02:43 mymac kernel[0]: GFX0: family specific matching fails Nov 10 09:02:43: --- last message repeated 2 times --- Nov 10 09:02:43 mymac /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow[23]: Login Window Application Started Nov 10 09:02:43 mymac kernel[0]: fRegisters at 0x3de98000 Nov 10 09:02:43 mymac kernel[0]: dsmos: Initializing... Nov 10 09:02:43 mymac kernel[0]: dsmos: Hook and decryption contexts set! Nov 10 09:02:43 mymac kernel[0]: dsmos: Starting... Nov 10 09:02:43 mymac kernel[0]: GFX0: match category IOFramebuffer exists Nov 10 09:02:44 mymac loginwindow[23]: Login Window Started Security Agent can log-in connect to screensharing. but it didn't give much info about "Graphics/Display" thru screensharing. I only got this: Kext info:
  8. GMA X3000 Working with QE/CI/OpenGL/Rotation

    here's an excerpt from the systemlog in 10.5.5. can't do remote screen as the system is unresponsive. will try again in my 10.5.4 hard disk... Nov 10 08:36:43 localhost kernel[0]: Jettisoning kernel linker. Nov 10 08:36:43 localhost kernel[0]: Resetting IOCatalogue. Nov 10 08:36:43 localhost kernel[0]: GFX0: family specific matching fails Nov 10 08:36:43 localhost kernel[0]: Matching service count = 1 Nov 10 08:36:43 localhost kernel[0]: Matching service count = 2 Nov 10 08:36:43: --- last message repeated 4 times --- Nov 10 08:36:44 localhost kernel[0]: GFX0: family specific matching fails Nov 10 08:36:44: --- last message repeated 1 time --- Nov 10 08:36:44 localhost kernel[0]: dsmos: Initializing... Nov 10 08:36:44 localhost kernel[0]: dsmos: Hook and decryption contexts set! Nov 10 08:36:44 localhost kernel[0]: dsmos: Starting... Nov 10 08:36:44 localhost kernel[0]: GFX0: family specific matching fails Nov 10 08:36:44 localhost kernel[0]: fRegisters at 0x3dd87000 Nov 10 08:36:45 localhost kernel[0]: GFX0: match category IOFramebuffer exists Nov 10 08:36:45 localhost rpc.statd[30]: statd.notify - no notifications needed Nov 10 08:36:46 localhost bootlog[50]: BOOT_TIME: 1226277399 0 Nov 10 08:36:47 localhost socketfilterfw[52]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35 Nov 10 08:36:47 localhost RFBRegisterMDNS[33]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35 Nov 10 08:36:47 localhost DirectoryService[46]: Launched version 5.5 (v514.23) Nov 10 08:36:47 localhost fseventsd[41]: bumping event counter to: 0xc6d4 (current 0x0) from log file '000000000000b8c8' Nov 10 08:36:47 localhost kernel[0]: AppleRTL8169Ethernet: Ethernet address 00:0e:a6:f4:2f:1c Nov 10 08:36:47 localhost /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow[36]: Login Window Application Started
  9. GMA X3000 Working with QE/CI/OpenGL/Rotation

    hi theStevo, thanks for the suggestions. just to clarify, the black screen in other versions were the screen where it stalled. for newly installed kexts, it's been a habit for me to boot in verbose mode. After long pile of system message/log, it switched to GUI - black, blue, then - black. that's what i meant. the message was something like "... frame buffer exists." i'll capture the exact message... and post it here. thanks!
  10. GMA X3000 Working with QE/CI/OpenGL/Rotation

    hi theStevo, As far as I am aware, i never replaced nor modified the other 3 AppleIntelGMAX3100* files/packages. Here's what I did: Installed a retail 10.5.1 system. Chameleon as EFI. It boots fine. Loads fine. I made a hard disk image of it. So that reinstallation if needed would be easier - just restore from an image. Common steps Remove AppleIntelIntegratedFrameBuffer, AppleIntelGMAX3100.kext, AppleIntelGMAX3100FB.kext from /System/Library/Extensions folder. Install your packaged AppleIntelGMAX3100.kext, AppleIntelGMAX3100FB.kext to /System/Library/Extensions folder using Kext Helper b7. To make sure, repair permissions Per leopard version 10.5.1 - did "Common steps" 10.5.2 - restored base system from ghost image, installed comboupdate 10.5.2, install LeopardGraphicsUpdate, did "Common steps" 10.5.3 - restored base system from ghost image, installed comboupdate 10.5.3, did "Common steps" 10.5.4 - restored base system from ghost image, installed comboupdate 10.5.4, did "common steps" 10.5.5 - restored base system from ghost image, installed comboupdate 10.5.5, did "Common steps" ok then, I was asking if you could post the other 3 AppleIntelGMAX3100* files that you are using, so I could test and hope that it'd work. but seems not. thanks anyways. sorry for the confusion
  11. GMA X3000 Working with QE/CI/OpenGL/Rotation

    hi thestevo... i've tried it in my ASUS P5B-VM but I couldn't get it to work. I've tried AppleIntelGMAX3100GA.plugin, AppleIntelGMAX3100GLDriver.bundle, AppleIntelGMAX3100VADriver.bundle from 10.5.2 Loepard Graphics Update, from 10.5.3, from 10.5.4 and 10.5.5... ALL FAILED. system specs: ASUS P5B-VM with E2140, 2GB RAM, 160GB HDD (SATA Enhanced Mode) Retail Install: 10.5.0 to 10.5.5, Vanilla Kernel, Chameleon EFI 10.5.1 kexts - boots to black screen; keyboard capslock can be turned ON/OF - not hang 10.5.2 kexts - boots to black screen; keyboard capslock can be turned ON/OF - not hang 10.5.3 kexts - boots to black screen; keyboard capslock can be turned ON/OF - not hang 10.5.4 kexts - boots to black screen; keyboard capslock can be turned ON/OF - not hang 10.5.5 kexts - boots to blue screen; hang (keyboard doesn't respond) can you also post the additional AppleIntelGMAX3100* packages from your working system? thanks!
  12. OK, make me a believer

    Try these original steps (from netkas) the next time you update install again with vanilla kernel and EFI. download 10.5.5 combo update run the script (provided in the link above) start the installation of the combo update when installer said it's done, don't restart yet, follow the startup script editing instruction (in the link above) restart NOTE: it won't continue to load the UI in the first OS load. it will try to restart.
  13. 10.5.5 Combo update went fine with my AtomHack (Intel D945GCLF) Used netkas method (for 10.5.2)
  14. Mac OS 10.5.5 Out!

    10.5.5 Combo update went fine with my AtomHack (Intel D945GCLF) Used netkas method (for 10.5.2) Usual issues: * graphics lost resolution adjustment * won't sleep/restart/shutdown properly * inappropriate processor/RAM speed in "About this MAC" Restored the following to resolve the said issues: - modified AppleIntelIntegratedFramebuffer.kext - modified AppleSMBIOS.kext - modified AppleACPIPlatform.kext
  15. if you don't want to download hfsdebug... and you are not command-line savvy, UUID can be obtained using OS X Disk Utility
×